Symantec Ghost 11 / WinPE Drivers for Intel Pro 1000 (82579) NIC in new Lenovo T420s

Posted on 2011-05-02
Last Modified: 2012-05-11
Hey All,

I have a new Lenovo T420s with an Intel Pro1000 NIC that I would like to be able to back up across my network using a USB based Ghost 11.5 boot disk.  This method works fine for other laptops I manage but the problem that I'm running into with this one is that when I boot using the Ghost USB boot disk, the network card in this Lenovo is not being recognized by Ghost/WinPE and does not get an IP address on the network.   The drivers for the Intel Pro1000 network card are not included in the default Ghost/WinPE build so I tried downloading the drivers from Intel's website and including them in my Ghost boot disks, but that still does not work.

Has anyone out there been able to make this work with this NIC or have any suggestions on how I can get this NIC recognized by Ghost?  Thanks!!
Question by:AJ524
    LVL 116

    Expert Comment

    by:Andrew Hancock (VMware vExpert / EE MVE)
    Are you sure that the network drivers you have downloaded are the correct drivers for the Lenovo laptop.

    Have you tried the MSDOS Boot Partition Client and NDIS DOS drivers to see if they recognise the network cards, we've had some issues with WinPE not working with laptops and desktops, and had to revert to MSDOS Boot Partition mode.

    Author Comment

    Thank you for your reply.  

    The OS on the laptop is Win7 and according to the device manager, the NIC is an Intel Pro 1000, version 82579.  I downloaded the Vista driver for this specific 82579 variant of the Pro 1000 from intel's site, so I am reasonably sure that I have the correct driver package.   I also found a version of the same driver on the Symantec forums that were supposedly specifically for this NIC and WinPE/Ghost, but none of this worked.  

    I accessed the drivers from the EXE file by expanding the EXE into a temp directory which showed drivers for the Pro100, Pro1000 and ProXGB (10Gbps).  As this is a Pro1000 NIC, I went into the Pro1000 folder and found the NDIS5x, NDIS61 and NDIS62 driver folders.  I then used the  Ghost Boot Wizard to create a copy of the WinPE-512 image and I added the drivers from all 3 NDIS folders within the Pro1000 driver pack.  I then made sure to put checks in the boxes for all 3 imported drivers so that they were included when creating my Ghost Boot/WinPE image, but in the end, the NIC still did not show up.   I have made various versions of the WinPE-512 boot image including one with every possible driver included in the Ghost Boot Wizard, but still nothing works.  

    Regarding your question about the MS-DOS method... It seems to me that to use the MS-DOS mode in Ghost Boot Wizard I would need to use floppies.  I have an external floppy drive I could make use of if that is the case.  I also see PC-DOS... would the MSDOS drivers work there?    I tried the Linux option via USB and there is no option to add drivers at all, so that's not much help.   Primary goal here is to just get the NIC an IP address either by DHCP or static assigned by the Ghost Boot Wizard.  So far I only get due to WinPE  not recognizing the NIC.  

    Hope this helps!
    LVL 116

    Accepted Solution

    pcdos or msdos will do, symantec are just not licensed to use msdos. i use the term generally, use pcdos, and dos ndis2 drivers, that should work 100%, WinPE, WinPE-512 is unreliable in our opinion, weve had issues with nic and storage drivers, now weve changed to pcdos boot partition, its also much quicker!


    Author Closing Comment

    You are absolutely right about PC-DOS... it worked!  Although I will say that when I attempted to create my own PC-DOS image with the Intel drivers included that failed so I went with the generic.  Thank you VERY much!

    Here's what I did, for those of you who run into this some day...

    Bring up the Ghost Boot Wizard, Select PC-DOS, Select Network Boot Package, Select "Universal Packet Driver v2.0" (Universal driver pack), Select Symantec Ghost, Do not override BIOS firewire or USB control, I then assigned my thumb drives IPs (we prefer statics), select USB, next next next, etc and presto!  Perfectly working USB Ghost thumb drive with PC-DOS and NIC drivers for the Intel Pro1000.

    Expert Comment

    Thanks for your comment AJ524 and hanccocka. It worked for me too !

    Expect for me at the "Select Symantec Ghost" screen, it tries to look for the ghost.exe and by ghost machine only had ghost32.exe and ghost64.exe but not GHOST.EXE

    So I had to basically find GHOST.exe from another ghost server and copy it over. Because ghost32.exe will not work in a 16bit DOS environment.

    Thanks !

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    Join & Write a Comment

    Suggested Solutions

    How to fix error ""Failed to validate the vCentre certificate. Either install or verify the certificate by using the vSphere Data Protection Configuration utility" when you are trying to connect to VDP instance from Vcenter.
    By default, Carbonite Server Backup manages your encryption key for you using Advanced Encryption Standard (AES) 128-bit encryption. If you choose to manage your private encryption key, your backups will be encrypted using AES 256-bit encryption.
    This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
    This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

    734 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now