• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 735
  • Last Modified:

reliance netconnect not working on ubuntu desktop 10.4

Dear Experts:

I have purchased dell vostro 3500 laptop installed ubuntu 10.4 desktop edition , for internet i have reliance netconnect for making this to work installed
libwvstreams4.6-base_4.6.1-1
libwvstreams4.6-extras_4.6.1-1
libuniconf4.6_4.6.1-1
wvdial
gnome-ppp
After installing the above packages and when tried to connect it gets connected able to open the google.com when key in something to search it does not go from this main page, also many pages does not open but able to ping. Please suggest me how to fix this, below posted for your reference.
sudo gnome-ppp

sudo gnome-ppp

WVCONF: /root/.wvdial.conf

GNOME PPP: Connecting...

GNOME PPP: STDERR: --> WvDial: Internet dialer version 1.60

GNOME PPP: STDERR: --> Cannot get information for serial port.

GNOME PPP: STDERR: --> Initializing modem.

GNOME PPP: STDERR: --> Sending: ATZ

GNOME PPP: STDERR: ATZ

GNOME PPP: STDERR: OK

GNOME PPP: STDERR: --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

GNOME PPP: STDERR: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

GNOME PPP: STDERR: OK

GNOME PPP: STDERR: --> Modem initialized.

GNOME PPP: STDERR: --> Sending: ATM1L3DT#777

GNOME PPP: STDERR: --> Waiting for carrier.

GNOME PPP: STDERR: ATM1L3DT#777

GNOME PPP: STDERR: CONNECT

GNOME PPP: STDERR: --> Carrier detected.  Waiting for prompt.

GNOME PPP: STDERR: ~[7f]}#@!}!}!} }8}"}&} } } } }#}$@#}%}&[1b]1}&Y}'}"}(}"P[7f]~

GNOME PPP: STDERR: --> PPP negotiation detected.

GNOME PPP: STDERR: --> Starting pppd at Tue May  3 11:29:03 2011

GNOME PPP: STDERR: --> Pid of pppd: 4477

GNOME PPP: STDERR: --> Using interface ppp0

GNOME PPP: STDERR: --> pppd: [05][7f]

GNOME PPP: STDERR: --> pppd: [05][7f]

GNOME PPP: STDERR: --> pppd: [05][7f]

GNOME PPP: STDERR: --> pppd: [05][7f]

GNOME PPP: STDERR: --> local  IP address 115.241.56.211

GNOME PPP: STDERR: --> pppd: [05][7f]

GNOME PPP: STDERR: --> remote IP address 220.224.141.145

GNOME PPP: STDERR: --> pppd: [05][7f]

GNOME PPP: STDERR: --> primary   DNS address 202.138.103.190

GNOME PPP: STDERR: --> pppd: [05][7f]

GNOME PPP: STDERR: --> secondary DNS address 202.138.117.60

GNOME PPP: STDERR: --> pppd: [05][7f]



Please help.

0
D_wathi
Asked:
D_wathi
  • 6
  • 3
2 Solutions
 
Duncan RoeSoftware DeveloperCommented:
The connection looks fine. Problems with Google may be unrelated. Check that you don't have any firewall rules that might be getting in the way though:
sudo { set -x;for i in filter nat mangle raw;do iptables -t $i -n -v --line-numbers -L;done;set +x; } 2>&1|less -X

Open in new window

Also check that routing is correct:
ip route list

Open in new window

0
 
D_wathiAuthor Commented:
Sir, Thanks for the reply.
ip route list
220.224.141.145 dev ppp0  proto kernel  scope link  src 115.241.94.213


sudo { set -x;for i in filter nat mangle raw;do iptables -t $i -n -v --line-numbers -L;done;set +x; } 2>&1|less -X
bash: syntax error near unexpected token `}'

------------/etc/wvdial.conf------------------------
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
;Modem Type = Analog Modem
Modem Type = USB Modem
Baud = 115200
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
; Phone = <Target Phone Number>
; Password = <Your Password>
; Username = <Your Login Name>
Phone = #777
Username = 7483044621
Password = 7483044621
--------------------------------------------------------------

sudo wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT
--> Carrier detected.  Waiting for prompt.
~[7f]}#@!}!}!} }8}"}&} } } } }#}$@#}%}&+[1c][1b][1e]}'}"}(}"rV~
--> PPP negotiation detected.
--> Starting pppd at Thu May  5 12:10:52 2011
--> Pid of pppd: 1746
--> Using interface ppp0
--> pppd: ¿[7f]
--> pppd: ¿[7f]
--> pppd: ¿[7f]
--> pppd: ¿[7f]
--> local  IP address 115.241.94.213
--> pppd: ¿[7f]
--> remote IP address 220.224.141.145
--> pppd: ¿[7f]
--> primary   DNS address 202.138.103.190
--> pppd: ¿[7f]
--> secondary DNS address 202.138.117.60
--> pppd: ¿[7f]
-----------------------------------------------------------------

# iptables -L -v -n
[sudo] password for  dwathi:
Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination        

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination        

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination

-----------------------------------------------------------------------------------------------------
gets connected when browse can go to main pages and from the main page if we click it shows off line does not go from there on. but the same data card used on windows works fine. Please help to fix this. Thanks in advance

0
 
Duncan RoeSoftware DeveloperCommented:
Looks like sudo stumbled on the curly braces. If you can get a command prompt using e.g. sudo -s, it might be worth re-trying from the "{" onwards.
But you showed your filter table is empty, so iptables may not be the problem.
What does strike me is that you have no default route to send everything through your ppp connection.
To fix this, I would add a line consisting of the single token defaultroute to /etc/ppp/options
Post what's in that file now if in doubt (it shouldn't contain sensitive data)
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 
Duncan RoeSoftware DeveloperCommented:
Personally I never use sudo, so the first post was a bit of a guess. In the absence of getting a command prompt, this might work:
sudo sh -c "{ set -x;for i in filter nat mangle raw;do iptables -t $i -n -v --line-numbers -L;done;set +x; } 2>&1|less -X"

Open in new window

0
 
D_wathiAuthor Commented:
Sir, Thank you very much for the reply, in the /etc/ppp i can find two files
1, options
2, options.ppt

please find the attached two files options and options.ppt and request you to suggest me what changes to be done so that the problem is resolved, thanks in advance. eagerly waiting for your valuable help, thanks once again. options.txt optionspptp.txt
0
 
Duncan RoeSoftware DeveloperCommented:
It does not look to me that you are using pptp, so the file to change is /etc/ppp/options. Just add a line to that file containing "defaultroute", e.g.:
sudo echo defaultroute > /etc/ppp/options

Open in new window

or use your favourite editor.
After that, stop and start ppp and everything should "just work". If it doesn't, post again the output from ip route list, also please the output from ls -lR /etc/ppp and ls -luR /etc/ppp
0
 
D_wathiAuthor Commented:
Sir, Thank you very after adding the defaultroute in the /etc/ppp/options. Started working fine also finally please suggest me is this below output correct if wrong in permissions or anything please correct me, also please tell me how to find at what speed the connection is connceted,

sudo ls -lR /etc/ppp

[sudo] password for dwathi:

/etc/ppp:

total 84

-rw------- 1 root root   104 2011-05-06 08:50 chap-secrets

-rwxr-xr-x 1 root root  1754 2010-03-07 11:06 ip-down

drwxr-xr-x 2 root root  4096 2011-02-11 18:50 ip-down.d

-rwxr-xr-x 1 root root  1892 2010-03-07 11:06 ip-up

drwxr-xr-x 2 root root  4096 2011-02-11 18:50 ip-up.d

-rwxr-xr-x 1 root root   784 2010-03-07 11:06 ipv6-down

drwxr-xr-x 2 root root  4096 2010-03-07 11:06 ipv6-down.d

-rwxr-xr-x 1 root root   922 2010-03-07 11:06 ipv6-up

drwxr-xr-x 2 root root  4096 2010-03-07 11:06 ipv6-up.d

-rw-r--r-- 1 root root    13 2011-05-06 08:50 options

-rw-r--r-- 1 root root  1759 2010-02-02 07:04 options.pptp

-rw-r--r-- 1 root root  1759 2011-05-05 21:53 optionspptp.txt

-rw-r--r-- 1 root root 13486 2011-05-05 21:53 options.txt

-rw------- 1 root root  1652 2011-05-06 08:50 pap-secrets

drwxr-s--- 2 root dip   4096 2011-05-05 11:32 peers

-rwxr-xr-x 1 root root   137 2010-03-07 11:06 pppoe_on_boot

drwxr-xr-x 2 root root  4096 2009-02-20 23:26 resolv

-rw-r--r-- 1 root root    53 2011-05-06 08:50 resolv.conf



/etc/ppp/ip-down.d:

total 8

-rwxr-xr-x 1 root root  559 2010-03-07 11:06 0000usepeerdns

-rwxr-xr-x 1 root root 2204 2009-02-20 23:26 0dns-down



/etc/ppp/ip-up.d:

total 8

-rwxr-xr-x 1 root root  891 2010-03-07 11:06 0000usepeerdns

-rwxr-xr-x 1 root root 4024 2009-02-20 23:26 0dns-up



/etc/ppp/ipv6-down.d:

total 0



/etc/ppp/ipv6-up.d:

total 0



/etc/ppp/peers:

total 12

-rw-r----- 1 root dip  1093 2011-02-11 18:50 provider

-rw-r--r-- 1 root root   30 2010-01-11 20:58 wvdial

-rw-r--r-- 1 root root   75 2010-01-11 20:58 wvdial-pipe



/etc/ppp/resolv:

total 0

-----------------------------------------------------------------------------------------------------------------------

ls -luR /etc/ppp

/etc/ppp:

total 84

-rw------- 1 root root   104 2011-05-06 08:50 chap-secrets

-rwxr-xr-x 1 root root  1754 2011-05-05 11:48 ip-down

drwxr-xr-x 2 root root  4096 2011-05-05 11:48 ip-down.d

-rwxr-xr-x 1 root root  1892 2011-05-05 11:43 ip-up

drwxr-xr-x 2 root root  4096 2011-05-05 11:43 ip-up.d

-rwxr-xr-x 1 root root   784 2010-03-07 11:06 ipv6-down

drwxr-xr-x 2 root root  4096 2011-05-06 08:56 ipv6-down.d

-rwxr-xr-x 1 root root   922 2010-03-07 11:06 ipv6-up

drwxr-xr-x 2 root root  4096 2011-05-06 08:56 ipv6-up.d

-rw-r--r-- 1 root root    13 2011-05-06 08:50 options

-rw-r--r-- 1 root root  1759 2011-05-05 21:49 options.pptp

-rw-r--r-- 1 root root  1759 2011-05-05 21:54 optionspptp.txt

-rw-r--r-- 1 root root 13486 2011-05-05 21:54 options.txt

-rw------- 1 root root  1652 2011-05-06 08:50 pap-secrets

drwxr-s--- 2 root dip   4096 2011-05-06 08:56 peers

-rwxr-xr-x 1 root root   137 2010-03-07 11:06 pppoe_on_boot

drwxr-xr-x 2 root root  4096 2011-05-06 08:56 resolv

-rw-r--r-- 1 root root    53 2011-05-06 08:50 resolv.conf



/etc/ppp/ip-down.d:

total 8

-rwxr-xr-x 1 root root  559 2011-05-05 21:43 0000usepeerdns

-rwxr-xr-x 1 root root 2204 2011-05-05 21:43 0dns-down



/etc/ppp/ip-up.d:

total 8

-rwxr-xr-x 1 root root  891 2011-05-05 11:43 0000usepeerdns

-rwxr-xr-x 1 root root 4024 2011-05-05 11:43 0dns-up



/etc/ppp/ipv6-down.d:

total 0



/etc/ppp/ipv6-up.d:

total 0

ls: cannot open directory /etc/ppp/peers: Permission denied



/etc/ppp/resolv:

total 0


0
 
Duncan RoeSoftware DeveloperCommented:
Generally it looks OK, especially if it's now working for you. But I do notice one thing: I suggested
sudo echo defaultroute > /etc/ppp/options

Open in new window

when I actually meant
sudo echo defaultroute >> /etc/ppp/options

Open in new window

Notice >> rather than >. As a result, you now have an options file consisting of defaultroute and nothing else. You might like to try
sudo cp /etc/ppp/options.txt /etc/ppp/options
sudo echo defaultroute >> /etc/ppp/options

Open in new window

That will achieve what I originally intended.
You don't need to keep the .txt files, but one of them has already served as a useful backup so you might like to leave them. Personally I use a revision control system to monitor changes I make to system configuration files. I find RCS fine for this, but use whatever you're used to.
0
 
Duncan RoeSoftware DeveloperCommented:
Is this a USB modem? From the dial command DT#777 it looks to me like one. USB serial lines just go as fast as they can, regardless of displayed speed.
If it's a real serial line, then you can find out the speed with stty. for instance, for ttyS0, I did
21:42:19# stty -F /dev/ttyS0
speed 9600 baud; line = 0;
-brkint -imaxbel

Open in new window

0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now