Plesk Panel 10.0.1 update caused a redirect error 11444/relay

I recently did an update on my Plesk 10.0.1, and i added the business managment and plugin update. The update installed flawlessly, but when i went to go back to my control panel, i am redirected to

https://edifier.b1fam.com:11444/relay

How do i fix this issue, i went to the parallels knowledgebase, and found a solution, but i am not sure how to go throught the process, i am not very proficient with linux, so i need some one to walk me through the process. like how to change from old host name to new one to correct this issue.. please help

Here is the possible solution, but i dont know how to determine the old hostname value and the new hostname value to resolve the issue

http://kb.parallels.com/en/9412

I know this sounds stupid, but i don't know what values goes in for the old host name and new host name.

dramous45Asked:
Who is Participating?
 
Duncan RoeConnect With a Mentor Software DeveloperCommented:
Hi dramous45 - I saw your new Q but am unable to help. I don't know anything about Plesk, only the odd thing or 2 about Linux.
I hope you don't mind, but I posted a link back to this Q in your new one, so Plesk experts can immediately see the background to this Q.
You might want to post a comment on the Parallels web site also - perhaps you will get help there.
0
 
Duncan RoeSoftware DeveloperCommented:
The old / new host thing is only if you are using local Customer & Business Manager - are you doing that?
0
 
dramous45Author Commented:
yes, it was recommended by plesk
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
Duncan RoeSoftware DeveloperCommented:
In a command window, hostname will show you what is the host name of your computer. You can check that your network is configured reasonably by entering ping -c1 $(hostname) as in this example:
10:08:30$ ping -c1 $(hostname)
PING dimstar.local.net (10.255.255.1) 56(84) bytes of data.
64 bytes from dimstar.local.net (10.255.255.1): icmp_seq=1 ttl=64 time=0.018 ms

--- dimstar.local.net ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.018/0.018/0.018/0.000 ms
10:08:43$ 

Open in new window

Provided you get similar output, you can go ahead and follow the instructions in this Parallels solution page.
--old-hostname is optional (that's what the square brackets mean) so try something like
sudo /usr/share/plesk-billing/update-hostname --new-hostname=$(hostname)

Open in new window

Or instead of using sudo, get a root command prompt
0
 
dramous45Author Commented:
i found my host name by typing in host name  at the root command prompt. but when i key in the syntax path that you sent to me and what is at  plesk, i keep getting command not found for update-hostname, but when i go to it using the cd command going into the nest so to speak i see the update-hostname path, but when i type it in at the command prompt i keep getting command not found. So i believe the exact syntax is what i need, my host name is edifier.b1fam.com. Please help
0
 
dramous45Author Commented:
i am not sure what values change to exact syntax, such as when to i actually type in my hostname, or use the word hostname as reference to a command syntax. i hope i am explaining this correctly
0
 
Duncan RoeSoftware DeveloperCommented:
Perhaps update-hostname does not have execute permission if it itself is not found as a command. try
ls -l /usr/share/plesk-billing/update-hostname

Open in new window

You should get a line starting -rwxr-xr-x. If you instead see -rw-r--r-- then the file is not executable:
sudo chmod a+x /usr/share/plesk-billing/update-hostname

Open in new window

to make it executable. Then re-try the original update-hostname invocation. If you get errors, post them here
0
 
dramous45Author Commented:
Duncan roe,
       I have kept up with your comments, and i need to point out a few new things that i have discovered. i found out these points. i installed the local Customer & Business Manager update to my Plesk 10 Panel, after the installation i tried to login using the 8443 port, but i am being redirected to port 11444 and the hostname that appears is my actual hostname, in the Url, but i am being redirected to port 11444. So it obvious the that issue might not be only the hostname issue, but something deeper, where the software redefined the host name wrong somewhere else I just dont know where.. do you have any ideas?
0
 
Duncan RoeSoftware DeveloperCommented:
Nothing beyond what's on the web sites. But if as root you do lsof -i -n -P, you will  see what process is listening on port 11444. post back what you find.
0
 
dramous45Author Commented:
ducan roe, i did some research and found the exact problem i am having and the solution is posted on parallel
http://kb.parallels.com/en/111266

Even though i found the KB, i need to see you can walk me through the troubleshooting process with a step by step approach that is not so technical. i Need to know when to use the editor, and how to access the Plesk database using the command line to fix the issue that is mentioned. Please Help
0
 
Duncan RoeSoftware DeveloperCommented:
The instructions look fairly explicit to me, except perhaps the first bit Try to check file /etc/sso/sso_config.ini ....
Post the output from this command: grep relay_port /etc/sso/sso_config.ini
That should show us whether it needs changing. Are you familiar with any text editors at all? Anyway, we should manage.
To check that your installation is as expected by the web site, please also post the output from type -a sso. That will show where the sso program is installed.
0
 
dramous45Author Commented:

grep relay_port /etc/sso/sso_config.ini


did not give any results

[root@edifier ~]#   vim /etc/sso/sso_config.ini

;
; Single Sign-On server configuration
;

; Server's database location
db_file = /var/lib/sso/sso.db

; Log file name
log_file = /var/log/sso/sso.log

; Level of logs verbosity
; 0 - no logs, 1 - ERROR, 2 - WARN, 3 - INFO, 4 - DEBUG, 5 -TRACE
; Recommended values are for INFO or DEBUG.
log_level = 10

; Authentication session expiration period in seconds
; If session was not touched for this period it might be automatically closed.
session_expire_time = 36000

; Server's public certificate (used in web server configuraion, it is here mostly for reference)
cert_file = /etc/sso/sso.pem

; Certificate authority for SP certificates issued by IdP upon SP registration
cacert_file = /etc/sso/sso-ca.pem

; OpenSSL configuration used by IdP server
openssl_conf_file = /usr/share/sso/openssl.conf

; How long to keep data records marked for deletion before they are physically removed.
keep_deleted_records_for = 5 days

; Debugging interface username (is used when server's DEBUG mode is enabled)
admin_user = admin

; Debugging interface password in form hashFunction:hashValue.
; Allowed hash functions: sha1, md5, id. 'id' is not recommended.
admin_password = md5:fa09180620c9ee50748aa94b37d80ba8

; Restrict authentication by SP user's credentials when SP user is already assigned with Federation account
restrict_sp_auth_when_assigned_with_fi = On


; Super Privileged Service Provider
                                                                                                                                                      1,1           Top
 
Now concerning the last command -a sso i get no command is found, so i guess i am not using it in the proper directory
0
 
Duncan RoeSoftware DeveloperCommented:
My bad - type -a sso will not find sso because you seem to have to invoke it as /usr/local/psa/bin/sso.

/etc/sso/sso_config.ini does not specify relay_port = 11444 - that is good. Should it now contain the line  relay_port = 8443? I don't know. Plesk is not free and I don't have it so can't try it here, but at a guess I would think it would do no harm to add it. You might like to try adding it and see if that fixes everything, although I don't expect it will. As long as it doesn't make things worse, I would be inclined to leave it, or you may prefer to take the line back out for now.

We now know that /etc/sso/sso_config.ini is not redirecting to 11444 so it's time to move on to the next step of the solution in the web page. Two commands:
# /usr/local/psa/bin/sso -s -server https://<your-domain-name>:8443 -url https://<your-domain-name>:8443
# /usr/local/psa/bin/sso -e

Open in new window

First of all, don't type the "# ". It is there to advise you that you have to issue the commands as root.
That leaves the decision what to type in place of <your-domain-name>. From your original post, would that be edifier.b1fam.com?  On the basis that it is, you would enter:
/usr/local/psa/bin/sso -s -server https://edifier.b1fam.com:8443 -url https://edifier.b1fam.com:8443
/usr/local/psa/bin/sso -e

Open in new window

The following commands are similar. Invoke mysql as root. Note that command has back-quotes - you do best to select and copy from the browser into your command window. Again, mysql> is the expected command prompt: you don't type it.
0
 
dramous45Author Commented:
/usr/local/psa/bin/sso -s -server https://edifier.b1fam.com:8443 -url https://edifier.b1fam.com:8443

this is the result for that command

Wrong registration information returned by Identity Provider

/usr/local/psa/bin/sso -e

this is the result for that command

SSO Server is not specified
0
 
dramous45Author Commented:
Duncan roe, i am able to log into the panel after applying these commands you gave me, but my business Management section of plesk  only display links to  blank pages.  such as :

https://edifier.b1fam.com:8443/plesk-billing/admin/clients.php?action=821&return-panel-url=https%3A%2F%2F66.76.161.72%3A8443&context=billing-customers

 i have three new sections after the udpate displaying in the panel:

business operation
link
link

business monitor
link
link
business update
link
link
0
 
Duncan RoeSoftware DeveloperCommented:
The responses in http#a35771750 do not look encouraging. All I can do is help you with the command line as you requested. If the commands suggested in solutions posted elsewhere don't work then there is nothing further I can do.
edifier.b1fam.com was my best guess at <your-domain-name> - can you think of another one?
Alternatively, maybe something was lost when you did the upgrade.
You may need to seek paid help to fix this - Google finds plenty of that.
0
 
dramous45Author Commented:
ok, i actually logged into the control panel, and able to navigate thru it, but the new update seems to take me to blank pages as if something is missing, or not directed to the right path. any ideals
0
 
dramous45Author Commented:
i posted a new question that give you more of an ideal of what i need help with, i want to see if you will come in on this question with your expertise to help me get this issue taken care of

The New Question: Plesk Business Management Update Issue
0
 
dramous45Author Commented:
duncan roe , is a great with his explaination
0
All Courses

From novice to tech pro — start learning today.