• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 279
  • Last Modified:

Throughput issue in File transfer to W2003 servers from Windows 2003 and Windows 2008

Hi

When we try to do Robocopy between Windows 2008 to Windows 2003 and Windows 2003 to Windows 2003 servers we find the throughput is very low.. Has anyone come across this issue ?

Thanks
GK
0
gkumar72
Asked:
gkumar72
  • 6
  • 3
  • 3
1 Solution
 
bbaoIT ConsultantCommented:
are the all mentioned servers on the SAME subnet locally??
0
 
Cris HannaCommented:
You might consider turning off Receive Side Scaling and TCP Chimney Offload?
http://support.microsoft.com/kb/951037    This article is for Windows Server 2008.   There is a link in the article for the same thing on Server 2003
0
 
gkumar72Author Commented:
I did check this article....
0
Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

 
gkumar72Author Commented:
i did check the article and did the changes but did not see the any increase in throughput
0
 
Cris HannaCommented:
it might also be necessary to disable smb signing
0
 
gkumar72Author Commented:
Do I disable it in W2003 server ?If yes I do i do it.... I saw commands for W2008 but nothing for W2003
0
 
gkumar72Author Commented:
when i transfer a 1 GB file between a Windows 2003 32 bit SP2 and Windows 2003 64 bit SP2, the throughput is very less..12014886 Bytes/sec...

Same when I transfer the file from W2003 32 bit SP2 to Windows 2008 R2
0
 
bbaoIT ConsultantCommented:
again, are all servers on the same subnet?? or any routers or firewall between the subnets??
0
 
gkumar72Author Commented:
No firewalls in between them.. Even when i try to do copy between 2 Hyper V VMS inside the same chassis the problem exists...
0
 
bbaoIT ConsultantCommented:
i would speculate it was caused by improper TCP window size or unnecessary differential compression.

try NETSH INTERFACE TCP SET GLOBAL AUTOTUNINGLEVEL=DISABLED to disable automatic adjustment for TCP window size on the network.

or, disable Remote Differential Compression in Control Panel.

FYI - Vista: very slow to copy large files
http://www.chicagotech.net/netforums/viewtopic.php?t=576

hope it helps,
bbao
0
 
Cris HannaCommented:
SMB 2.0 does not exist in WS 2003, but you would want to disable on 2008 since 2003 doesn't support SMB 2.0
0
 
gkumar72Author Commented:
Micorsoft confirms that W2003 performance with SMB1.0 is asyn and in W2008 it Syn and that is causing the difference in speed
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 6
  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now