• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1651
  • Last Modified:

Delphi 2010 + Firebird 2.5 + IBX: crash the IDE

Hi Experts,
I'm experiencing a very annoying problem. I use Delphi 2010, Firebird 2.5, IBX components, Windows 7 Pro.
Whenever I invoke the "Edit SQL" property editor on a TIBQuery or TIBDataSet, I get a crash of the IDE. Sometimes it crashes ("this program has stopped working blah blah blah"), sometimes the Delphi error dialog popups ("Access Violation in dcldb140.bpl at address blah blah... view details... etc"); clicking ok doens't solve because the popup appears again and again, forever; I have to kill bds via task manager.
I have another machine with Delphi that has the same exact problem.
This problem started appearing some time ago, but it did appear quite seldom, and a restart was enough to recover from the error.
Now it is appearing everytime.
Has anyone had the same issue? Any idea how I can approach it?
 the damn error
0
lomo74
Asked:
lomo74
1 Solution
 
Nick UpsonPrincipal Operations EngineerCommented:
ensure you have the most up-to-date version of ide
0
 
lomo74Author Commented:
Delphi and C++ Builder 2010 Update 4

this is the latest, afaik
0
 
lomo74Author Commented:
I'm going to do a fresh install on a VM...
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
lomo74Author Commented:
darn - on a fresh install it is running well, apparently.
what on earth I did that caused this... on two machines!
now I'm going to
1) calc diffs between the working installation and the messed one;
2) reinstall all the stuff (devexpress, fastreport, and so on).
I'll make test at each step. I want to discover which is the offending component. aaarrrggghhhhh
0
 
Ephraim WangoyaCommented:

I had a similar problem with Delphi 7 but I solved it the lazy way

I just installed EurekaLog, now everytime there is a problem, a popup dialog from EurekaLog is displayed and I just click on the continue button LOL
0
 
lomo74Author Commented:
I have the problem in the IDE, not in my own applications.
Can EurekaLog trap exceptions in the IDE too? Before the VCL itself traps the exception?
Moreover, I see that the exception is occurring at SqlEdit.pas line 507; I opened that file and saw that we're inside an ActionUpdate event. Doing some debug reveals that possibly the EAX register contains trash when the event is called (I'm not 100% sure of this)...
But at least this explains why the error never goes away: the ActionUpdate event is called whenever the application is idle... :-(
0
 
lomo74Author Commented:
today the error is gone.
darn... tomorrow it will come back again.
this drives me crazy
0
 
lomo74Author Commented:
update --
I compared my install with a fresh install -> binary same, so uninstall / reinstall of the IDE should solve nothing.
Instead, I found this thread: http://www.delphigroups.info/2/10/757317.html
Well, I'm sure I did the same mistake, once, while installing one of the many components I work with.
So, I followed these steps:
1) removed all components, except those shipped with Delphi itself;
2) removed the various ToolsApi.dcu DesignIntf.dcu and so on that I manually created because I din't find them (and didn't know they were inside designide.dcp)
3) recompiled/reinstalled a small set of components that I really need, so that they aren't using my (broken?) ToolsApi.dcu etc but the correct ones
So far, the problem is gone. I'll test in the next days.
0
 
lomo74Author Commented:
Sorry - I'm still testing.
Problem is appearing again, but unfrequently.
I agree that the Q be closed.
BTW there is a nice solution: create wrapper components and define custom editors for properties. Finally, I adopted this technique, and now I have my own TWrapIBDataset with a custom SQL editor that uses syntax hilight (synedit) and does not crash :-) This is a nice topic for an article: "how to enhance standard Delphi components with customized design time editors" ;-)
Anyway I would be happy to finally figure out what is going wrong with Embarcadero's standard components...
0
 
mlmccCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now