Windows Server 2008 x64 SP2 Installation failed with error code hr=0x80070011

When I'm installing the Service Pack 2 for Windows Server SBS 2008 x64, I'm getting this error: 0x80070011. I've searched the database here with the same error and tried all the possibles solutions:
SFC /SCANNOW, CHKDSK, installing from safe mode, normal mode and runas.
I did run checksur to test and no error found. I'm able to install any others updates except the SP2.

I've tried to install it standalone but still fail with a description : NOT_SAME_DRIVE_ERROR.

In CBS log, here are the last lines with errors:

011-04-30 16:22:53, Info                  CSI    00000032 Expected resource missing in file installer: [l:24{12}]"LANGWRBK.DLL"

2011-04-30 16:22:53, Info                  CSI    00000033 Expected resource missing in file installer: [l:22{11}]"vmguest.iso"

2011-04-30 16:22:53, Info                  CSI    00000034 Expected resource missing in file installer: [l:18{9}]"s3cap.sys"

2011-04-30 16:22:53, Info                  CSI    00000035 Expected resource missing in file installer: [l:22{11}]"storflt.sys"

2011-04-30 16:22:53, Info                  CSI    00000036 Expected resource missing in file installer: [l:30{15}]"storflt.sys.mui"

2011-04-30 16:22:53, Info                  CSI    00000037 Expected resource missing in file installer: [l:32{16}]"netvsc60.sys.mui"

2011-04-30 16:22:53, Info                  CSI    00000038 Expected resource missing in file installer: [l:32{16}]"netvsc50.sys.mui"

2011-04-30 16:22:53, Info                  CSI    00000039 Expected resource missing in file installer: [l:64{32}]"Microsoft.Web.Management.Iis.dll"

2011-04-30 16:22:53, Info                  CSI    0000003a Expected resource missing in file installer: [l:82{41}]"Microsoft.Web.Management.AspnetClient.dll"

2011-04-30 16:22:53, Info                  CSI    0000003b Expected resource missing in file installer: [l:76{38}]"Microsoft.Web.Management.IisClient.dll"

2011-04-30 16:22:53, Info                  CSI    0000003c Expected resource missing in file installer: [l:70{35}]"Microsoft.Web.Management.Aspnet.dll"

2011-04-30 16:22:53, Error                 CSI    0000003d@2011/4/30:20:22:53.874 (F) d:\longhorn\base\wcp\sil\fs_buffered.cpp(3042): Error STATUS_NOT_SAME_DEVICE originated in function Windows::Rtl::SystemImplementation::CBufferedFileSystemProvider::CreateOrOpenContentsFile expression: TempDirSerial == TargetSerial
[gle=0x80004005]
2011-04-30 16:23:15, Error                 CSI    0000003e (F) STATUS_NOT_SAME_DEVICE #8978552# from Windows::Rtl::SystemImplementation::CSystemIsolationLayer_IRtlSystemIsolationLayerTearoff::TransferFile(flags = (ReplaceIfExists|OpenForBackupIntent|MissingFileIsOk), op = [24]"HardLinkWithCopyFallback", odir = @0x172f5b98, oname = [l:22{11}]"mxdwdui.dll", ndir = @0x172ea948, nname = [l:22{11}]"mxdwdui.dll", disp = Unmapped disposition: 0)
[gle=0xd00000d4]
2011-04-30 16:23:15, Error                 CSI    0000003f (F) STATUS_NOT_SAME_DEVICE #8957477# from CFileInstaller::CommitChanges(...)[gle=0xd00000d4]
2011-04-30 16:23:15, Error                 CSI    00000040 (F) STATUS_NOT_SAME_DEVICE #8957476# from PrimitiveInstaller::CCoordinator::FinalizeChanges(...)[gle=0xd00000d4]
2011-04-30 16:23:15, Info                  CSI    0000087b SMI Primitive Installer [done]

2011-04-30 16:23:15, Error                 CSI    00000041 (F) STATUS_NOT_SAME_DEVICE #6732529# from CCSDirectTransaction::PerformChangeAnalysis(...)[gle=0xd00000d4]
2011-04-30 16:23:15, Error                 CSI    00000042 (F) STATUS_NOT_SAME_DEVICE #6732528# from CCSDirectTransaction::PrepareForCommit(...)[gle=0xd00000d4]
2011-04-30 16:23:15, Error                 CSI    00000043 (F) STATUS_NOT_SAME_DEVICE #6732527# from CCSDirectTransaction::GenerateComponentChangeList(...)[gle=0xd00000d4]
2011-04-30 16:23:15, Error                 CSI    00000044 (F) STATUS_NOT_SAME_DEVICE #6732526# from Windows::COM::CPendingTransaction::ExtractInformationFromRtlTransaction(...)[gle=0xd00000d4]
2011-04-30 16:23:15, Error                 CSI    00000045 (F) HRESULT_FROM_WIN32(17) #2516070# from Windows::COM::CPendingTransaction::IStorePendingTransaction_Analyze(...)[gle=0x80070011]
2011-04-30 16:23:15, Error                 CSI    00000046 (F) HRESULT_FROM_WIN32(17) #2500929# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_Commit(Flags = 47 (0x0000002f), pSink = NULL, disp = disp, coldpatching = FALSE)[gle=0x80070011]
2011-04-30 16:23:15, Error                 CSI    00000047 (F) HRESULT_FROM_WIN32(17) #2500928# 123758579 us from Windows::ServicingAPI::CCSITransaction_ICSITransaction::Commit(flags = 0x0000002f, pSink = NULL, disp = 0)
[gle=0x80070011]
2011-04-30 16:23:15, Error                 CBS    Exec: Failed to pend CSI transaction because transactions cannot be merged: 0. hr: 0x80070011
2011-04-30 16:23:15, Info                  CSI    00000048@2011/4/30:20:23:15.512 CSI Transaction @0x79d2520 destroyed
2011-04-30 16:23:15, Info                  CBS    WER: Generating failure report for package: VistaSP2-KB948465~31bf3856ad364e35~amd64~~6.0.1.18005, status: 0x80070011, failure source: Execute, start state: 4, target state: 7
2011-04-30 16:23:26, Info                  CBS    SPI: Error callback - 0x80070011
2011-04-30 16:23:26, Info                  CBS    Exec: Processing complete.  Session: 30148467:3073801257, Package: VistaSP2-KB948465~31bf3856ad364e35~amd64~~6.0.1.18005, hr: 0x80070011
2011-04-30 16:23:26, Info                  CBS    Restored system sleep block state: 0x80000000
2011-04-30 16:23:26, Info                  CBS    Session: 30148467:3073801257 finalized.  Reboot required: no
2011-04-30 16:23:26, Error                 CBS    SPI: (CSPICbsClient::ChangeState:462)Failed changing package state to 7 hr=0x80070011
2011-04-30 16:23:26, Error                 CBS    SPI: (CSPCInstallTask::Execute:1037)Failed to install package with identity VistaSP2-KB948465~31bf3856ad364e35~amd64~~6.0.1.18005 hr=0x80070011
2011-04-30 16:23:26, Info                  CBS    SPI: Reporting Failed package event
2011-04-30 16:23:27, Error                 CBS    SPI: (CSPInstall::Install:1332)Failed executing Install task hr=0x80070011
2011-04-30 16:23:27, Info                  CBS    SPI: Ending SP Installation
2011-04-30 16:23:27, Error                 CBS    SPI: (PerformSPInstallation:764)Failed to install SP using UI hr=0x80070011
2011-04-30 16:23:27, Error                 CBS    SPI: (wmain:1059)Failed to perform SP installation hr=0x80070011
2011-04-30 16:23:27, Info                  CBS    SPI: Reporting Failed event
2011-04-30 16:23:52, Info                  CBS    SPI: SPInstall terminating, return code 0x11
2011-04-30 16:23:52, Error                 CBS    SPI: (SPIRegQueryStringValue:511)Failed to query registry value: MiscString2 er=0x2
2011-04-30 16:23:52, Error                 CBS    SPI: (CSystem::GetMachineName:348)Failed to query machine name from RAC hr=0x80070002
2011-04-30 16:23:52, Info                  CBS    SPI: Deleting directory: C:\05e214cc410dc2aa4bbdf76c519c\ac4acbed65f6f84b14de05b534.  ret=2


The thing I suspect is that someone move the directory SoftwareDistribution to empty the C:\ because there was not enough data.

I'll move again the directory to its original place and try to do the update again. Still, I'll have enough room for installing it (over 6gb.).

Let me know if there is something that I am missing.

Thanks
CalinourAsked:
Who is Participating?
 
CalinourAuthor Commented:
Here are the updates: the problem was that the SPOOLER folder was directing on another drive (junction link). SP2 asked for a file named "mxdwdui.dll" in a subfolder this folder. SO went back to the c:windows/system32/spool/ file path, reinstalled and SUCCESS. It was so a pain... I didn't think that the spooler would cause this error since it was pointing others files. Mark as solved!

Thanks for the help.
0
 
bbaoIT ConsultantCommented:
ever tried uninstall and reinstall??
0
 
CalinourAuthor Commented:
Of what ? SP2? It's not installed yet. And if you were talking about OS, not an option for the customer.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
bbaoIT ConsultantCommented:
I were talking about SP2. as the previous install was interrupted in the middle, so better restore the system first before trying one more.

frankly, i am not sure if the uninstall could be done, just have a try.
0
 
CalinourAuthor Commented:
Ok ,

I can't uninstall it and no restore point is available. Tried to re-create the SoftwareDistribution but failed again. The WSUS server  wasn't install so I did. Failed again.

I have the spooler directory that is map to a drive. This and a Hyper-V machine on another drive too (junctions links).

Is there any free number to call Microsoft to have support for this kind of issue installing Service Pack 2?


0
 
bbaoIT ConsultantCommented:
there is no free number to call MS support.

however, some MS and 3rd-party FREE online forums may help, including MS newsgroup, TechNet community forums, and here at EE. :)

http://www.microsoft.com/communities/newsgroups/en-us/
http://social.technet.microsoft.com/forums/en-au/categories/
0
 
CalinourAuthor Commented:
I found out by myself.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.