FTP Windows Server 2008, don't make users login?

I'm trying to configure an internal FTP server for a coworker to use for temporary storage.  He doesn't want to have to login at all.  Setting it to Anonymous Authentication still requires you to enter a username and password.  How can I make it not require anything?
LVL 1
CerixusAsked:
Who is Participating?
 
BDoellefeldConnect With a Mentor Commented:
AFAIK there is no way around not providing _something_. For instance, in most FTP clients where you have a check box or whatever for "anonymous user". All that does is send a canned user name and password. All Anonymous FTP really means is that no verification is preformed against the creds you supply, but something needs to be supplied.

However... you can pass a BS username and password in the URL you use to make the connection. That may help you.

Example: ftp://username:password@my.FTPsite.com/
0
 
BDoellefeldCommented:
Could be NTFS permissions. How are the NTFS permissions setup on the folder.

Here is a decent how to in case you want to retrace your steps.
http://www.trainsignaltraining.com/windows-server-2008-ftp-iis7
0
 
CerixusAuthor Commented:
I'm not sure you understand.  Here is the description of "Anonymous Authentication" from IIS Help:

"Anonymous authentication is a built-in authentication method that allows any user to access any public content by providing an anonymous user name and password. By default, Anonymous authentication is disabled."

I want to avoid the bold part.
0
 
AlexPaceConnect With a Mentor Commented:
I doubt you can do what you want to do.  The most simple configuration I've seen is where the username is "anonymous" and the password is either blank or whatever you type is is accepted as valid.  If you want to make it easier to use, perhaps a better method would be to use a scriptable ftp client with a command script to log in automatically.

0
 
CerixusAuthor Commented:
The client is the problem and what is driving the requirement for no username password.  It cannot be changed.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.