• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 846
  • Last Modified:

squid proxy server problems with 1 site

I’ve got a squid proxy server 2.7 on an Ubuntu 64 (10.04.02) server.   4gb ram, plenty of drive space…

It runs all of my 200 users just fine… Except for 1 site.
When I go to the site below, it comes up in a browser (IE), then just dies after a few navigations.  
When I remove Squid proxy from the equation, the site is slow, but not horrible.

When using squid, I get the site, click a few links then it seems to time out.

Any suggestions on improving performance?  Is it squid or the site?


Thanks
-Brian



Here’s the site:
http://www.natlallergy.com/


The site is heavily cross linked with marketing crap.  I don’t manage the site, just some of the infrastructure in a my call center.


I see some high load times  in access.log:
1304439744.799 118071 10.1.16.71 TCP_MISS/200 34236 GET http://www.natlallergy.com/cat/1323/anti-allergen-laundry-detergent-allergy-free-laundry-care.html - DIRECT/72.249.189.22 text/html
1304439744.947    112 10.1.16.71 TCP_MISS/200 4251 CONNECT sealserver.trustkeeper.net:443 - DIRECT/204.13.200.57 -
1304439744.972    124 10.1.16.71 TCP_MISS/200 9926 GET http://www.natlallergy.com/images/153/clearly-clean-concentrates-by-envirorite.jpg - DIRECT/72.249.189.22 image/jpeg
1304439744.975    123 10.1.16.71 TCP_MISS/200 6359 GET http://www.natlallergy.com/images/153/dri-pak-soap-flakes-pure-natural-laundry-soap.jpg - DIRECT/72.249.189.22 image/jpeg
1304439744.976    124 10.1.16.71 TCP_MISS/200 6911 GET http://www.natlallergy.com/images/153/enviro-rite-clearly-clean-laundry-detergent.jpg - DIRECT/72.249.189.22 image/jpeg
1304439745.025    222 10.1.16.71 TCP_MISS/404 2894 GET http://www.natlallergy.com/images/bkg-TopNavSale.gif - DIRECT/72.249.189.22 text/html
1304439745.101    125 10.1.16.71 TCP_MISS/200 5831 GET http://www.natlallergy.com/images/153/citrisafe-laundry-liquid.jpg - DIRECT/72.249.189.22 image/jpeg
1304439745.102      0 10.1.16.71 TCP_IMS_HIT/304 401 GET http://www.natlallergy.com/images/corner_banner_newitem.gif - NONE/- image/gif
1304439745.102    125 10.1.16.71 TCP_MISS/200 7832 GET http://www.natlallergy.com/images/153/allersearch-allergen-wash-laundry-detergent.jpg - DIRECT/72.249.189.22 image/jpeg
1304439745.120    147 10.1.16.71 TCP_MISS/200 4485 CONNECT sealserver.trustwave.com:443 - DIRECT/204.13.200.58 -
1304439745.160    211 10.1.16.71 TCP_MISS/200 38370 GET http://www.natlallergy.com/images/153/anti-allergen-laundry-detergent.jpg - DIRECT/72.249.189.22 image/jpeg
1304439745.227     64 10.1.16.71 TCP_REFRESH_HIT/304 424 GET http://images.scanalert.com/meter/www.natlallergy.com/13.gif - DIRECT/184.86.144.80 image/gif
1304439745.229    125 10.1.16.71 TCP_MISS/200 10593 GET http://www.natlallergy.com/images/153/de-mite-laundry-additive-for-dust-mite-control.jpg - DIRECT/72.249.189.22 image/jpeg
1304439745.276    249 10.1.16.71 TCP_MISS/200 45454 GET http://www.natlallergy.com/images/153/static-eliminator-dryer-sheets.jpg - DIRECT/72.249.189.22 image/jpeg
1304439745.301    174 10.1.16.71 TCP_MISS/200 12807 CONNECT sealserver.trustwave.com:443 - DIRECT/204.13.200.58 -
1304439745.309     32 10.1.16.71 TCP_MISS/200 552 GET http://www.google-analytics.com/__utm.gif? - DIRECT/74.125.95.138 image/gif
1304439745.484    108 10.1.16.71 TCP_MISS/200 1307 GET http://seg.sharethis.com/getSegment.php? - DIRECT/204.236.131.44 text/html
1304439745.487    123 10.1.16.71 TCP_MISS/204 308 GET http://l.sharethis.com/pview? - DIRECT/204.236.130.144 -
1304439745.510     19 10.1.16.71 TCP_MISS/204 660 GET http://b.scorecardresearch.com/b? - DIRECT/209.18.42.96 -
1304439750.345   5211 10.1.16.71 TCP_MISS/200 1297 CONNECT www.nextag.com:443 - DIRECT/216.185.212.2 -
1304439805.501  60270 10.1.16.71 TCP_MISS/200 6166 CONNECT a248.e.akamai.net:443 - DIRECT/209.18.42.19 -

0
CousinDupree
Asked:
CousinDupree
1 Solution
 
BlazCommented:
It seems that your squid server is waiting for some sort of timeouts - 2 minutes for the first request and 1 minute for the last request.

This could be a number of things including DNS timeout (for example remote server not responding to a AAAA record request, only after the timeout the A record is requested)
0
 
CousinDupreeAuthor Commented:
problem must be with external site.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now