Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 796
  • Last Modified:

Unable to Connect to Server\Instance Name SQL Server 2008 R2

I'm able to connect to SQL Server locally, and I'm able to telnet into the server from another macine; however when attempting to connect to the server via ssms from another machine, I'm receving the following error message when attempting to connect to a SQL Server Instance (server\instance) "Error locating server/Instance specified"  I've enabled "allow remote connections", I've enabled "sql browser", I've doubled and triple checked the instance name, I've enabled TCP/IP.

0
nitayalevette
Asked:
nitayalevette
  • 4
  • 2
  • 2
  • +2
1 Solution
 
Ephraim WangoyaCommented:

"Error locating server/Instance specified"

Make sure its a backslash

server\Instance
0
 
nitayalevetteAuthor Commented:
Backslash is there, and going in the right direction
0
 
nitayalevetteAuthor Commented:
The local server is able to see the instance and connect; however we are unable to connect to the instance from another server or computer
0
Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

 
sabeeshCommented:
Is there any firewall is running in server, if yes try to disable or add the SQL Port in exception
0
 
dba2dbaCommented:
Did you restart SQL Services after enabling tcp/ip and remote connections.
Also, please try connecting with FQDN as Servername.DomainName.com\INstranceName,PortNumber from the remote machine.

You can also explicitly force a connection using TCP/Ip and Named pipe (as tcp:Servername.DomainName.com\INstranceName,PortNumber  and np:Servername.DomainName.com\INstranceName)

Try connecting using the sqlcmd from command line as well

Thanks,
0
 
nitayalevetteAuthor Commented:
We are able to connect via sqlcmd; however we are still unable to connect via ssms.  Firewall is OFF, and we have restarted the services.
0
 
Alpesh PatelAssistant ConsultantCommented:
Please make sure Remote connection is enabled in configuration. TCP/IP and other protocol is configured well, Firewall has proper exception.
0
 
nitayalevetteAuthor Commented:
TCP/IP Connections are enabled; however we are going through port 2153 for this connection.  We have another instance running over port 1433.  How can I make SSMS go through port 2153 vs 1433?
0
 
dba2dbaCommented:
Did you try Connecting via SSMS as

 Servername\InstanceName,2153   or  tcp:Servername\InstanceName,2153

Thanks,
0
 
sabeeshCommented:
Try the following. Sql Server Configuration Manager -> SQL Native Client Configuration -> Client Protocol Disable VIA.
On SQL Server Network Configuration -> Protocol for <Instance Name> Disable NamedPipe and VIA and enable.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 4
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now