?
Solved

Issue Connecting to Exchange 2010 From A Specific Internet Connection

Posted on 2011-05-03
10
Medium Priority
?
697 Views
Last Modified: 2013-12-14
My Boss is able to take his laptop to any internet connection and Outlook will successfully connect to our Exchange 2010 server - that is except for the connection at his house.  For what it's worth his ISP is Bresnan.  When he attempts to connect, a certificate error pops up (attached to this thread).  The certificate error that pops up is issued to bresnan.net, Outlook should be pulling a certificate issued to our domain that we purchased from GoDaddy.

I have spent several hours on support calls with Microsoft, and they say it's an issue with Bresnan.  I tried to get support from Bresnan, but they were even less help.
ssl-cert-error.jpg
0
Comment
Question by:yctech
  • 3
  • 3
  • 3
  • +1
10 Comments
 
LVL 10

Expert Comment

by:Larry Larmeu
ID: 35516621
Looks like the ISP is trying to proxy the SSL traffic through their server or something.  Try calling the support line and asking for a supervisor or network engineer.
0
 
LVL 8

Expert Comment

by:steinmto
ID: 35516721
Have you tried OWA if you are running it?  Just to see if the SSL cert is correct with OWA.
0
 

Author Comment

by:yctech
ID: 35516762
OWA works with no SSL cert error
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 8

Expert Comment

by:steinmto
ID: 35516791
Do you have a vpn you could try out to see if he has the same issue at home after connecting to it?  That should wipe out bresnan.net from being the issue.
0
 
LVL 4

Expert Comment

by:kdgoodknecht
ID: 35516865
I'll bet if you look in his DNS search list on his home network it has bresnan.net.
What this does is appends bresnan.net to all DNS queries sent to the DNS server, then in what I consider a dumb airheaded move by any DNS admin, they added a wildcard CNAME record to the bresnan.net domain so when Outlook attempts to autoconfigure it hits the wildcard record and resolve like this: autoconfigure.Their_real_domain.com.bresnan.net
See this:
QUESTION SECTION:
autoconfigure.Their_real_domain.com.bresnan.net.         IN      A      

ANSWER SECTION:
autoconfigure.Their_real_domain.com.bresnan.net. 10800   IN      CNAME   bresnan.net.
bresnan.net.            2311    IN      A       64.78.178.63
0
 
LVL 8

Expert Comment

by:steinmto
ID: 35516895
kdgoodknecht Good Catch not a good idea by bresnan.net.
0
 

Author Comment

by:yctech
ID: 35516966
If I remember correctly, when doing an "ipconfig" it does show bresnan.net

Any way to work around this issue?
0
 
LVL 4

Accepted Solution

by:
kdgoodknecht earned 2000 total points
ID: 35689875
It is probably picking it up from DHCP for the DNS Connection specific suffix, some  ISPs require this for the DNS connection specific suffix, you'll need to contact the ISP and tell them what is going on and why. Ask them if the DNS connection Suffix is required, then if not, it depends on what is doing DHCP, whether or how to stop it from applying the suffix. Another option, you can manually configure the DNS Connection Specific Suffix to your internal domain name, or to something like "domain.invalid" on the DNS tab of TCP/IP properties sheet.
0
 

Author Comment

by:yctech
ID: 35691441
Ok... got this problem resolved (or rather a workaround)

When I did an nslookup to our mail server - this was the output:
C:\Documents and Settings\hwilliamson>nslookup mail.ourmailserver.com
Server:  blnmt001dns.ext.bresnan.net
Address:  69.145.248.4

*** blnmt001dns.ext.bresnan.net can't find mail.ourmailserver.com: Non-existe
nt domain

Open in new window


I then configured DNS setting for DHCP to assign Google's DNS servers (8.8.8.8 and 8.8.4.4)

C:\Documents and Settings\hwilliamson>nslookup mail.ourmailserver.com
Server:  google-public-dns-a.google.com
Address:  8.8.8.8

Non-authoritative answer:
Name:    mail.ourmailserver.com
Address:  65.xx.xxx.xxx

Open in new window


Now it's resolving correctly but I still can't connect to our Exchange server with Outlook.

When doing an ipconfig I still show bresnan.net as the "connection-specific DNS suffix"
 ipconfig 1
In the Advanced TCP/IP settings for his NIC I made the following change:
 
 dns
Now an ipconfig shows "yca.local" as the connection-specific DNS suffix and I am now able to connect to our Exchange server...
0
 
LVL 4

Expert Comment

by:kdgoodknecht
ID: 35691694
Thanks for coming back and showing your solution, this will help other people that come across this problem with wildcard records mixed with the DNS suffix search list.
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

MS Outlook undoubtedly is the most widely used email client.Its user-friendliness, cost effectiveness, and availability with Microsoft Office Suite make it the most popular email application.  Its compatibility with Microsoft applications like Exch…
Exchange administrators are always vigilant about Exchange crashes and disasters that are possible any time. It is quite essential to identify the symptoms of a possible Exchange issue and be prepared with a proper recovery plan. There are multiple…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
Is your OST file inaccessible, Need to transfer OST file from one computer to another? Want to convert OST file to PST? If the answer to any of the above question is yes, then look no further. With the help of Stellar OST to PST Converter, you can e…
Suggested Courses
Course of the Month9 days, 16 hours left to enroll

571 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question