Visual Studio 2010 (64-bit) ORA-06413 error

I've got a vb.net web application that connects to the Oracle DB on my old PC (32-bit, XP Prof.), but now won't on my new PC (64-bit, Windows 7).  All I get is an ORA-06413 "not connected" error

Visual Studio 2010 installed in C:\Program FilesX86\
 - so this should avoid the whole parentheses/Oracle path issue

64-bit Oracle DAC asp.net 4 installed in C:\Oracle64

I can connect in Visual Studio using the Server Explorer ... MSDAORA.ServerName

Here is part of my code:
>>>>
Imports System.Data.OracleClient
Imports System.Data.OleDb

'64-bit - I think -
Dim myConnection As New OleDb.OleDbConnection("Provider=OraOLEDB.Oracle.1;Data Source=XXXX;User ID=XXXX;Password=XXXX;")

Dim myCommand As OleDbCommand
Dim dr As OleDbDataReader

            Try
                myConnection.Open()
                myCommand = New OleDbCommand(QRY5, myConnection)

                dr = myCommand.ExecuteReader()

                ....read into some variables....

            Catch ex As Exception
                ex.Message.ToString()
                Throw

            Finally
                dr.Close()
                myConnection.Close()
>>>>

On the 32-bit PC, this works:
            ' 32 bit
            'Dim myConnection As New OleDb.OleDbConnection("Provider=MSDAORA.1;Data Source=XXXX;User ID=XXXX;Password=XXXX;")

TIA
shelbyinfotechAsked:
Who is Participating?
 
slightwv (䄆 Netminder) Commented:
My guess is you are running into a supportability issue.  

Looks like you are using the Microsoft drivers 'for Oracle'.  The newer MSoft drivers probably don't know how to talk to the Oracle 8 DLLs.

The newer ODAC from Oracle are almost guaranteed to not be able to talk to an older Oracle 8 database.

Here's a quick reference to Oracle's support site:
Metalink note 207303.1 - Oracle 10G client is "officially supported" for
connecting to 8.1.7 but nothing earlier.

0
 
slightwv (䄆 Netminder) Commented:
Since Visual Studio is 32Bit, I think you will need the 32Bit ODAC.  I'm not sure VS can reference the 64Bit drivers.
0
 
radcaesarCommented:
If you can connect in server explorer using MSDAORA.ServerName,

then use the same MSDAORA.ServerName in provider, why did u use OLEBD in code?
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
slightwv (䄆 Netminder) Commented:
I just saw the re-read "Visual Studio 2010 (64-bit) "

What threw me was "Visual Studio 2010 installed in C:\Program FilesX86\".

Do the Bit versions match?
0
 
shelbyinfotechAuthor Commented:
I believe I have those in C:\Oracle817cl.  When I ran it with the 32 bit connection string, I still get the exact same error.
0
 
shelbyinfotechAuthor Commented:
As far as I know, Visual Studio is only a 32 bit application.  The 64-bit references the system the application is installed on.  Sorry for the confusion.
0
 
slightwv (䄆 Netminder) Commented:
>>C:\Oracle817cl

Were you using the Oracle 8 32Bit drivers?  I can see where Oracle 8 will throw an error.
0
 
shelbyinfotechAuthor Commented:
Yes, these are the same drivers that I used on my 32 bit PC.
0
 
slightwv (䄆 Netminder) Commented:
But were they Oracle 8?  I would get newer/supported Oracle data access providers.  32Bit.
0
 
shelbyinfotechAuthor Commented:
Right now we are running an Oracle 8 server with intentions of upgrading to 10.
0
 
shelbyinfotechAuthor Commented:
It sent to to the right sight to get answers, which was Oracle support
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.