[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Fresh SharePoint 2010 Install - "An unexpected error has occurred" and EventID 8306.

Posted on 2011-05-03
8
Medium Priority
?
3,672 Views
Last Modified: 2012-05-11
Greetings!

I've never encountered this error on a fresh SharePoint 2010 installation, and I'm not quite sure what to make of it.  I set up a three-server farm with SQL, Application, and a Web Front End.  All software is at the required version level and patch level.

- I installed my SSL certification in the MMC for Certificates.
- Went into Central Administration and set up a Web Application to use SSL.  
- Edited the bindings for port 443 in IIS to use the new SSL certificate.
- Created a site collection under the new web application.
- Site collection = team site.
- Central Administration > User Policy > added my account with Full Control to the web application.

So, when I browse to my site (https://sharepoint.com/test) I get the following error, on an otherwise blank white page:
An unexpected error has occurred.

{0}: If you have permission, you can use this page to temporarily close Web Parts or remove personal settings. For more information, contact your site administrator.

I tried going to the Web Part Maintenance Page, and nothing happened.  
I then edited the web.config to allow WSS_Medium trust level and then ran products and technology wizard again (since it also included an IISRESET).

Nothing changed.

So I went looking through the Application server logs and found this EventID 8306:
"An exception occurred when trying to issue security token: The server was unable to process the request due to an internal error.  For more information about the error, either turn on IncludeExceptionDetailInFaults (either from ServiceBehaviorAttribute or from the <serviceDebug> configuration behavior) on the server in order to send the exception information back to the client, or turn on tracing as per the Microsoft.NET Framework 3.0 SDK documentation and inspect the server trace logs..."

This is followed by a Warning (EventID 2138):
"The SharePoint Health Analyzer detected a condition requiring your attention.  The Security Token Service is not available.  The Security Token Service is not issuing tokens.  The service could be malfunctioning or in a bad state.  Administrator should try to restart the Security Token Service on the boxes where it is not issuing tokens.  If problem persists, further troubleshooting may be available in the KB article.  For more information about this rule, see (broken Microsoft URL).

I read here (http://sensoft2000-sharepoint.blogspot.com/2010/10/error-security-token-service-is-not.html) to go check out the "SharePoint Web Services Root" application pool in IIS (inetmgr) and make sure it was started (did an IISRESET) and while it was running, that didn't solve the error, either.

Before I end up breaking something, I wanted to ask if any of the experts here have run into the issue before.  Any help or advice would be greatly appreciated.

Thank you,

SPK
0
Comment
Question by:ThatSharepointGuy
  • 5
  • 2
8 Comments
 
LVL 4

Expert Comment

by:pritamsh
ID: 35674737
You need aply hotfix...Follow below mentioned article;

http://support.microsoft.com/kb/2465996
0
 
LVL 6

Author Comment

by:ThatSharepointGuy
ID: 35707405
Thanks, Pritamsh!

Unfortunately, the problem persists even after I apply the hotfix ;-(
0
 
LVL 6

Accepted Solution

by:
ThatSharepointGuy earned 0 total points
ID: 35916238
Just posting back in case anyone else has the same problem...

I'm assuming that this was because the two FIMS services had the incorrect account settings listed in the "log on" tab of the service properties in services.msc.  I changed them what they should have been, and everything worked beautifully afterwards.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
LVL 6

Author Closing Comment

by:ThatSharepointGuy
ID: 35950920
Fixed issue without EE member help.  Best of luck to anyone who has this issue, as I hear it can be caused by other, more nasty, issues.
0
 

Expert Comment

by:chrisp666
ID: 36223347
For the ignorant amongst us, what are FIMS services?

Thanks
0
 
LVL 6

Author Comment

by:ThatSharepointGuy
ID: 36224094
0
 

Expert Comment

by:chrisp666
ID: 36228643
Oh,lordy, the more I look into this, the more complicated it becomes. Thank you so much for your assistance.
0
 
LVL 6

Author Comment

by:ThatSharepointGuy
ID: 36230629
No problem!  Yea, it's pretty complicated, for sure!
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
In case you ever have to remove a faulty web part from a page , add the following to the end of the page url ?contents=1
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
Suggested Courses

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question