• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3604
  • Last Modified:

How do I set my ASA 5510 for 1Gb

Hi All,
I'm trying to figure out why my ASA only reports being capable of 100Mb on e0/0 and e0/1.  I have read that if the device it is plugged into (in my case, a Dell PowerConnect 2748) is 1Gb capable, it will run at that speed, but am finding this to be untrue (at least in my case anyway).  The PC2748 is a Gig switch (all ports are gig by default), but am still not seeing 1Gb within the ASA (sho int).
---------------------------------------------------------------------------
ASA# sho int e0/1
Interface Ethernet0/1 "INSIDE", is up, line protocol is up
  Hardware is i82546GB rev03, BW 100 Mbps, DLY 100 usec
        Auto-Duplex(Full-duplex), Auto-Speed(100 Mbps)
-----------------------------------------------------------------------------
I've tried to manually set the speed but to no avail (config t | if e0/1 | speed 1000). When I try this, I get an error stating that 1000 is not an option (options are 10/100/Auto).

Am I missing something?
       
0
PMGIT
Asked:
PMGIT
  • 2
  • 2
  • 2
  • +1
2 Solutions
 
Robert Sutton JrSenior Network ManagerCommented:
Is the intf you're connecting to gigabit capable?
Have you tried running the "Auto" option?

Let us know.
0
 
Robert Sutton JrSenior Network ManagerCommented:
And also.... Just an FYI...
You will need to purchase a security plus license(if you havent already) to get gigabit speed on the asa-5510 for ports e0/0 and e0/1.
0
 
PMGITAuthor Commented:
HI,
Yes, the int I'm connecting to is on the 2748 and all ports are gig (I double checked the specific int settings in the gui). Also, I do have the sec plus license:
sho ver
Licensed features for this platform:
Maximum Physical Interfaces  : Unlimited
Maximum VLANs                : 100
Inside Hosts                 : Unlimited
Failover                     : Active/Active
VPN-DES                      : Enabled
VPN-3DES-AES                 : Enabled
Security Contexts            : 2
GTP/GPRS                     : Disabled
VPN Peers                    : 250
WebVPN Peers                 : 2
Advanced Endpoint Assessment : Disabled
This platform has an ASA 5510 Security Plus license.
0
The IT Degree for Career Advancement

Earn your B.S. in Network Operations and Security and become a network and IT security expert. This WGU degree program curriculum was designed with tech-savvy, self-motivated students in mind – allowing you to use your technical expertise, to address real-world business problems.

 
Ernie BeekExpertCommented:
What version of the software are you using?

I remember returning an ASA once because it had no Gb interface.
I'd got those when I upgraded the software. Can't remember what software version it was implemented (7.x something) though. If you're able to, just go to 8.2.x should do the trick.
0
 
PMGITAuthor Commented:
Ah, okay... craigbeck's link may explain what is going on...
I ran into this myself. Gigabit was introduced in 7.3(2). But it was left out of 8.0(2).
I cannot speak for 8.0(3) - but I know it works as stated in 8.0(4).
That is with a Security Plus licence you can configure "speed 1000" on e0/0 and e0/1 (it will autodetect it as well).

I am currently running 8.0(2) - that figures.  I'll upgrade to 8.2 this weekend and see if that changes anything.  I'll split points between craigbeck and erniebeek because you're both saying the same thing (although un-verified to be correct as of yet).  
Thanks all!
0
 
Ernie BeekExpertCommented:
Good luck!

Let us know if this works out.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

  • 2
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now