Dell Precision M6500 laptop not reading P2 card

I have a dell precision M6500 laptop with an internal P2 card reader (smart card reader).  I downloaded the P2 drivers from panasonic but still cannot read the card.  The card is a Panasonic P2 R series AJ-P2C016RG.  I hear an audible beep when I insert the card but cannot see the drive under my computer.  Running Windows 7 Ultimate 64 bit.

What am I missing?
Lynn PerryFinancial ManagerAsked:
Who is Participating?
 
BlueThundaConnect With a Mentor Commented:
Here's the link to drivers for the Precision M6500's integrated Texas Instruments PCI8412 Memory Card/1394 Controller, sounds like this is what you're looking for:

http://support.us.dell.com/support/downloads/format.aspx?releaseid=R247353

There are 2 flavors to choose from, I suggest the PREM6500_DRVR_WIN_R247353.EXE update package at the top. The other contains the same drivers and will likely involve a few more steps for a more manual installation, if preferred. Confirmed that both are compatible with Win7 x64 ;)

Hope that does the trick!
0
 
BlueThundaCommented:
Make sure you've formatted the P2 card in the camera first, before inserting the card in the reader and installing the drivers.

Also, make sure your camera has the updated firmware to recognize the 16GB card or you'll not be able to format without updating. If that's the case you'll need to go to Panasonic's website to get the newer firmware for the camera.

Hope this helps ;)
0
 
Lynn PerryFinancial ManagerAuthor Commented:
Thank you for the response but I am not sure it that is our problem.  The card has been formatted and they have been recording on it.

I asked how he viewed it before the new laptop and he said he just put it in the internal reader on his old computer (Dell Vostro destop) and it recognized it as a drive.  When I insert the card on the new laptop, you hear the "beep beep" like when you insert a USB drive but we cannot see it under "my computer".  I looked at devices under control panel and under mass storage devices there is an exclamation point and it says no drive installed but he did download the Panasonic P2 driver and it shows in the tray as installed.  

The user did a bit of research and found a reference to it possibly being a mounting problem.  If the card was viewable on the old system, shouldn't the format be readable on the new?  

Does the mass storage device item have anything to do with the internal reader?
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
Craig BowmanIT Services ManagerCommented:
right click my computer and go to manage - this will bring up computer management
on the left side click disk management and see if you can see your drive in the list below.  
It may require you changing the drive letters of a cd rom or other drive in order for that stick to show up.
0
 
Craig BowmanIT Services ManagerCommented:
You can change them by right clicking and choosing change drive letter or path
0
 
Lynn PerryFinancial ManagerAuthor Commented:
In the computer management console, I only see the standard C and D for the single hardrive and the DVD.  I plugged 2 usb devices in which become E and F.  I then inserted the P2 card again and it still did not see it but it beeped like it does when new hardware is connected.  The device manager says I am missing the driver for "Mass Storage Controller" under "Other Devices".  I believe that is related to the card reader as it disappears when I eject the P2 card.  I thought windows would auto detect a driver as it does for USB devices.  I tried to search for the mass storage controller drvier but it found nothing when it search the internet.  Any thoughts?

I just set up the Dell auto update service and installed recommended updates for that system build but that did not solve the problem.

0
 
nobusCommented:
does it show in disk management?
0
 
nobusCommented:
...you may have to assign a drive letter
0
 
Lynn PerryFinancial ManagerAuthor Commented:
Thank you all for your help and comments.  BlueThunda directed me to the correct Dell drivers.  The first time I installed them, I did not have the card in and it said they installed but it still did not work.  I tried again with the card in and "jackpot", the card was recognized and a drive letter assigned.  Thank you again.  I really appreciate your willingness to help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.