?
Solved

Can't load LibXSLT.so

Posted on 2011-05-04
8
Medium Priority
?
661 Views
Last Modified: 2012-08-14
Hi to all,

The library system (koha) I am using require XML::LibXSLT. While trying to compile koha and run “make test” I got following error:

#   Failed test 'use C4::RotatingCollections;'
#   at t/00-load.t line 32.
#     Tried to use 'C4::RotatingCollections'.
#     Error:  Can't load '/usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/auto/XML/LibXSLT/LibXSLT.so' for module XML::LibXSLT: /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/auto/XML/LibXSLT/LibXSLT.so: undefined symbol: xsltRegisterLocalRVT at /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/DynaLoader.pm line

Can anyone help with this?
Thanks you
0
Comment
Question by:uknet80
  • 5
  • 2
8 Comments
 
LVL 12

Accepted Solution

by:
upanwar earned 1336 total points
ID: 35690111
This URL would help you to Debugging load library path issues.

http://mindspill.net/computing/linux-notes/debugging-load-library-path-issues.html

If you found that required package is not installed on your box and If you are using the RHEL 5 then you can know the package which containes the the dependent library file by executing the below given command.

# rpm -q --redhatprovides LibXSLT.so

you need rpmdb-redhat package to be installed on your system to use this option.

0
 

Author Comment

by:uknet80
ID: 35690573
I get same error for

Tried to use 'C4::Labels'.
Tried to use 'C4::Circulation'

do you think that is to do with dependacy, I am getting into a point were I don't know what to do???

I did run following:
$ perl -v
This is perl, v5.8.8 built for x86_64-linux-thread-multi

$ /sbin/ldconfig -v | grep libxslt
        libxslt.so.1 -> libxslt.so.1.1.17

$ xslt-config --libs
-L/usr/lib64 -lxslt -lxml2 -lz -lm

$ xslt-config --cflags
-I/usr/include/libxml2



I do really need help with this, i am not familiar with perl at all?
0
 
LVL 12

Assisted Solution

by:upanwar
upanwar earned 1336 total points
ID: 35692202
Could you please provide us output of

# cat /ect/redhat-release

# ldd /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/auto/XML/LibXSLT/LibXSLT.so
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 

Author Comment

by:uknet80
ID: 35695827
Red Hat Enterprise Linux Server release 5.4 (Tikanga)

LibXSLT.so path is different from the one you sent me it is as follow

[root@RHEL5-koha auto]# ldd /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/XML/LibXSLT/LibXSLT.so
        libxslt.so.1 => /usr/lib64/libxslt.so.1 (0x00002b67fa77d000)
        libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00002b67fa9b2000)
        libz.so.1 => /usr/lib64/libz.so.1 (0x00002b67facef000)
        libm.so.6 => /lib64/libm.so.6 (0x00002b67faf04000)
        libexslt.so.0 => /usr/lib64/libexslt.so.0 (0x00002b67fb187000)
        libgcrypt.so.11 => /usr/lib64/libgcrypt.so.11 (0x00002b67fb399000)
        libgpg-error.so.0 => /usr/lib64/libgpg-error.so.0 (0x00002b67fb60c000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00002b67fb80f000)
        libnsl.so.1 => /lib64/libnsl.so.1 (0x00002b67fba24000)
        libgdbm.so.2 => /usr/lib64/libgdbm.so.2 (0x00002b67fbc3d000)
        libdb-4.3.so => /lib64/libdb-4.3.so (0x00002b67fbe43000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00002b67fc138000)
        libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00002b67fc33d000)
        libutil.so.1 => /lib64/libutil.so.1 (0x00002b67fc575000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00002b67fc778000)
        libc.so.6 => /lib64/libc.so.6 (0x00002b67fc994000)
        /lib64/ld-linux-x86-64.so.2 (0x0000003ef1600000)



0
 
LVL 38

Assisted Solution

by:wesly_chen
wesly_chen earned 664 total points
ID: 35703044
How do you install "XML::LibXSLT" module for perl?
# perl -MCPAN -e "install XML::LibXSLT"
or
install rpm from rpmforge?
0
 

Author Comment

by:uknet80
ID: 35711113
can't install from CPAN, as CPAN try to fetch XML::LibXSLT v1.70, and this version require libxslt 1.1.18 and higher on RHEL5 only 1.1.17, is available and can't be updated or removed as it has lots of dependancy, then I install rpm:

perl-XML-LibXSLT-1.63-2.el5.rf.x86_64.rpm
perl-XML-LibXML-1.66-1.el5.rf.x86_64.rpm

0
 

Author Comment

by:uknet80
ID: 35711729
I have downloaded below packages and compiled it, this solve the problem thanks for everyone
XML-LibXML-1.59.tar.gz
XML-LibXSLT-1.59.tar.gz
0
 

Author Closing Comment

by:uknet80
ID: 35711731
thanks
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Often times it's very very easy to extend a volume on a Linux instance in AWS, but impossible to shrink it. I wanted to contribute to the experts-exchange community a way of providing a procedure that works on an AWS instance. It can also be used on…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Six Sigma Control Plans
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question