?
Solved

No Internet on HTC Aria

Posted on 2011-05-04
8
Medium Priority
?
414 Views
Last Modified: 2012-05-11
I have just put my Optus sim card into a new HTC Aria and I can't seem to get the internet to work.
It worked fine on my last phone. I am new to Android.

Any ideas?

0
Comment
Question by:nealerocks
  • 4
  • 3
8 Comments
 
LVL 12

Expert Comment

by:xmlmagician
ID: 35688368
you might need a 3G card depending on how things are setup in the asian networks. I assume that you have checked that you are on the right tariff that allows you 3G connectivity etc. what was your old phone?
0
 
LVL 12

Author Comment

by:nealerocks
ID: 35688377
Old phone was windows mobile. The internet worked fine up until 10 minutes ago when I put the sim card into the new phone.
I have had this plan for ages.
0
 
LVL 11

Accepted Solution

by:
RedLondon earned 2000 total points
ID: 35688392
Sounds like you need to give your Android phone the APN details for your provider

http://ausdroid.net/apns/ seems to have the details for Optus...

Settings ->
Wireless & Networks ->
Mobile Networks ->
Access Point Names ->
*Hit the Menu button* -> New APN

Name: Optus Yes Internet
APN: yesinternet
Proxy:
Port:
Username:
Password:
Server:
MMSC:
MMS Proxy:
MMS Port:
MMS Protocol (Android 2.1+): WAP 2.0
MCC: 505
MNC: 02
Auth Type: PAP
APN Type: internet or default
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
LVL 11

Expert Comment

by:RedLondon
ID: 35688407
The Optus website can send you the settings by SMS too ... http://optusau.wdsglobal.com/mainPage.html looks to be where you need to go.  Picking any Android phone name from the list should be OK if yours isn't listed.
0
 
LVL 12

Author Comment

by:nealerocks
ID: 35688421
I entered the APN details, do I need a reboot or anything?
0
 
LVL 12

Author Comment

by:nealerocks
ID: 35688435
I changed it from "internet" to "default" and it connected straight away.

Thats very much!
0
 
LVL 12

Author Closing Comment

by:nealerocks
ID: 35688437
Brilliant!
0
 
LVL 11

Expert Comment

by:RedLondon
ID: 35688445
I don't think you need to reboot but I guess it wouldn't hurt to try.

Settings -> Wireless & Networks has an option labelled "Mobile network", it needs to be ticked to allow data - without it being ticked you can only use voice.  Is it ticked?

Presumably you can make/receive calls, so you know you're connected to the network and this is just a data issue?
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this post we will learn how to connect and configure Android Device (Smartphone etc.) with Android Studio. After that we will run a simple Hello World Program.
In this post we will learn how to make Android Gesture Tutorial and give different functionality whenever a user Touch or Scroll android screen.
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Suggested Courses

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question