Flash file appears in Firefox/Chrome but not IE?

I'm building a .net site and have flash files embedded in pages, example code below. For some reason it's coming up fine in Firefox and Chrome, but hanging up in IE. The page won't load properly, all I get is the static HMTL stuff. Any ideas?


<object id="blahblahblah" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" height="178" width="465" align="middle" classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"><param value="sameDomain" name="allowScriptAccess"/><param value="http://www.blahblahblah.com/flash/CTS2.swf" name="movie"/>  <embed src="http://www.blahblahblah.com/flash/CTS2.swf" quality="high" bgcolor="#ffffff" width="465" height="178" name="blahblahblah" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer"></embed></object>
scogordoAsked:
Who is Participating?
 
dgofmanConnect With a Mentor Commented:
I don't know where did you get so old implementation of HTML :)

codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0"

You will not able to run latest Flex or Flash SWF file using Flash Player 8

  <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="465" height="178" id="blahblahblah">
                <param name="movie" value="http://www.blahblahblah.com/flash/CTS2.swf" />
                <param name="quality" value="high" />
                <param name="allowScriptAccess" value="sameDomain" />
                <param name="allowFullScreen" value="true" />
                <object type="application/x-shockwave-flash" data="http://www.blahblahblah.com/flash/CTS2.swf" width="465" height="178">
                    <param name="quality" value="high" />
                    <param name="allowScriptAccess" value="sameDomain" />
                    <param name="allowFullScreen" value="true" />
                    <a href="http://www.adobe.com/go/getflashplayer">
                        <img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash Player" />
                    </a>
                </object>
            </object>

I hope you will change URL to your domain bcz is invalid

http://www.blahblahblah.com/flash/CTS2.swf
0
 
edemcsCommented:
change src to href in your embed tag
0
 
CWS (haripriya)Commented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.