[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 683
  • Last Modified:

Problems with Windows 7 share

Hi, I'm having a problem with a client's share folder.  The client has a Windows 7 Professional PC.  All the basics seem right: Network Discovery is turned on, sharing is turned on, password protected sharing is turned off, the Everyone user is granted full access, and I disabled the group policy that won't accept blank passwords.  I aslo tried creating a test account on both computers with identical names and passwords and added that name to the share.  I played around with the credentials manager on Windows 7 with the names and passwords mentioned.

Two XP Professional computers on the same workgroup can map to the folder.  One XP Professional laptop and one Windows 7 Home Premium desktop can't access the folder.  They can see the host computer in Networks and can ping it by name or IP address.  But in both cases, they get an "Enter network password" dialog box and no matter what user name and password we use, they keep getting the same bad user name and password error.  I also tried

1. diabling startups and non-MS services
2. removing the antivirus
3. disabled the firewalls on each PC.  

The computers are on a workgroup called RESOURCECENTER.  I'm including a picture of the dialog box.  I notice that the dialog is calling RESOURCECENTER a domain.  Also the PCs are not on a domain but I see some domain mentioned in the same dialog box.

What bothers me is that two PCs have no problem and the other two can't connect. Any help would be appreciated!
 
Enter network password dialog
0
sexygeek
Asked:
sexygeek
1 Solution
 
JRasterCommented:
What OS is the client connecting too?  
0
 
Jackie ManCommented:
For your windows 7 pc, try the following.


According to Arthur Xie, it says:-

"The policy is:

Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Network security: LAN Manager authentication level

If your system is Windows 7 Home Premium, you may change it from Registry.

1. Launch regedit from Start Search box.
2. Find the following branch.
 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

3. Create a DWORD key under Lsa and set:

Name: LmCompatibilityLevel
Value: 1

4. Restart."

Source: http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/91fe4e10-a0d4-45db-94df-fad885d8f64f
0
 
sexygeekAuthor Commented:
Thanks Jackieman, I'll try that and get back.  To JRaster, the host of the share is Windows 7 Pro.  There are 4 clients.  Three XP Pro, two of which can map the folder and one Windows 7 Home Premium which along with one XP Pro cannot.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
Jackie ManCommented:
For the xp pc which cannot access the network share, run the command below in command prompt and post back your results.

       net use *
0
 
Jackie ManCommented:
Besides, if you have remote or physical access and admin rights to the windows 7 home premium host pc, also check the registry on whether lmcompatability level has been added and post back what value has been set for that entry.

http://technet.microsoft.com/en-us/library/cc960646.aspx
0
 
ocanada_techguyCommented:
In my experience what sometimes happens is the client machine A (XP say) connects to the file server machine B (Win 7 in your case) as the special "Guest" account.  This most often happens if you A are connecting to a shared printer on B.  Once that happens, all other connection attempts default to the same Guest account, but if Guest is not allowed access to certain files shares, and with even feeble security settings the Guest account would NOT be allowed access to those, well then the OS "goes through the motions" of failing the connection and then requesting alternate credentials.  The problem comes when even if you provide perfectly valid credentials in that dialog, it still does not connect.  See you cannot connect from machine A to machine B as multiple different credentials during the same session, so either a reboot (which doesn't help if the machine just up an reconnects the printer on reboot)
What you can try to do is DISCONNECT all connections from the client to the other machine, AND THEN try using the Map Network Drive wizard to connect using the CORRECT credentials FIRST.
On machine A go to Explorer and then Tools, Disconnect Network Drive... and see what connections to \\machineB\whatever already exist, ask yourself what are those and how they happened, and disconnect them.  THEN use Explorer, Tools, Map Network Drive, choose a letter like Z: and specify \\machineB\sharename, AND, HERE IS THE IMPORTANT PART. click the Connect using a different user name.  In that dialog specify NAMEOFMACHINEB\USernamethatexistsonmachineb for the user and the corresponding password.
Alternatively, on Machine B, under Computer Management you can look in the System Tools Shared Folders branch to see what Shares have how many existing Client connections and Sessions to see what connections those are, and disconnect them from that side (but they may reconnect if the client refreshes the connection)

map-network-username.JPG
0
 
sexygeekAuthor Commented:
These steps were necessary but the final answer was that this workgroup was sharing a LAN with a Windows Domain group which they had beed organizationally descended.  So there were computers with the same NETBIOS name in the domain and consequently there were name resolution problems.  I fixed this by putting a router in between and now everything connect with no issues.  Thanks for the help!
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now