Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Dell 3548 Vlan question

Posted on 2011-05-04
14
Medium Priority
?
1,659 Views
Last Modified: 2012-05-11
Ok i have  4 3548's all connected by fiber to each other and then to a 2 stack 3448p that connects via fiber to a 6224F.  THere is a cisco router that is doing the sub interfaces and dhcp relay, I am installing a shoretel VOIP system.  I currently have a data vlan of 120 and a voice vlan that i created new of 125.  if i put the port in general mode and add both 125 and 120 tagged i get nothing, or if i tag 125 and leave 120 untagged i get nothing.  if i set the pvid for the interface i get a 120 address on the phone and a 120 address on the pc plugged into the phone.  If i remove 120 and put the port in access mode 125, both phone and pc get a 125 address.  trunk mode doesn't work at all. if i statically assign and address to phone for 125 while its in general mode, it will work.  one workaround i found is that if i manually set the phone to tag traffic and set it to vlan 125, with the port in general and both 120 and  125 tagged with the pvid as 120 then the phone gets a 125 address like it should and the pc gets a 120 address as it should.  my question is, should i have to manually tag from the phone for this to work?

attached is the current config.

thanks
stat2.txt
0
Comment
Question by:jasonmichel
  • 7
  • 6
13 Comments
 
LVL 26

Expert Comment

by:Soulja
ID: 35693664
Okay, so your router is performing the routing for all the vlans? Are you daisy chaining phone and pc's, or plugging the pc's directly as well as the phone to their respective ports? Do you have ip helpers on the subinterfaces that you created?
0
 
LVL 1

Author Comment

by:jasonmichel
ID: 35694496
Yes I am plugging pcs into phones, yes I have dhcp helpers on the sub int
0
 
LVL 26

Expert Comment

by:Soulja
ID: 35698510
You need to add:

voice vlan id 125

This should let the switch know that this vlan is for the phones.

One the ports add:

voice vlan enable
voice vlan secure

Voice vlan enable will automatically configure the vlan voice configuration for the port.
0
Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

 
LVL 26

Expert Comment

by:Soulja
ID: 35698516
0
 
LVL 1

Author Comment

by:jasonmichel
ID: 35698889
Did you see my config?  I did all that which is why I can't figure out why I still have to set the phones to tag to get it to work
0
 
LVL 26

Expert Comment

by:Soulja
ID: 35698959
So port 25 is the port you are testing on? That is the only one I see voice vlan enable on.
0
 
LVL 26

Expert Comment

by:Soulja
ID: 35698987
Which switch's config did you post? One of the 3548's. Am I seeing this correctly?

interface vlan 1
ip address 10.15.120.24 255.255.255.0
exit
interface vlan 1
ip address 10.15.125.24 255.255.255.0


Also, why do you have vlan interfaces on this switch if it is a 3548 if they don't have ip address attached to them?
0
 
LVL 1

Author Comment

by:jasonmichel
ID: 35699111
just for management purposes, yes i posted one of the 3548's  not sure what port 25 has to do with?  i did those commands you typed, so if i do the voice enable, then i shouldn't have to add the data vlan to that port as well correct?
0
 
LVL 26

Accepted Solution

by:
Soulja earned 2000 total points
ID: 35699250
If the pc is going to be connected to the port as well I, the data vlan will have to be on the port as well.

Try this on a port (Just a stab at it):

switchport access vlan 120
voice vlan enable
0
 
LVL 1

Author Comment

by:jasonmichel
ID: 35701002
Port e30: Configuration cannot be applied in the current port mode
nursesta2sw(config-if)#
0
 
LVL 26

Expert Comment

by:Soulja
ID: 35701141
Did you try removing the general mode from the port first? no switchport general ?
0
 
LVL 1

Author Comment

by:jasonmichel
ID: 35701149
yes
0
 
LVL 1

Author Comment

by:jasonmichel
ID: 35701151
i think when you put in access mode, its only allowed for that vlan
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, WatchGuard's Director of Security Strategy and Research Teri Radichel, takes a look at insider threats, the risk they can pose to your organization, and the best ways to defend against them.
Unable to change the program that handles the scan event from a network attached Canon/Brother printer/scanner. This means you'll always have to choose which program handles this action, e.g. ControlCenter4 (in the case of a Brother).
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question