ValidatorCalloutExtender works but RangeValidator message also shows

I have a gridview. Here's a part of it...

 <asp:TemplateField HeaderText="Unit Price" ItemStyle-Width="100px">
                        <ItemTemplate>
                            <asp:TextBox CausesValidation="true" CssClass="bf_textbox" ID="txtUnitPrice" AutoPostBack="true" runat="server"></asp:TextBox>
                            <asp:RangeValidator ID="RangeValidator1" runat="server" ControlToValidate="txtUnitPrice" ErrorMessage="Invalid. Numbers and 2 decimals only." MaximumValue="99999999" MinimumValue="-9999999" Type="Currency">Invalid. Numbers and 2 decimals only.</asp:RangeValidator>
                            <cc1:ValidatorCalloutExtender ID="RangeValidator1_ValidatorCalloutExtender" runat="server"
                                Enabled="True" TargetControlID="RangeValidator1">
                            </cc1:ValidatorCalloutExtender>
                        </ItemTemplate>
                        <ItemStyle Width="100px" />
                    </asp:TemplateField>

PROBLEM: When I type in an invalid entry the ValidatorCalloutExtender AND the text for the RangeValidator appears. I only want to see the callout message. How can I do this? I do NOT want to see the RangeValidator message. Thanks.
LVL 9
RobertNZanaAsked:
Who is Participating?
 
CodeCruiserCommented:
Add "Display=None" to the rangevalidator.
0
 
RobertNZanaAuthor Commented:
Enjoy the easy points. Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.