?
Solved

Connecting Cisco 3825 router to Catalyst 3560G via HWIC-1GE SFP

Posted on 2011-05-04
14
Medium Priority
?
2,165 Views
Last Modified: 2012-05-11
I have a Cisco 3825 router with HWIC-1GE SFP installed and connected. I need to trunk it and connect it to Cisco Catalyst 3560G switch. I can't seem to figure this one out. I have 2 VLANs that need to go thru this one link.
Attached is the image of what I am trying to do, called Cisco 3 times now, waste of my time.
 Below are the configs:
Switch:
interface GigabitEthernet0/52
 description TO 3825-Router Gig 0/0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed nonegotiate

Router:

interface GigabitEthernet0/0/0
 no ip address
 negotiation auto
interface GigabitEthernet0/0/0.70
   encapsulation dot1q 70
interface GigabitEthernet0/0/0.92
   encapsulation dot1q 92




 product-data-sheet0900aecd8016be.jpg
0
Comment
Question by:yachtingpromotions
  • 7
  • 6
14 Comments
 
LVL 26

Expert Comment

by:Soulja
ID: 35693724
You need to assign the ip addressed to those subinterfaces also. They will then be the default gateway for their respective VLAN.
0
 
LVL 26

Expert Comment

by:Soulja
ID: 35693744
For example:

interface GigabitEthernet0/0/0.70
description Engineering
capsulation dot1q 70
ip address 192.168.70.1 255.255.255.0
 
 interface GigabitEthernet0/0/0.92
description Accounting
encapsulation dot1q 92
ip address 192.168.92.1 255.255.255.0

interface GigabitEthernet0/0/0.93
description Voice
encapsulation dot1q 93
ip address 192.168.93.1 255.255.255.0


0
 

Author Comment

by:yachtingpromotions
ID: 35693785
The problem is that these VLANs are already defined and have IP addresses. So when you try to assign an IP to the subinterface it states that "IT IS OVERLAPPING WITH VLAN #"  see below:

interface Vlan70
 ip address 192.168.10.1 255.255.255.0
 ip access-group 123 in
 ip flow ingress
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
!

interface Vlan92
 ip address 66.175.117.129 255.255.255.128
 ip virtual-reassembly
 ip route-cache flow
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 26

Expert Comment

by:Soulja
ID: 35693873
Oh, you said you needed the vlans to go through the link, so I assumed you meant they needed to be routed by the 3825 router. Okay, so they are already routing between each other. Okay, so you don't need subinterfaces then. Subinterfaces on the ethernet ports are for if you wanted the router to perform the vlan routing. What you need to do is change the switchport connect to the router into a routed port. I see that you are using nat. Which port is the nat outside. Can you post the switch config? Thanks
0
 

Author Comment

by:yachtingpromotions
ID: 35694051

NAP-CORE-SWITCH#sh run
Building configuration...

Current configuration : 5921 bytes
!

!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname NAP-CORE-SWITCH
!
boot-start-marker
boot-end-marker
!
logging buffered 52000
no logging console!

aaa new-model
!
!
aaa authentication login default local
aaa authentication login sdm_vpn_xauth_ml_1 local
aaa authorization exec default local
aaa authorization network sdm_vpn_group_ml_1 local
!
!
!
aaa session-id common
clock timezone EST -5
clock summer-time EDT recurring
system mtu routing 1500
ip name-server 4.2.2.2
ip name-server 69.25.1.1
ip name-server 4.2.2.1
!
!        
!
!
crypto pki trustpoint HTTPS_SS_CERT_KEYPAIR
 enrollment selfsigned
 serial-number
 revocation-check none
 rsakeypair HTTPS_SS_CERT_KEYPAIR
!
!
 
  quit
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface GigabitEthernet0/1
interface GigabitEthernet0/51

interface GigabitEthernet0/52
 description TO 3825-Router Gig 0/0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed nonegotiate
!
interface Vlan1
 ip address 192.168.10.9 255.255.255.240
 no ip route-cache
 no ip mroute-cache
!
ip default-gateway 192.168.10.1
ip classless
ip http server
ip http secure-server
!
ip sla enable reaction-alerts
!

!
line con 0

!
end
0
 
LVL 26

Expert Comment

by:Soulja
ID: 35694926
Okay, what device has the interfac vlan 70 and 92. Could you post that config? Thanks
0
 
LVL 6

Expert Comment

by:Wissam
ID: 35695641
what we mean is configuring the ip address under the subinterface in the router itself, this ip configured will be the default gateway for PCs in the specific vlan
0
 

Author Comment

by:yachtingpromotions
ID: 35697964
Soulja, router has vlan 70 and 92 see above, I posted vlan interfaces already.



WPRARAON:

READ the whole post, you can't assign an IP address to a subinterface that is within a certain VLAN, overlapping will occur......
0
 
LVL 26

Expert Comment

by:Soulja
ID: 35698277
I say scrap the vlan interfaces and create the subinterfaces of the gig connection similar to what I specified earlier. This should work for you. Also apply the necessary nat commands that you had on the vlan interfaces.
0
 

Accepted Solution

by:
yachtingpromotions earned 0 total points
ID: 35720331
Thank you all for the great response, unfortunately many of you (like myself) were close but not close enough. Here's a solution:

On a router side create subinterfaces but DO NOT put ip addresses on them, use BVI bridge groups instead:

interface GigabitEthernet0/0/0
 no ip address
 negotiation auto
!
interface GigabitEthernet0/0/0.1
 encapsulation dot1Q 70
 bridge-group 1
!
interface GigabitEthernet0/0/0.2
 encapsulation dot1Q 1 native
!
interface GigabitEthernet0/0/0.92
 encapsulation dot1Q 92
 bridge-group 92

Then where your vlans were reference the Bridge groups and put all the configs that use to be on vlans on BVI interfaces including IP addresses.

interface Vlan70
 no ip address
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Vlan92
 no ip address
 bridge-group 92
 bridge-group 92 spanning-disabled

!
interface BVI1
 ip address 192.168.10.1 255.255.255.0
 ip access-group 123 in
 ip flow ingress
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
!
interface BVI92
 ip address XX.XXX.XXX.X0 255.255.255.240
 ip virtual-reassembly
 ip route-cache flow

Don't forget little details:

bridge 1 protocol ieee
bridge 1 route ip
bridge 92 protocol ieee
bridge 92 route ip

ON the switch side normal config for trunking:

interface GigabitEthernet0/52
 description TO 3825-Router Gig 0/0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed nonegotiate

(the reason why the speed in this config is nonegotiate because it is predetermined by HWIC-1GE-SFP, that only operates at 1000 and full duplex.)

This configuration was done with SFP port on both router Cisco 3825 Adv Ip Serv. and switch 3560 G. Remember if you have 3800 series router, The SFP port that is next to G interfaces doubles as a G 0/0 and G 0/1 ports, so if those two ports are in use you must get a HWIC-1GE-SFP (in my case) to acquire another G interface G 0/0/0.
0
 

Author Comment

by:yachtingpromotions
ID: 35720377
thanks.
0
 
LVL 26

Expert Comment

by:Soulja
ID: 35720758
You do know however that the solution you provided using BVI's doesn't represent the solution for the original question and topology you provided. Nevertheless good luck.
0
 

Author Comment

by:yachtingpromotions
ID: 35721586
Yes it does, but to each it's own Soulja. Perhaps you misunderstood the question and my setup, best of luck to you.
0
 

Author Closing Comment

by:yachtingpromotions
ID: 35759407
Thank you all.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
Why do some people recommend buying business VoIP from an ISP? What are the benefits to my company? What are the costs?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question