?
Solved

CCR Re-Seed fails with comain controller issue after failed copy status

Posted on 2011-05-04
7
Medium Priority
?
1,100 Views
Last Modified: 2012-05-11
I have a CCR cluster at my head end.  It replicates to an SCR target at a disaster recovery site.  The SCR target acts as its own hub transport server, and I have an additional hub transport at the head end.

Yesterday we were doing some power testing for our new UPS equipment, and inadvertently shut down power for all servers simultaneously.  When the exchange cluster came back up, the copy status for two out of the four storage groups came back as failed.  I attempted running the update storage group on both from the GUI.  I also tried running the update-storagegroupcopy -identity "mail group 1" command in the CLI (elevated to run as admin).  It returns an error stating that the mailbox group "could not be found on domain controller."

The other two storage groups are running fine, and so were these before the outage... so it islt likely a permissions or sharing issue.  Any suggestions?
0
Comment
Question by:jat0818
  • 4
  • 3
7 Comments
 
LVL 8

Expert Comment

by:ckeshav
ID: 35696813
Hope you are running this from the passive node. Make sure you select "Delete any existing Transaction logs in the Target Path"

http://www.msexchange.org/articles_tutorials/exchange-server-2007/high-availability-recovery/exchange-2007-service-pack1-managing-ccr-cluster-using-exchange-management-console.html
0
 

Author Comment

by:jat0818
ID: 35701193
yes, I am running this from the passive node.  And for one of the mail groups, I actually deleted all database files and logs and attempted to enable storage group copy from scratch.  i still get the error about the object not existing in active directory.  On the second failed storage group, I left everything intact, and tried to reseed, and I did select the option to delete any existing transaction logs in the target path.  Still nothing.
0
 
LVL 8

Expert Comment

by:ckeshav
ID: 35703595
Can you post the exact error message
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:jat0818
ID: 35706283
Update-StorageGroupCopy : The operation could not be performed because object '
mail group 2' could not be found on domain controller 'VDCa.alpha.local'.
At line:1 char:24
+ update-storagegroupcopy <<<<
    + CategoryInfo          : NotSpecified: (0:Int32) [Update-StorageGroupCopy
   ], ManagementObjectNotFoundException
    + FullyQualifiedErrorId : 35D2A146,Microsoft.Exchange.Management.SystemCon
   figurationTasks.UpdateStorageGroupCopy
0
 

Accepted Solution

by:
jat0818 earned 0 total points
ID: 35721800
I found the solution to this... it seems that when i type the command update-storagegroupcopy -identity "mail group 2" the command seems to assume that the primary server node name is what should be used to look up the mail store.  This is not the case.  When using this command, it appears you have to explicitly  specify the exchange cluster name... this isn't specified on technet, nor do a lot of the examples of the use of this command seem to show it either.  Maybe this is just something specific to my setup.  Anyway, after specifying the cluster name the command worked properly and the reseed is completing now.
0
 
LVL 8

Expert Comment

by:ckeshav
ID: 35721997
ok
0
 

Author Closing Comment

by:jat0818
ID: 35759430
Upon completing my own research, this solution worked for me and solved the initial question I was asking.
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Eseutil Hard Recovery is part of exchange tool and ensures Exchange mailbox data recovery when mailbox gets corrupt due to some problem on Exchange server.
This article will help to fix the below errors for MS Exchange Server 2016 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

612 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question