[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 278
  • Last Modified:

Need help to move WSS 3.0 server to new server in 2 server farm

I have WWS 3.0 installed in a 2 server Farm (Srv1 has Web server and search server, Srv2 is SQL2005 DB server). I have created a new VM server as the new home for the Web server and search server roles. This VM has the same OS and patches as Srv1. I am a little confused as to how the move is done. In some articles they say a WSS backup needs to be done and then WSS installed on the new server and then the back up restored to the new server. In another article it says that i run the SP Prod and Tech Config Wizard and choose Adavanced install and choose to have this server be a front end to an existing Farm. This second method makes the most sense since the Config data is stored in the Config DB. It also seems that i caould choose to have the Central Admin Application web site hosted on the new server at the same time as its still on the old server. I really want to have the existing server continue to serve all my end users while the new server is brought online and tested to make sure it works completely before i remove WSS from the old server. Any suggestions?
0
Joseph Strong
Asked:
Joseph Strong
  • 2
  • 2
1 Solution
 
FastpayITCommented:
Since you are just moving the web front-end then the method of just adding the new server to the farm and selecting it to host the Central Admin Application will work. Then remove the old server from the farm. I've done this in the past and it works fine. It's moving the databases that gets tricky...
0
 
Joseph StrongIT ManagerAuthor Commented:
Will this simple procedure allow the new server to provide all the functions of the old server except as DB server?
0
 
FastpayITCommented:
Yes, because the configuration is stored in the database not on the web servers. That's why you can have a "farm" of front-end servers to serve up the content.
0
 
Joseph StrongIT ManagerAuthor Commented:
i have been able to get the new server up and running and i have changed the Central Admin mappings to the new server and that works. I would like to browse to the new server to confirm  the web app is fully functional on it, but when i go to the http://{new server} i get redirected to http://{old server} instead. I would like to have all my users still access the old server while i test the new one, so i don't think changing the Alternate Access Mappings settings is what i want to do. I can i have both servers serve the Web App at the same time?
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now