Cannot uninstall SQL Server 2008 on Server 2008 SP2

Had Sharepoint 3 installed on a Windows Server 2008 SP2 server (also a domain controller - but not primary) and was looking to upgrade to Sharepoint 2010 Foundation.  After trying to get Sharepoint working, I ended up uninstalling all SQL versions, and reinstalling.  I've uninstalled/reinstalled a number of SQL versions - mainly SQL 2008 Server Express, and SQL 2008 R2 Server Express.  Now when I try to uninstall the  "Microsoft SQL Server 2008 (64-bit)" in Add/Remove Programs, all the checks pass, but all that comes up is "Redistributable Features" - it runs through the uninstall and then at the end of the process it comes up with the error as in the attachment.

SDK option is now stuck in the uninstall, but the" Redistributable Features" was there first.

What do I do
Error.jpg
ErrorA.jpg
badzsterAsked:
Who is Participating?
 
badzsterConnect With a Mentor Author Commented:
Don't know what fixed it in the end...
0
 
ajwukTechnical Consultant / Project ManagerCommented:
Hi,
 Try removing the Native Client first and then the SQL components.
You could also try locating the component GUID in the registry under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\ and then run msiexec /x "{GUID}"

HTH.
0
 
Alpesh PatelAssistant ConsultantCommented:
Please remove SQL in sequence. Some small packages and then after full SQL Server.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
dejaanbuCommented:
try a repair-install first
and then follow

http://support.microsoft.com/kb/955499
0
 
badzsterAuthor Commented:
Thanks all - but no luck still.  I've now installed the full version of SQL which installs an instance succesfully according to the installation and Studio Management but it is not accessible.  The inly SQL service that is set to automatic is the SQL VSS Writer - when I try to start this service the message reads:  Error 14001: The application has failed to start because its side-by-side configuration is incorrect.

In the application log it says:

Activation context generation failed for "C:\Program Files\Microsoft SQL Server\90\Shared\sqlwriter.exe". Dependent Assembly Microsoft.VC80.CRT,processorArchitecture="amd64",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.4027" could not be found. Please use sxstrace.exe for detailed diagnosis.
0
 
badzsterAuthor Commented:
Tried a whole heap of solutions that finally worked after 10 restarts.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.