Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1974
  • Last Modified:

SBS 2008 Internet Address Wizard cannot configure Exchange e-mail for your Domain

I've inherited an SBS 2008 server that was went through some sort of migration from an SBS 2003. SBS 2008 best practices has a number of issues that smacks of an incomplete migration.

I've already fixed a number of errors that prevented connect to the internet wizard and fix my network wizard from completing.

Now I'm stuck at this message and it prompts me to go back to fix my network task. When I go back to this it runs fine with a warning concerning DNS client not configured to point only to the internal IP address of the server.

This message also shows up in the Best Practices Analyser. I've seen links that deal with this same message but none show in relation to this situation.

I know I have a list of things to fix still from the BPA but was hoping to get to this problem first. Users are getting a security alert in when they first open outlook stating remote.company.com Informaion you exchange with this site cannot be viewed or changed by others. However, there is a problem with the sites security certificate. The name on the security certificate is invalid or does not match the name of the site.

Trying to change the site name from remote.company.com to mail.company.com

I think the previous support had some sort of outside certificate and I'm just wanting to use a self signed certificate from the SBS.

Any help is appreciated.
0
Terrymac_Computer_Guy
Asked:
Terrymac_Computer_Guy
  • 6
  • 4
  • 3
4 Solutions
 
Cliff GaliherCommented:
You've actually asked two questions here. For the sake of focusing on issues, you should choose one and focus on it, and post another question for your other issues. This helps experts focus and understand an issue, helps get answers marked as "answered" more quickly, and helps future problem seekers find their answers through search engines. Wading through a "question" with 10 separate bullet-pointed issues, as an extreme example, I'm sure you can see that finding the correct solution for just one bullet point would be quite frustrating.

So, do you want to work on your DNS issue in this question or your certificate issue?

-Cliff
0
 
Cliff GaliherCommented:
On re-reading the question, while I still see that there are two issues mentioned, I also (slowly) realized that it would be best to focus on the DNS issue first. Doing so will allow you to run the IAW and fix the second issue "properly" instead of working around the wizard.

The error you are getting is pretty straightforward. Go into the NIC properties and remove any DNS IP addresses that aren't pointing to the SBS server itself.

That will resolve the DNS client error and you can see if the FMNW runs properly.

-Cliff
0
 
connectexCommented:
The DNS issue is quite simple. The SBS server is a automatically configured to be the DNS server for your network. It resolves all the DNS requests from the internal network. So proper setup is to under have one DNS address listed in the TCP/IP properties. The one address should be the IP address of the SBS server.

As for the certificate and host name for the RWW and other SBS sites. You run the "Setup your internet address" wizard. It will create the self-signed certificate and by default uses remote.domain.com. There's an advanced option on the domain entry page that will let you change remote to mail or anything else you desire.

-Matt-
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
Terrymac_Computer_GuyAuthor Commented:
OK I removed the second ip for the server 2003 dc/dns in the network addapter TCPIP 4 setttings. And then had to remove the DNS forwarders and the fix network completed with only warning of the router.

I ran the connect to the internet wizard and this ran fine now too. Somewhere in the process the DHCP had to be fixed to serv IPv6. and I had to add the 003 router ip address in the DHCP server options.

However running the Internet address Management wizard fixes the remote web workplace and erros out with this message
The wizard cannot configure Exchange e-mail for your domain. To correct this problem, run the Fix my network task.

Can't seem to get past this point still.

I think its concerning the certificate. My understanding is that there was a purchased certificate but its expired now. I'm trying to just use the internal self signed. Do I need to remove the other certificate first? Also it may have been using the "remote" prefix and I'm trying to use "mail" for the prefix so mail.mycompany.com

0
 
connectexCommented:
Yes, remove the exisiting certificate via the link on the right hand side. Then run the "Setup your internet address" wizard again, it will issue a new self-signed certificate. The self-signed certificate will be good for the next two years. When it's about expired you will need to run the "Setup your internet address" wizard again to get a certificate that's good for another two years.

-Matt-
0
 
connectexCommented:
Also remember to used the advanced option on the domain entry page of the "Setup your internet address" to change the default remote.domain.com to mail.domain.com.

-Matt-
0
 
Terrymac_Computer_GuyAuthor Commented:
Hey Matt where is the link on the right hand side? I can't see it in the Windows SBS console.
0
 
connectexCommented:
In the Windows SBS Console. Choose Network from the buttons on the top row. Click on the Connectivity tab. If the certificate was installed via the SBS console you should see "Remove this trusted certificate". See the image.
Connectivity-tasks.JPG
0
 
Terrymac_Computer_GuyAuthor Commented:
No there only shows add a trusted certificate

The internet domain name shows configured with mail.mycompany.com

and

Webserver certificate shows Self-Issued

Server Firewall shows Off ??
0
 
Terrymac_Computer_GuyAuthor Commented:
More info

The exchange server is able to send and receive email fine.

There is a smart host configured to send email.
0
 
Terrymac_Computer_GuyAuthor Commented:
I have this again in the BPA
DNS client not configured
The DNS Client is not configured to point to the internal IP address of the server.
I've fixed this already once.

I'm wondering if the wizards are changing this back to the way it was?
0
 
Cliff GaliherCommented:
No, but your DHCP changes may be. From what I've read, you are doing a fair amount of manual configuration, which causes all sorts of unpredictable behavior. SBS wizards properly set up the NIC and all DHCP options by default. You shouldn't need to be making ANY changes. It may be time to call in a paid professional to scrub the entire system and get it back to a supportable state.

-Cliff
0
 
Terrymac_Computer_GuyAuthor Commented:
While the issues weren't fully resolved the help was good enough to attmpt repair and then draw the conclusion of none repairable.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now