Can I still run this adprep / gpprep after this 2008 R2 server is now a DC/GC server?

Posted on 2011-05-04
Last Modified: 2012-05-11
I executed the command adprep /forestprep and next, executed adprep /domainprep. But forgot to run adprep /gpprep before runnig DCPROMO.

The server 2008 R2 is now a domain controller and a global catalogue server seems to be running fine. One problem I’m having is windows 7 workstations does not get the users to the correct Home directory location but XP workstations do get the home directory fine.

Question is can I still run this adprep / gpprep after this 2008 R2 server is now a DC/GC server? Do I need to?
Question by:Terrymac_Computer_Guy
    LVL 76

    Accepted Solution

    Presumably you run /domainprep /gpprep when you upgraded your AD from 2000 to 2003. It does not seem that you need to run it now:
    As far as your windows 7 issue, this has to be checked using your GPO/Group policy preferences.
    Use GPMC to get the group policy results to see whether the unexpected behavior is a result of policy or preference.
    LVL 8

    Assisted Solution

    As mentioned by arnold you shouldn't need to run adprep /gpprep but there is no harm in doing so either if you want to rule it out as the cause of your issue.

    Do you have other drive mappings pushed out by logon script or anything? Are they working and it's just the Home directories that aren't working?

    Try looking in event viewer and see if you can notice any errors in there around the time the computer is logging in.

    I had major issues getting drive mappings working in my domain (for windows 7) only to find out the reason was 'portfast' had not been enabled on any of our network switches. Could that be causing your issue also?

    Author Comment

    I have other drive mappings pushed out by the logon script and they map out fine on any workstation. Its only the Home folder setting in active directory that seems to be a problem and its isolated Windows 7 workstations.

    I've moved the user folders from the old 2003 DC over to the new 2008DC.
    The setting for the Home folder is in the active directory user properties and Profile tab and have the Connect button selected with H To \\server2008\user\%username%
    If you look at the map drive on an xp computer for H after booting up it shows H: \\server2008\user$\username
    But on the W7 workstations it only shows H: \\server2008\user$

    I think I may have found the problem in the logon script. There were other references for the H drive and were REM'd out using a ; I used the # instead and I think it may have fixed it. Will see in the morning if its ok now and report back.

    LVL 76

    Expert Comment

    The issue could be that this 'share' has a stale reference on the server and that would explain why the user can not map it.  Check the current share sessions on the server and disconnect the one for this user and see whether that fixes the issue.  

    Author Closing Comment

    Problem solved.


    Featured Post

    Enabling OSINT in Activity Based Intelligence

    Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

    Join & Write a Comment

    Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
    OfficeMate Freezes on login or does not load after login credentials are input.
    This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
    This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

    755 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now