RDP Client still says RDGateway server certificate is expired

Posted on 2011-05-04
Last Modified: 2012-05-11
I have a Windows 2008 server running RD Gateway. It has worked fine for the past year. My GoDaddy UCC SSL certificate expired this week and I installed a renewed certificate that is valid until 5/4/2012. I followed the instructions from GoDaddy, installed the intermediate certificate using the MMC and the server certificate (using the request/complete CSR utilities) in IIS7. I set the bindings for all interfaces to the new certificate in IIS7. I then launched RDGateway Manager and selected the new certificate with the 5/4/2012 expire date. The RDGateway Manager says all is good

However, when I try to access the site with my off-site RDP client, it stall says the certificate is expired and when I view the certificate, it still shows the old one.

I have restarted the W2K8 server twice. Is the old certificate cached somewhere?

Any ideas?


Question by:dcadler
    LVL 13

    Expert Comment

    you need to install it on clients too

    Accepted Solution

    As it turned out, there was an ISA2004 server in place that alson needed the new certificate. I exported it from the RDGateway server and imported it into the ISA2004 server, then I assigned the newly imported certificate to the web listener associated with the RDGateway. This fixed the problem.

    Author Closing Comment

    I solved the problem on my own. The issue was caused by a component I did not list in my problem descrition.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Better Security Awareness With Threat Intelligence

    See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

    Local Printing Using Remote Desktop Windows 7 sometimes has issues with printing to a local printer using a Remote Desktop Connection (RDC). The 1st step is to verify that printers are checked on the Local Resources tab of the Remote Desktop C…
    When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
    This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
    This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    11 Experts available now in Live!

    Get 1:1 Help Now