Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

ASA 5505 inside has no internet

Posted on 2011-05-04
5
Medium Priority
?
334 Views
Last Modified: 2012-05-11
Greetings.

I am very new to Cisco and the ASA 5505.  I have combed the internet and used both CLI and ASDM settings to try to get just a basic LAN to work.  So far, I have been unsuccessful.

I can ping, and connect on the inside network, but the inside network has no internet access.  I don't think it is DNS, because
I cannot ping a known IP address.

I have attached the setup code.
I would be grateful if someone could help me debug this problem, and also if you have any suggestions to make
regarding my setup.

I am using the ASA 5505 as a firewall and DHCP and router.  

T1 router (bridged) --> ASA 5505 (static IP) -->inside/green interface (192.168.6.0/24).

If I need to add another router to the mix, please let me know -
  such as:  
T1 router (bridged) --> ASA 5505 (static IP) -->router 192.168.66.0/24 -->inside/green interface (192.168.6.0/24)
but this would result in double-nat/PAT, right?

I also have to do some subnet vpns and a VPN that is PAT-ed to a single IP, but that is for a later topic,
after I get this working.

Thanks in advance for your help!

ASA001> enable
Password: **************
ASA001# show run
: Saved
:
ASA Version 8.2(1)
!
hostname ASA001
domain-name metro-news.com
enable password PbitEKx51FsLXrKh encrypted
passwd 2ASQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.6.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address aaa.bbb.ccc.ddd 255.255.255.240
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone MST -7
clock summer-time MDT recurring
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 4.2.2.1
 name-server 192.168.1.211
 domain-name metro-news.com
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 aaa.bbb.ccc.ddd 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.6.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.6.20-192.168.6.90 inside
dhcpd dns 192.168.6.212 192.168.1.211 interface inside
dhcpd wins 192.168.6.212 192.168.1.211 interface inside
dhcpd lease 86400 interface inside
dhcpd ping_timeout 200 interface inside
dhcpd domain metronews.local interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:9d7899bd49396f414bcbbb5fbfa4553c
: end
ASA001#

Open in new window

0
Comment
Question by:pootwaddle
5 Comments
 
LVL 6

Expert Comment

by:Wissam
ID: 35695972
your global outside and nat inside statements are correct,
did you verify that the ASA is able to reach the internet ?
howe about a show xlate when trying a connection to internet from an internal PC?
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 35696236
For starters try:

access-list outside permit icmp any any
access-group outside in interface outside


And

policy-map global_policy
 class inspection_default
  inspect icmp
0
 

Author Comment

by:pootwaddle
ID: 35699197
thanks for the suggestions.  I have made the changes.  My ASA 5505 is currently off-line and I will swap it in at the next break
(so I don't interrupt production as swapping routers will kill what we do here)

I hope I am clear, I am less concerned about "ping" (it is only a tool I use) than "normal" internet connectivity to
websites, etc.  
I added the icmp permit group of statements, though.

Thanks so far - with your help I think I am getting closer!
0
 
LVL 16

Accepted Solution

by:
uescomp earned 2000 total points
ID: 35699379
Just to be clear, you have another device that terminates the T1 connection?  I would check with your ISP and make sure that your ASA is configured with the correct default route to their default gateway / next hop router.  Your config looks good.  My guess would be either the wrong default route configured or a problem with the T1 link not being set up correctly.
0
 
LVL 9

Expert Comment

by:gavving
ID: 35699440
When you swap in the ASA5505, you might need to reboot the upstream router.  That router may cache the IP number assigned to the old firewall and not map it to the new mac address on the ASA5505.  Rebooting that device will clear that issue.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This past year has been one of great growth and performance for OnPage. We have added many features and integrations to the product, making 2016 an awesome year. We see these steps forward as the basis for future growth.
WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question