Exchange 2010 DAG Network Configuration (MAPI vs Replication)

I'm setting up a new Exchange 2010 environment with two mailbox servers in a DAG group. I have two NICs per server that I'm using. One for MAPI and one for Replication. According to Technet and several other articles I need to deselect "Replication" on the MAPI DAG Network so it will only be used for MAPI/DATA traffic. Only the Replication (Private) network will have the "replication" checkbox enabled. My Sr. Sys Admin disagrees with me and believes that both the MAPI and Replication DAG networks need to have the "Replication" option selected.

This is the only way he could get the DAG Cluster Name/IP to come online in Failover Cluster Manager. The DAG Cluster IP is on the MAPI network. If the "Replication" option is not enabled then the MAPI network shows as "cluster: disabled" in Failover Cluster Manager. The Cluster IP can not be brought online unless that network is Cluster: Enabled. It will only show as cluster: enabled if the "replication" option is selected.

Any ideas?
cogentsystemsAsked:
Who is Participating?
 
MegaNuk3Connect With a Mentor Commented:
Sounds like your senior admin is correct. In good old E2k7, the replication was always over the public network until SP1 where you could allow it to use the Private network too.

The cluster IP is on the public interface and also the cluster talks to the File Share Witness over the public interface.
0
 
cogentsystemsAuthor Commented:
Ok. I'm confused why Technet and other articles walk you through disabling replication for the MAPI (Public) network. If the cluster IP is on the public network then it won't be able to be brought online because the Public network is not "cluster: enabled". How do they expect things to work if the MAPI network does not have replication enabled?
0
 
MegaNuk3Commented:
Can you post a link to the technet article that says that?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
MegaNuk3Commented:
Is your config the same as this?
http://www.ntweekly.com/?p=863
0
 
cogentsystemsAuthor Commented:
I think the problem is that my admin believes the DAG Name/IP needs to be accessible on the Internal Network (MAPI) when in fact it needs to be on the Replication Network (private/heartbeat). According to that link the DAG is on the new replication network that they created.

The technet article is here: http://technet.microsoft.com/en-us/library/dd638104.aspx#NR

There is also this article: http://exchangeinbox.com/article.aspx?i=157&t=6

Specifically the section that says:
Next we will disable the replication on the MAPI network. Open the properties of the second network which is configured with the IP of your internal network, uncheck Enable replication check box

There are other articles that say to leave replication enabled on both networks (Replication and MAPI), but I think that's incorrect, or maybe it doesn't really matter.
0
 
cogentsystemsAuthor Commented:
Actually, I take that back. The DAG they were creating was just the replication network and not the actual DAG group name.

I just re-read the article you mentioned and the Cluster Network 1 does show "allow cluster network communication on this network" and "allow clients to connect through this network" checked. Does that mean on the DAG Network in Exchange Mgmt that they also have the "Replication" option Enabled? I believe this is the only way you can get these settings to show as checked in failover cluster mgr.
0
 
cogentsystemsAuthor Commented:
Yes, this is part of the problem. We have the DAG IP on our MAPI/Public subnet and not the Replication/Private/Heartbeat network. The DAG hostname and IP could not be brought online until we enabled the replication option on the MAPI/Public DAG Network. There are several articles out there that state to disable the replication option on the MAPI Network.

The only thing I can think of is that the DAG IP should be on the Replication/Private subnet which will make that hostname/IP unavailable to all machines on the domain except the two mailbox servers that are connected via crossover on the Replication/Private network.

Should the DAG IP be on the MAPI or Replication network?
0
 
MegaNuk3Commented:
The DAG IP should be on the MAPI network as that is how outlook connects to it via the CAS.
0
 
cogentsystemsAuthor Commented:

Ok, but if you disable "replication" on the MAPI network then it is not considered "cluster: enabled" in failover cluster manager. If the MAPI network is not cluster: enabled then the IP for the DAG can not be brought online. The only way to bring the cluster resource online is to check the "replication" option on the MAPI DAG network which goes against what Microsoft and several articles is stating.

Not a big deal. We have replication enabled on both MAPI and Replication networks and everything is working fine. I'll go ahead and award you the points since you were kind enough to help me out.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.