• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1134
  • Last Modified:

Windows VMs communicating through serial devices on a ESX 4 host

Hi All,

We are currently evaluating OpManager to replace Nagios as our monitoring solution. The environemnt is ESX 4 vSphere and Opmanager is running on a Windows VM. We need to be able to have OpManager send SMS alerts through our MC35i serial GSM device.

So far we haven't been able to get this to work through a Windows VM but it works fine with a Linux VM (Nagios). The Opmanager VM is on a different host to the Nagios VM.

On the ESX 4 host the Opmanager VM belongs too, the serial device is physically connected and the VM is using /dev/ttyS0 for the Serial Port. How can we map to this port through a Windows VM.. is it even possible?

At the moment Opmanager reports "Modem is not connected properly. Please check your settings"

Thanks in advance for your responses.



0
ams_group
Asked:
ams_group
  • 2
  • 2
  • 2
1 Solution
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
That serial device should be mapped to COM1 in the Windows VM.

Something you may want to consider, we have much better compatibility in using USB to Serial Adaptors in VMs, and use USB passthru.

if you would like to no more see refer to this link

http://www.vm-help.com/esx40i/VMDirectPath/USB_Setup.php
0
 
coolsport00Commented:
Yes, by all means it's possible...at least in using serial ports. I have a serial-connected device to a VM. It uses the same setting as you stated (/dev/ttyS0). You can only have one VM using the physical host's serial connection, though. (see: http://kb.vmware.com/kb/1001979) Get the hostd logs and see if it shows us anything (see: http://kb.vmware.com/kb/1021800)

~coolsport00
0
 
ams_groupAuthor Commented:
Thanks for your responses. The solution was quite simple... I enabled Serial Port 1 in the Opmanager VM's bios and it's working now.
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
coolsport00Commented:
Nice! Glad it's working now...

~coolsport00
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Normally the Default Operation for Serial Poirts in the Virtual Machine BIOS are set to AUTO.

AUTO - Bios or OS choose configuration.

So I'm assuming your Serial Ports were both Disabled!

 Default for Serial Ports in a VMware VM is AUTO
0
 
ams_groupAuthor Commented:
Problem was that the COMM port was not enabled in the VM bios.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

  • 2
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now