Can not open documents from Sharepoint 2010 document library.

I have a Sharepoint 2010 Enterprise server. It used to work OK, but now when I try to Open a document in Excel 2010 from a document library ("Edit in Microsoft Excel"), I get an windows Security login prompt.
It does not accept password, and the document ends up blank.
I can read the document in the browser, but not in Excel/Word.

I believe the error apeared after I changed some Access URL mappings.

I have verified I.E. trusted sites, and the sharepoint site is added there.


atsj0Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Minesh ShahSharePoint & all about itCommented:
is it happening with only 1 document library or or only 1 sub site only 1 site collection  or 1 web app or whole farm..
0
atsj0Author Commented:
It happends on every library. All site collections/Farm.


0
atsj0Author Commented:
After more troubleshooting, I found that Open in explorer for a library also fails.
With the same login prompt.
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

Minesh ShahSharePoint & all about itCommented:
check this on a few different machine as well, this will tell us the issues is machine / login specific or not.
0
atsj0Author Commented:
I have tested with any combination of WinXP/Win7, Office 2007 & Office 2010
0
Minesh ShahSharePoint & all about itCommented:
if this is happening with only excel 2010,
have a look at advanced setting of library, open doc in browser must not be selected..
0
atsj0Author Commented:
Did not work. But I will now test MS Office 32bit vs 64bit.
0
_valkyrie_Commented:
I am having the same issue. Server 2008 R2, Sharepoint 2010, any computer/copy of office the login fails when I try to open a document. Everything else on the site works perfectly.

If I find a solution, I'll post it here for you. You're not alone.
0
atsj0Author Commented:
I had an sharepoint consultant looking at this.
After working with the access mappings he solved the issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
atsj0Author Commented:
Did not get full details on the fix, since a lot of different approaches was tried.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.