Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

permission denied when trying to update hp bios in esxi

Posted on 2011-05-05
9
Medium Priority
?
4,695 Views
Last Modified: 2012-05-11
hello,

i am trying to update my esxi server's bios. i downloaded the .scexe file from hp and copied it over to one of my datastores.
i connect to the datastore via putty and browse the directory where the file is located.
then i run
./ filename.scexe

always get permission denied

i am logged in as root

any1 help me out?
0
Comment
Question by:Saputo
9 Comments
 
LVL 40

Expert Comment

by:coolsport00
ID: 35699315
Check the downloaded file's permissions. See this article:
http://www.linuxclues.com/articles/16.htm

~coolsport00
0
 
LVL 28

Expert Comment

by:bgoering
ID: 35699323
What model server do you have. You will likely need to do a stand alone bios update as ESXi doesn't really offer a full linux shell.
0
 
LVL 28

Expert Comment

by:bgoering
ID: 35699337
Also on the off chance ESXi has enough shell to run the update, as well as the permissions check also make sure the execute bit is set on the file.

chmod a+x filename
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
LVL 125
ID: 35699580
I would complete the recommended update by using the HP Smartstart CDROM.

This means you will need to schedule and shutdown the sever, and boot the server using the HP Smartstart Firmware CDROM and complete the update.

0
 

Author Comment

by:Saputo
ID: 35699606
the model is a HP DL380 G6

iv done it many times on ESX with no issues, but on ESXi im having these permission problems
0
 
LVL 125
ID: 35700029
This is ESXi it has no Linux or Service Console.
0
 
LVL 125
ID: 35700037
I would recommend using the HP Smartstart Firmware CDROM because you will also be able to select updates for Network Interface Cards, iLO and Storage Controllers in on upgrade.
0
 
LVL 28

Accepted Solution

by:
bgoering earned 500 total points
ID: 35700743
0
 
LVL 28

Expert Comment

by:bgoering
ID: 35700765
And yes - ESX has enough of linux in the service console you can typically run many linux apps (such as bios updaters). ESXi however was designed to be managed through APIs and the management shell lacks the capabilities of the full ESX service console.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When rebooting a vCenters 6.0 and try to connect using vSphere Client we get this issue "Invalid URL: The hostname could not parsed." When we get this error we need to do some changes in the vCenter advanced settings to fix the issue.
It’s time for spooky stories and consuming way too much sugar, including the many treats we’ve whipped for you in the world of tech. Check it out!
Teach the user how to use create log bundles for vCenter Server or ESXi hosts Open vSphere Web Client: Generate vCenter Server and ESXi host log bundle:  Open vCenter Server Appliance Web Management interface and generate log bundle: Open vCenter Se…
This video shows you how easy it is to boot from ISO images for virtual machines with the ISO images stored on a local datastore on the ESXi host.
Suggested Courses

581 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question