?
Solved

OSX Server wikis and blogs error 503 (stale pidfile /var/run/wikid.pid)

Posted on 2011-05-05
4
Medium Priority
?
1,112 Views
Last Modified: 2012-05-11
I'm running a XServe server with OSX Server 10.5.8.

The teamserver services (Wikis and blogs) displays a 503 error when trying to be accessed. Everything is enabled in WGM and in SA.

I get periodically (every 30 seconds or so) 3 error messages in the system log :
www com.apple.wikid[13597]: Removing stale pidfile /var/run/wikid.pid
www com.apple.launchd[1] (com.apple.wikid[13597]): Exited with exit code: 1
www com.apple.launchd[1] (com.apple.wikid): Throttling respawn: Will start in 9 seconds

I saw it could be caused by corrupted plist files but I checked everyone of them in the folder containing the wikis with plutil and they're all OK.
I already tried resetting the logs and restoring the wiki server as described here http://support.apple.com/kb/ts2915 even if i didn't restore from Time Machine, it didn't change anything. I also tried deleting the plist files even if plutil was saying they were OK to let the system rebuild them, it changed nothing.

Does anyone have a clue on where the problem could be and what may be the cause?
 
Many thanks in advance for the help, i really don't know where else to look and what for.
0
Comment
Question by:bafforosso
  • 3
4 Comments
 
LVL 12

Expert Comment

by:nxnw
ID: 35756264
CHeck the wikid error log as well to look for additional information.

Is this a new service, or was it already running, and broke down?

Try repairing permissions and see if it reports errors for anything that may be related (i.e teams, apache, wikid come to mind).
0
 

Author Comment

by:bafforosso
ID: 35768342
This service was already running and just broke down.

I already tried repairing permissions and it reports some errors but totally unrelated.

I've decided to set up a clean install of 10.6 server, i'll keep you posted when i import the wikis if everything is working fine or if there is still a problem.
0
 

Accepted Solution

by:
bafforosso earned 0 total points
ID: 35816223
So i set up the clean install and imported all the wikis one by one, no sign of a problem anymore, everything is running smoothly.
0
 

Author Closing Comment

by:bafforosso
ID: 35900286
This is not the solution i expected as i had to do a clean install and couldn't just fix the broken service, but at least everything is working properly now
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It is possible to boost certain documents at query time in Solr. Query time boosting can be a powerful resource for finding the most relevant and "best" content. Of course the more information you index, the more fields you will be able to use for y…
Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
Users will learn how to set proper sequence settings, scale images, paste attributes, add transitions, fades, and music. Open up Final Cut Pro 7 and Create a new Project: Set the Sequence Settings. a) Click File > Easy Setup > Format > Apple ProRe…
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question