• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 999
  • Last Modified:

Configuring Cisco 877 for a PPPoA internet

Hello experts,

We have an old Linksys router, and now upgrading to Cisco 877. Here are our old Linksys router settings:

Encapsulation: PPPoA
Multiplexing: VC
VPI: 8
VCI: 35
Username: ouruser
Password: oursecret
Local IP Address: 192.168.1.10
Subnet: 255.255.255.0

In order to configure the Cisco 877, I have followed step by step as described in this article:

http://www.cisco.com/en/US/docs/routers/access/1800/1801/software/configuration/guide/pppoanat.html 

Here are the steps I made:

Configure the dialer interface:

interface dialer 0
ip address negotiated
ip mtu 1492
encapsulation ppp
ppp authentication chap
dialer pool 1
dialer-group 1
exit
dialer-list 1 protocol ip permit
ip route (I didn't know what to type here)

configure the ATM WAN interface:

interface atm 0
pvc 8/35
encapsulation aal5mux ppp dialer (Not sure about this)
dialer pool-member 1
no shutdown
exit

Configuring DSL Signaling protocol:

(Nothing I have done here)

Configuring NAT:

ip nat pool pool1 192.168.1.0 192.168.1.255 netmask 255.255.255.0 (Is this correct?)
ip nat inside source list 1 interface dialer 0 overload
interface vlan 1
ip nat inside
no shutdown
exit
interface fastethernet 0
ip nat outside
no shutdown
exit
access-list 1 permit 192.168.1.0 255.255.255.0 (Is this correct?)



I think that I have made many mistakes in the above configuration. Would you please give me the correction?
0
Muhajreen
Asked:
Muhajreen
1 Solution
 
greg wardCommented:
ip route 0.0.0.0 0.0.0.0 dialer0
interface Dialer0
 mtu 1492
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp authentication chap pap callin
 ppp chap hostname *username*
 ppp chap password *password*
i dont think you need this.
ip nat pool pool1 192.168.1.0 192.168.1.255 netmask 255.255.255.0 (Is this correct?)
int atm0
 dsl operating-mode auto
 pvc 8/35
  encapsulation aal5snap/aal5mux <<not sure which
  protocol ppp dialer
  dialer pool-member 1

interface fastethernet 0
ip nat outside     < should be inside

interface vlan 1
ip nat inside
ip address 192.168.1.1 255.255.255.0

dialer-list 1 protocol ip permit
Try that

Greg
0
 
MuhajreenAuthor Commented:
Thank you Greg, that was great!
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now