Configuring network adpater on Ubuntu server 10.04 LTS(virtual machine) installed on Hyper-v

I have set up a Ubuntu 10.04 LTS server (virtual machine) on Hyper V. I am having trouble setting up the network adapter.  I have set up legacy network adapter for the vm.  I do not see eth0 under interfaces. i have tried the following article. no luck yet

sudo vi /etc/network/interfaces

auto lo
iface lo inet loopback


ifconfig

Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
...
kittu05Asked:
Who is Participating?
 
AkixaiCommented:
0
 
kittu05Author Commented:
Akixai,

Thanks for the response. I have followed that article and still having trouble. I don't see the network adapter
0
 
svsCommented:
does it appear in
lspci

Open in new window

output?
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
kittu05Author Commented:
the output
lspci

Open in new window


00:00.0 host bridge: Intel Corporation 440BX/ZX/DX - 52443BX/ZX/DX Host bridge (AGP disabled) (rev 03)
00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 01)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:08.0 VGA compatible controller: microsoft corporation devices 5353
00:0a.0 Ethernet controller: Digital Equipment Corporation DECchip 21140 [fastbet] (rev 20)
00:0a.1 Ethernet controller: Digital Equipment Corporation DECchip 21140 [fastbet] (rev 20)
0
 
CODVMCommented:
See if the interface was detected with this command:

ifconfig -a
0
 
kittu05Author Commented:
This article helped me in understanding the configuration
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.