• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 472
  • Last Modified:

Windows 2008 R2 Windows Server Backup permissions and Robocopy

I have scripts running in the Scheduler that run Robocopy to do file backups disk to disk. I am using the /B option to run the copy in backup mode. When I throw that switch, robocopy logs the error "You do not have the Backup and Restore Files user rights." I am running as the domain administrator. I have checked the box for "Run with highest privileges", and still the error. Once I get rid of the /B, it works fine. I would like to be able to use the switch. Not sure what is missing in this equation.

Thanks,
0
BHForum
Asked:
BHForum
  • 2
1 Solution
 
Adam BrownSr Solutions ArchitectCommented:
There's a specific user right that needs to be assigned to the account in order to perform backups. Go to Computer COnfiguration\Windows Settings\Security Settings\Local Policies\User Rights Assignment

The Back up files and directories rights is what you need to look for. If there is nothing listed in there, try to add the Administrators group to it. If you can't, you'll need to check your group policies and make sure the administrators group is added to that right in a GPO.
0
 
BHForumAuthor Commented:
acbrown2010: Sorry, been slammed lately. Gonna take a look at that and check what's there.

John
0
 
BHForumAuthor Commented:
Will check GPO to see if there are any inconsistencies.
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now