[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1489
  • Last Modified:

Cannot turn off disk-write cache on system drive (SBS 2008)

I want to disable disk-write cache on the drives in my PC running SBS 2008. I have managed to disable the disk-write cache on the non-system drives (both Western Digital), but I cannot disable it on the system drive (a Samsung drive).

When I untick the box and click OK, the dialog box hangs for a minute or two, then closes, but the box reverts to being ticked.

How can I turn it off?
0
Chris Millard
Asked:
Chris Millard
1 Solution
 
DavidCommented:
Not all HDDs allow this setting to be changed.  The configurable parameter(s) that control the cache settings are locked by firmware to be locked on, locked off, or configurable.   Not only that, but if you are connecting that disk to a SAS/SATA controller, then somewhere in the mix is a bridge or expander, which then have to do some protocol conversion to let the command get through.  Not all bridge/expanders let programs even get to that setting, even if the disk has firmware that allows the change.

This system IS behaving like the setting is locked.   If so, nothing you can do about it w/o changing firmware, which is a big can of worms that you do not want to open.

0
 
JReamCommented:

It's either the firmware or boot-time configurable options.    

We had a similiar issue with one of our Dell servers a year ago.  In our case the "enabled" cache was killing the disks performance.   At boot time, we got into the Dell Storage Manager and found the options for "Disk Cache Policy" and disabled it.  Great HD performance ever since.



0
Tackle projects and never again get stuck behind a technical roadblock.
Join Now