?
Solved

apt-get install failling

Posted on 2011-05-05
5
Medium Priority
?
1,322 Views
Last Modified: 2012-05-11
HI
i just installed debain squeeze

i am trying to intall apache2, but its failling

 apt-get install apache2
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 apache2 : Depends: apache2-mpm-worker (= 2.2.16-6+squeeze1) but it is not going to be installed or
                    apache2-mpm-prefork (= 2.2.16-6+squeeze1) but it is not going to be installed or
                    apache2-mpm-event (= 2.2.16-6+squeeze1) but it is not going to be installed or
                    apache2-mpm-itk (= 2.2.16-6+squeeze1) but it is not going to be installed
           Depends: apache2.2-common (= 2.2.16-6+squeeze1) but it is not going to be installed
E: Broken packages
root@debian:~#



my source.list is :

 cat /etc/apt/sources.list
#

# deb cdrom:[Debian GNU/Linux 6.0.1a _Squeeze_ - Official i386 CD Binary-1 20110322-15:11]/ squeeze main

#deb cdrom:[Debian GNU/Linux 6.0.1a _Squeeze_ - Official i386 CD Binary-1 20110322-15:11]/ squeeze main

# Line commented out by installer because it failed to verify:
deb http://security.debian.org/ squeeze/updates main
# Line commented out by installer because it failed to verify:
deb-src http://security.debian.org/ squeeze/updates main

# squeeze-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
deb http://ftp.debian.org/debian/ squeeze-updates main
deb-src http://ftp.debian.org/debian/ squeeze-updates main



how to slove this issue ??

h
0
Comment
Question by:fosiul01
  • 3
  • 2
5 Comments
 
LVL 4

Expert Comment

by:a1j
ID: 35701362
apt-get update ; apt-get install  apache2 apache2-mpm-worker

what's output of that?
0
 
LVL 4

Accepted Solution

by:
a1j earned 2000 total points
ID: 35701388
Oh you have only updates in our source.list.
You need to put there location of distro.

deb ftp://ftp.us.debian.org/debian/ squeeze main contrib non-free
for example
0
 
LVL 29

Author Comment

by:fosiul01
ID: 35701427
Hit http://ftp.debian.org squeeze-updates Release.gpg
Ign http://ftp.debian.org/debian/ squeeze-updates/main Translation-en
Hit http://security.debian.org squeeze/updates Release.gpg
Ign http://security.debian.org/ squeeze/updates/main Translation-en
Ign http://security.debian.org/ squeeze/updates/main Translation-en_GB
Ign http://ftp.debian.org/debian/ squeeze-updates/main Translation-en_GB
Hit http://security.debian.org squeeze/updates Release
Hit http://ftp.debian.org squeeze-updates Release
Hit http://security.debian.org squeeze/updates/main Sources
Hit http://security.debian.org squeeze/updates/main i386 Packages
Get:1 http://ftp.debian.org squeeze-updates/main Sources/DiffIndex [781 B]
Get:2 http://ftp.debian.org squeeze-updates/main i386 Packages/DiffIndex [781 B]
Hit http://ftp.debian.org squeeze-updates/main i386 Packages
Fetched 1,562 B in 17s (88 B/s)
Reading package lists... Done


apt-get install  apache2 apache2-mpm-worker
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 apache2 : Depends: apache2.2-common (= 2.2.16-6+squeeze1) but it is not going to be installed
 apache2-mpm-worker : Depends: apache2.2-common (= 2.2.16-6+squeeze1) but it is not going to be installed
                      Depends: apache2.2-bin (= 2.2.16-6+squeeze1) but it is not going to be installed
E: Broken packages
0
 
LVL 29

Author Comment

by:fosiul01
ID: 35701514
ur right!!
thanks

ask me anything on redhat but debain... this is first time!!!


anyway thanks man
0
 
LVL 29

Author Comment

by:fosiul01
ID: 35701520
is there any way you  would like to have a look to this one

http://www.experts-exchange.com/OS/Linux/Q_27019710.html?cid=239#a35700081
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses
Course of the Month15 days, 7 hours left to enroll

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question