[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 739
  • Last Modified:

LAN Remote Desktop Connection

Hi all,
I have a simple home network with Macs and PCs. I am trying to set up RDP between the Macs and PCs. Using RDP from one PC to another works fine. All PCs are already set up to allow RDP. The problem I am having is that if I try to connect to a PC over RDP on a Mac, it doesn't work.

My question is if there is something preventing it or a better, free alternative solution that is just as easy to use on my home network.

Thanks!
0
mfranzel
Asked:
mfranzel
  • 19
  • 19
  • 2
  • +1
1 Solution
 
FideliusCommented:
Which Mac OSX version are you using? Do you have latest Microsoft RDC for Mac?
I have OSX 10.6.6 with RDC for Mac version 2.1.0 (100825) and didn't have to do anything more than allow RDP on Windows.

Alternative is using VNC.

Regards!
0
 
g000seCommented:
Hi,

Logmein works great and it's free.  It's Mac compatible.

https://secure.logmein.com/products/free/
0
 
g000seCommented:
It's limited to a certain number of computers.

Here is some more info- https://secure.logmein.com/comparisonchart/comparisonFPP.aspx
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
mfranzelAuthor Commented:
I am using OSX 10.6.7 with Microsoft RDC for Mac 2.1.1. I am having this problem on both of my Macs... they are both unable to connect to all PCs on my network.

Logmein is great, but it's really more for when you are not local. I use it all the time and even have Pro licences, but for what I want to do, locally, I need something that is better.
0
 
FideliusCommented:
For LogMeIn you need internet connection. For access from local network VNC is far more better and faster.

For remote access from Internet i would recommend TeamViewer (free for personal use):
http://teamviewer.com/en/index.aspx

I'm using both (LogMeIn and TeamViewer), but I prefere TeamViewer it has more options in free version and it is faster them LMI.
0
 
pyntCommented:
Yes I agree with Fidelius. VNC is the way to go because osx is unix based.
http://www.tightvnc.com/

its free.
0
 
FideliusCommented:
Thanks for posting OS an RDC versions. I'll try to upgrade to 10.6.7 and to download new RDC this weekend to see if I'll be hit by same issue.
I will post the results when I'm done.
0
 
FideliusCommented:
I just tested. Here are combinations:
OS X  - RDC - result
10.6.6 - 1.0.3 - OK
10.6.6 - 2.1.0 - OK
10.6.6 - 2.1.1 - OK
10.6.7 - 2.1.1 - OK
10.6.7 - 1.0.3 - OK

No matter which OSX/RDC combination I use, it works. So we can assume RDC client is not the problem, and also OSX version is not the issue. Something else is problem.
Have you ever been able to connect over RDC to PC, or it is issue from begining? (wondering if RDC preferences are corrupted in some way)

Please try to telnet from Mac console to port 3389 on PC. It should look something like this if connection is possible:
mac:~ user$ telnet 192.168.1.10 3389
Trying 192.168.1.10...
Connected to 192.168.1.10.
Escape character is '^]'.
^]
telnet> quit
Connection closed.
mac:~ user$


Are you able to connect to any resource on PC from Mac? (shared folder, shared printer)
Do you see PC's on your Mac under Shared section in Finder?
0
 
mfranzelAuthor Commented:
I got the same results doing telnet. Here's where it gets weird...
I have another post on EE:

http://www.experts-exchange.com/Apple/Operating_Systems/Q_26808309.html

All other computers on my network disapear from the Shared menu on all Macs on my network while PCs can see every computer just fine.

As that post says, in Finder, the PCs AND Macs do not appear under Shared, however, if I go to the Connect to Server option, I can connect to the other PCs resources with no trouble.

I am assuming this has something to do with my problem here.
0
 
FideliusCommented:
Probably yes. I read the post, and it is really weird.

One thing crossed my mind. Try to do packet capture:
1. open terminal
2. paste command (replace en1 interface name you are using): sudo tcpdump -i en1 -s 0 -B 524288 -w ~/Desktop/DumpFile01.pcap
3. try to connect to over RDP
4. terminate capture with Ctrl+C
5. compress the file and post it

Also, did you try to reformat the disk and do clean install of MacOSX? I know this solution is extreme, but maybe it could work.

0
 
mfranzelAuthor Commented:
I do believe I tried a clean install in regards to the other post and nothing worked.

I did as you suggested and the file *should* be attached. I had to remove the extension .pcap because the system wouldn't let me upload it, just fyi.

Here's whats weird:
If I try to connect with RDP using the hostname (ie media-pc-lr) it fails. But if I connect using the IP address, it works. DumpFile01
0
 
mfranzelAuthor Commented:
Anyone??
0
 
FideliusCommented:
Hello, sorry for delay, but I was very busy and didn't have time to look at dump file.

So as I analyze it, I can see you tried 4 times RDC during dump:
- first was unsuccessful (you can see it by applying filter "tcp.stream eq 24" in Wireshark)
10.0.1.2 -> 67.215.65.132
- other three were successful (tcp.stream 28, 35 and 37)  
10.0.1.2 -> 10.0.1.53


So first one is very strange, because you can't have public address in your local network. By drilling down further I found this: (you can use filter "tcp.stream eq 24 || udp.port == 53" in Wireshark to see it)

PC 10.0.1.2 asks 10.0.1.1 (I assume local DNS, probably router) about media-pc-lr.2wire.net
DNS response is 67.215.65.132
After that it tries to connect to DNS resolved IP and it fails.

My assumption is wrong DNS resloving of media-pc IP address.

So do the following from terminal:
mac$ sudo nano -w /etc/hosts
# add following line in file
10.0.1.53 media-pc-lr
#save and close the file
mac$ dscacheutil -flushcache

After that try RDC connection via hostname.
0
 
mfranzelAuthor Commented:
Thanks for your reply.

Your suggestion did successfully work, but what happens if the IPs on my local network change?

Here's something else... that fact that you say the dump file has something about 2wire.net in it is very strange. My ISP is AT&T Uverse so I have to have their 2Wire residential gateway. But I don't like the features of it, so I use an Apple Airport Extreme as the router that assigns IPs and wifi. So if that is the case, why would anything behind this "second network" show anything with 2wire?

Is the way my network is set up causing this problem and the problem in the other ticket? Basically a DNS problem?
0
 
FideliusCommented:
Yes, it is probably DNS problem.
What device is on that public address I had found in dump? Your residential GW or something else?
Also what is the FQDN of media-pc-lr?

My assumption is that following thing is happening, and I think it is normal.
When you're trying to connect using hostname Mac looks at hosts file. As it is not there it asks DNS, so Airport forwards request toward AT&T public DNS. So connection at the end fails.

On the other hand when you do the same thing on PC with Windows, it uses NetBIOS to find host in local Workgroup. As it exists it doesn't ask DNS, and connection is successful.

I will try my theory tomorrow in my own network an post you results. ( it's 2AM here, and I need to be at work in the morning, sorry for delay with results ).
0
 
mfranzelAuthor Commented:
I have no clue what the public address is. I  did a ping from the mac to media-pc-lr and it popped up the same public ip address.

If your theory is correct, how can I fix it? I know this is sort of a double NAT, but they are technically 2 separate networks and should work independently (to an extent).  
0
 
FideliusCommented:
I tried, and in my network worked.

Mac has static IP and router as DNS server, PC is in WORKGROUP and has DHCP configuration by which it get's router as DNS server.
When I ran nslookup on mac:
mac:~ user$ nslookup ibm-t43-2
Server:         192.168.1.1
Address:        192.168.1.1#53

Name:   ibm-t43-2
Address: 192.168.1.138


I also tried nslookup for public address you are getting as response:

mac:~ user$ nslookup 67.215.65.132        
Server:         192.168.1.1
Address:        192.168.1.1#53

Non-authoritative answer:
132.65.215.67.in-addr.arpa      name = hit-nxdomain.opendns.com.

Are you using OpenDNS or DynDNS services? What is set as DNS server on Mac's ad PC's?

To sum up all we troubleshoot by now:
- RDC from Mac to PC works by IP
- RDC by Mac to PC doesn't work by hostname
- same situation from all Mac's to all PC's
- reinstall of the system didn't help, and it is happening on both Mac's so it isn't installation or OS related.

So problem is definitely in DNS, as everything works by IP.
My ISP is AT&T Uverse so I have to have their 2Wire residential gateway. But I don't like the features of it, so I use an Apple Airport Extreme as the router that assigns IPs and wifi.
Can you describe a little bit your topology. How is exactly Airport Extreme (AE) connected to residential gateway (RG)? Are all hosts connected to AE or you have hosts connected to RG also?

Try to capture traffic between RG and AE while you are connecting to RDC with hostname. You can do that by connecting one PC or Mac on RG and do tcpdump (Mac) or Wireshark capture (PC).
0
 
mfranzelAuthor Commented:
I do use OpenDNS. The OpenDNS servers are set in the AE and on each mac and PC the DNS server is 10.0.1.1 (the Airport router).

Basically, the RG is connected directly to the AT&T service with its public IP address. From a link port on the RG, the wire goes to the Internet port ont he AE. In the RG, there is an option to add a supplementary network. I added the IP address of the AE. There is also an option for subnet mask which is 255.255.255.0.  Then I DMZd the AE through the RG's firewall.

What's weird though is that on the AE, it shows its's public IP address as the same one the RG has. I COULD set up the AE in bridge mode, but then I loose a lot of features I need and use on the AE.
0
 
FideliusCommented:
I googled a bit to learn more about service you have and found this topic:
http://gigaom.com/apple/how-to-setup-an-airport-extreme-in-bridge-mode/

I understand that you don't want to put AE in bridged mode, so I read comments, and they explain why your AE has the same IP as RG.

One suggestion. Try to put AE in bridged mode just to see if RDC will work. If it will, then we can narrow the problem to AE setup and try to find solution in that direction.
0
 
mfranzelAuthor Commented:
Let me try that out and I will get right back to you.
0
 
mfranzelAuthor Commented:
Hello,
sorry for the late reply. I thought I sent my reply, but alas, I did not...

Anyways, I have set the airport in Bridged mode (after many settings changes on both routers, it was a pain in the a$$). I can simply type the PCs hostname in the RDC box and it will connect and if I ping, it will show an internal address, not a public IP like before. HOWEVER, the PCs are still not showing up under Shared in Finder.

So this leads to two questions:
1. Why if hostnames n ow work, do the PCs not show up in Finder?
2. How can I make this work while NOT using the Airport in Bridged mode because I want to use it's full set of features.
0
 
FideliusCommented:
Hello!

For first question:
Do you have firewall enabled on Mac or PC? If you have, try to disable it.
Also, try to connect PC to Mac with crossover cable and configure manually IP on both sides. With this we will eliminate all network components in between computers, and if problem still exists it must be local to Mac or PC. During this test try to capture traffic with tcpdump as you did before, so I can analyze capture.

For second:
All troubleshooting so far points to wrong DNS resolving. So I would suggest put AE i routing mode, remove OpenDNS servers from AE and use default ISP servers and see how it will work. You can do capture here also.
0
 
mfranzelAuthor Commented:
There is no firewall enabled on the Macs. I do not have a patch cable to test with, but I would like to point out this happens with all 3 macs on my networks.


Before switching AE to bridge mode, one of the things I tried was setting its DNS servers to my default ISP, then I tried using it (10.0.1.1), then I tried using the RG. Still... nothing worked.

Do you still want me to do a capture?
0
 
FideliusCommented:
Capture is te only way we can see what is going on in the network.
By your last post, I'm begining to suspect that AE is source of problems, but I can't figure out what part of it's configuration is causing them.
It would be great if you can substitute AE with some other router just for the test, but I doubt you have spare router.
0
 
mfranzelAuthor Commented:
I actually do have another router... I think it works. I will try to test that out later.

I am fine not having the computers show up in Finder, but i need host names to work in my network because I do not used static IPs on the individual computers.
0
 
FideliusCommented:
If you have another router, that's great.
From tcpdump you posted earlier it is clear that that DNS when AE is in routing mode causes wrong hostname resolution. If new router behaves the same, then the problem could be "DMZ" setting on RG.
0
 
mfranzelAuthor Commented:
Okay more happenings...
I didn't have another router to test with. So, I put the AE back in routing mode and DMZ on the RG. However, this time I didn't add the AE as the supplementary network on the RG, I just DMZd it. So, now all computers show up in Finder and I can connect tothem fine... BUT I am still unable to connect to them using hostnames over RDP. AND, if I try to ping in Terminal it says:

macpro:~ Matthew$ ping media-pc-lr
ping: cannot resolve media-pc-lr: Unknown host
macpro:~ Matthew$

I have attached the new dump file for you, again without the file extension. DumpFile01 DumpFile01
0
 
FideliusCommented:
So with this setup you see computers in Finder, so we can conclude that AE behaves differently in DMZ than as supplementary network on RG. That is probably because of RG setup which applies some restrictions in each case differently.

As I can see both attached dump files are the same.

First few assumptions (please correct me if I'm wrong):
10.0.1.1 is Airport Extreme (AE)
10.0.1.4 is MacPro
10.0.1.7 is Windows PC

So quick analysis:
I can see two RDP connections (filter: (tcp.stream eq 29) || (tcp.stream eq 46)) both successful. Probaly because you connected over IP.
Also if you filter capture in Wireshark using following expression
udp.port == 53
you can see that 10.0.1.1 doesn't resolve media-pc-lr, but resolves touch.facebook.com and others public FQDNs. So DNS works but it doesn't resolve local hostnames. It seems like AE doesn't cache local hostnames. I can't find anywhere information if and how AE caches local hostnames.
I found this:
http://head-lights.blogspot.com/2009/06/hostnames-with-airport-extreme.html
so you can try it.

If you can borrow some non-Apple router to try with, it will help a lot to clarify this behavior.
One thing you can try, if you didn't already, disconnect AE from RG, connect Mac and PC to AE and try to connect to RDC via hostname.
0
 
mfranzelAuthor Commented:
Didn't mean to upload two dump files. They are the same.

You are correct on your assumptions on the IP addresses.

I still don't have another router to try with, but I did unplug the internet from the AE and still nothing.

I have another AE on Verizon FiOS in the same type of setup and I have never had this problem. So I guess it is directly related to the AE?
0
 
FideliusCommented:
Can you switch the AE's?
Does Verizon FiOS router also has DMZ or supplementary network as RG?
0
 
mfranzelAuthor Commented:
Unfortunately, I cannot switch them as one is with me here in Florida and the other is in Washington, DC.

I did, however, realize that FiOS just comes in with an ethernet line into a hub, the hub then splits into the AE and then one into the special router for the TV service... so a bit of a different set up.

Obviously, there is a problem with the AE and the RG working together.
0
 
FideliusCommented:
Yes, I agree.
I think that RG makes most of the problems, as AE on other location works just fine in routing mode. I suspect that DMZplus is not real bridged mode for RG.

I also find this guide http://www.sbbala.com/uverse/index.html, which clarified AT&T Uverse configurations to me, but I'm sure you already done all that.

One thing I noticed in that document and in lots of discussion on http://www.uverseusers.com/index.php?option=com_smf&Itemid=2& is that lots of people suggest to turn off wireless on RG when you use DMZplus option.
0
 
mfranzelAuthor Commented:
I have done all of this, turned off the RG wifi and still nothing. I am getting everything to show up in finder, but still unable to connect with hostnames... WHAT GIVES!!! Screw you AT&T...

Any workarounds?
0
 
FideliusCommented:
Unfortunately, regarding all troubleshooting we've done, you will have to sacifice some functionality:

1. Workaround: AE in bridge mode
2. Workaround: use static IP config on all PC, edit hosts file on Mac's with hostames of all PC with corresponding IP address.

Did you try to reset AE to factory default settings prior to connecting it to RG's DMZplus port and then configure it? (just another wild guess).
0
 
mfranzelAuthor Commented:
Now it gets weird...
I am testing OSX Lion as a developer and now all the computers show in Finder on all Macs that are running Lion...?
0
 
FideliusCommented:
Maybe Apple changed something in neighborhood discovery procedure in new version.
0
 
mfranzelAuthor Commented:
I've requested that this question be deleted for the following reason:

No resolution. Have moved away from current equipment and ISP.
0
 
FideliusCommented:
Through troubleshoot of this problem we concluded that problem is probably in AT&T Uverse service and their DMZplus option which doesn't work in real bridged mode for RG.

Even if there was no "real" resolution of the problem, moving away to another ISP probably resolved some of the issues.
You can award me 0 points, but I would like that this question and all troubleshoot and discussion stays documented to help anyone else who has similar problem at least as suggestion to change ISP or service type.

Thanks!
0
 
mfranzelAuthor Commented:
Can I still award points to you for your help and time even though no solution was found?
0
 
FideliusCommented:
I think you can. If not, you can ask moderators to do so.

Thanks!
0
 
mfranzelAuthor Commented:
While there was no real solution because it is an AT&T problem, I am awarding points because the member still went above and beyond to troubleshoot with me.

Thanks!
0

Featured Post

Become a Leader in Data Analytics

Gain the power to turn raw data into better business decisions and outcomes in your industry. Transform your career future by earning your MS in Data Analytics. WGU’s MSDA program curriculum features IT certifications from Oracle and SAS.  

  • 19
  • 19
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now