Vista Laptop Won't Install Updates or Service Packs

I have a friend's Dell Inspirion Laptop with Windows Vista SP1 (32-bit) Home Premium that for some reason will not install any updates.  I've tried installing them in Safe Mode and downloading the Standalone versions.

I have tried everything in the following support documents as well with no luck.
support.microsoft.com/kb/883825
support.microsoft.com/kb/936212
support.microsoft.com/kb/949220

Does anyone have any suggestions for me?  I've tried Windows Updates, tried to install SP2, but they all return errors.  Is there something I'm missing?
LVL 7
Brad Sims, CCNANetwork AdministratorAsked:
Who is Participating?
 
BlueThundaCommented:
Ok, this is one of those messy buggers, so here are some more options to explore, free ones ;)

What firewall/AV software are you running, and did Norton or other firewall/AV programs come installed on the computer in question? Also, please mention whether Vista's firewall is enabled or not too please.

If you've uninstalled Spybot without disabling Tea Timer, this is rumored to cause this problem at times. The fix being, reinstalling Spybot, enabling Tea Timer, fully disabling (http://aumha.net/viewtopic.php?t=32409;), then uninstalling Spybot once again.

An additional option, reinstall the System Update Readiness Tool (http://support.microsoft.com/kb/947821) making sure to right-click and Run As Administrator.

I can keep coming up with alternate solutions to try, but eventually it's going to be exhausted to 3 options, installation repair, re-installation, or submitting a support ticket to Microsoft. Not that you should lose hope just yet, but figure knowing what's potentially ahead is better than getting run over by it!

FYI, last time I checked, there is no charge for support calls involving security updates ;) 1-866-PCSAFETY
0
 
bobnlaCommented:
Double check the date and time on the laptop.
If it is not current, they will not install

What error code do you get?
0
 
Brad Sims, CCNANetwork AdministratorAuthor Commented:
They are current.

When trying to install SP2 it says something to the effect of "The Application Is Not Binding" or something similar.  (I just closed the box, give me a few minutes and I can get the exact error).
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
Brad Sims, CCNANetwork AdministratorAuthor Commented:
Exact message (for SP2) is "Installation was not successful.  The application binding data format is invalid".  If I click 'details' it says "Error: ERROR_SXS_INVALID_ACTCTXDATA_FORMAT(0x800736b2)".  
0
 
BlueThundaCommented:
Do you happen to have Kapersky Internet Security installed?? There are some well documented issues with that program and installing updates. Uninstalling it usually remedies the issues associated.

If not, you can always try running the System File Checker Tool

http://support.microsoft.com/kb/936212

This repairs many problems with the operating system of varying origins.

;)
0
 
n2fcCommented:
Try this one:

http://support.microsoft.com/kb/946414

There is a special "fixit"  (50202) for this problem that you can download and try...
0
 
BlueThundaCommented:
Ah, that may be a bit different.

This error can be caused by malware or a virus at times so make sure you scan with a good removal tool after repair.

Use this tool to update Windows Drivers
http://www.cedhost.com/windows-update?0x800736B2

Use this tool to repair the specific error you're encountering
http://www.cedhost.com/repair-errors?0x800736B2

Hope this helps!!
0
 
Brad Sims, CCNANetwork AdministratorAuthor Commented:
n2fc - Tried this but it didn't work either.

BlueThunda - The cedhost ran the scan, but it wants me to buy the program now.  I was hoping to explore all free alternatives first :)
0
 
Brad Sims, CCNANetwork AdministratorAuthor Commented:
Also, the Standalone agent returns the same error number.  It says copying files for about 2 minutes,a nd then "Install Failed with following error number: 0x800736b2.
0
 
Here2HelpCommented:
Hey

Give Fix WU a go
0
 
Brad Sims, CCNANetwork AdministratorAuthor Commented:
Thanks for the help.  In the end the re-installation did the trick.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.