I want to grant the IT director MANAGE FULL ACCESS PERMISSION for ALL mailboxes in EXCHANGE 2007

Our IT director needs access to monitor all incoming and outgoing email sent to and from our company. Of course we could retrieve it using our GFI archiver, but he wants the ease of opening up his OUTLOOK 2007 and being able to manually add another mailbox, open and view the INBOX, SENT ITEMS or subfolders, then remove that mailbox or add another as he desires. The only solution I have found so far is opening the EXCHANGE console and selecting a users mailbox and going through the MANAGE FULL ACCESS procedure. This does not give him random access to call up users mail conviently and would require me to click every mailbox on our server to configure. Is there a striaght, cut and dry method that will allow me to give our IT director the mail access he wants. Perhaps a string of commands in the EXCHANGE shell? I have full Exchange admin and domain admin rights, but even I cannot add and view a users mailbox to my OUTLOOK without first going through the MANAGE FULL ACCESS procedure first...all suggestions welcome...thanks
Who is Participating?
Joseph DalyCommented:
You can grant full access permissions to your director on the entire database rather than individual mailboxes. Rather than retyping see the article written by EE's own tigermatt.

You can surely use the following powershell cmdlet
for example :
This example will grant Ted Bremer full access to Ellen Adam's mailbox.
Add-MailboxPermission -Identity "Ellen Adams" -User TedBrem -Accessright Fullaccess -InheritanceType all

Note:The Identity parameter requires the full name of the user in quotation marks.
Sekar ChinnakannuStaff EngineerCommented:
Thor2923Author Commented:
I am trying the command:

Get-MailboxDatabase -identity “[mailbox database name]” | Add-ADPermission -user [username] -AccessRights GenericAll

but it does not seem to like my database name. Where do I find the exact DB name that should be in this command? I am looking under Exchange console Server Configuration/Mailbox and I am in the database tab. The command does not seem to like any databasse I enter. I am assuming the database should have " on each side and I do not need the [] when I am entering the live command. Is there perhaps a path I need to enter with the database? I have had this problem before with EXCHANGE SHELL commands, I can never get the correct database name. I uploaded am image of the screen I am looking at on my EXCHANGE 2007 console where I am trying to find the databases. I was using "mailbox database" and "ExecDB" in the "[mailbox database name]" and my system can not seem to find them
Joseph DalyCommented:
If you just run the command get-mailboxdatabase you should be able to see a listing of all of them.

Then you can select the DB you want to use. I just tested it and dont think you need the quotes.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.