Help, firefox fails to load after upgrade to 4.01

This morning, I got the notification about an upgrade to 4.01 being available. I was running 3.6.16 so I went ahead and upgraded firefox.

Ever since, I can't open Firefox. In the list of processes in Windows Firefox shows up, but the browser itself doesn't load.

It's weird to use IE after 6 years. Moreover, all my passwords are in there, although I do have a backup.

Any help in resolving this would be greatly appreciated.

Thanks in advance.
scmeevenAsked:
Who is Participating?
 
sg08234Commented:
What about:

mozbackup for backup of the settings
deinstallation
reboot
new installation

Good luck - sg08234
0
 
houssam_balloutCommented:
0
 
Jackie ManCommented:
....then, post back the add-ons installed in your firefox (tools -> add-ons)
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
Jackie ManCommented:
Besides, does your computer fulfill the requirements..

Windows
Operating Systems

    * Windows 2000
    * Windows XP
    * Windows Server 2003
    * Windows Vista
    * Windows 7

Please note that while the 32-bit and 64-bit versions of Windows Vista and Windows 7 can be used to run Firefox 4, only 32-bit builds of Firefox 4 are supported at this time.
Recommended Hardware

    * Pentium 4 or newer processor that supports SSE2
    * 512MB of RAM
    * 200MB of hard drive space

Source: http://www.mozilla.com/en-US/firefox/4.0.1/system-requirements/
0
 
scmeevenAuthor Commented:
@houssam_ballout, it doesn't open even in Safemode.
@jackieman, my laptop is a Windows XP Pro with about 2 GB of space left. That seems to meet all the requirements
@sg08234, I am going to try your suggestion. I have mozbackup somewhere.
0
 
Jackie ManCommented:
Right click "My Computer" -> Manage -> Goto Event Viewer and post back the error you got.
0
 
sg08234Commented:
mozbackup: http://mozbackup.jasnapaka.com/

Regards - sg08234
0
 
scmeevenAuthor Commented:
@jackieman, I get no error. I see the hour glass icon for a few times when I click on Firefox and then there is nothing. When I look at the running processes, there is firefox.exe
0
 
scmeevenAuthor Commented:
This worked. I got mozbackup and backed up the 4.01 profile. Then, uninstalled FF through the control panel. One change - instead of reinstalling FF 4.01, I went to http://www.mozilla.com/en-US/firefox/all-older.html and downloaded the previous version 3.6.17 that had been working trouble free. Everything came back the way it was.

One note of caution - when uninstalling Firefox, DON'T enable the option to remove Firefox data. Otherwise, you will lose all your bookmarks, extension and stuff.
0
 
sg08234Commented:
Thanks for accepting solution!

Additional comment: If you have a mozbackup-Backup you can restore bookmarks, extension and other stuff stuff from it even if you selected the option "remove Firefox data" during deinstallation.

Regards - sg08234
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.