Message is looping. Error

Hi Everyone,

I have a client who has a funny sort of setup.

Its a doctors surgery who got brought out by a pharmacy. The doctors surgery was independent running its own sbs server and receiving mail etc as per a normal site.

When the pharmacy brought them out, the old IT guys moved the domain/sbs server from their old site and dumped it as per normal into the new site.
The pharmacy and the doctors surgery share the same internet connection through Telstra managed wan. This is all working so far.
The old IT guy got telstra to create a new external IP that is "assumingly" NAT'd through to the sbs server on port 25 to accept the mail on. This seems to be working correctly.
The pharmacy has its own domain name however and has telstra hosted mail. This is then POP'd to the sbs server and is supposed to be delivered to the users associating mailboxes. This doesnt work. When I took over, they were unable to receive the mail as the POP mail was from a different email domain to the users mailbox. To work around this, I created a new SMTP connector with the new domain name and turned the server off being the authoritive body so they wouldnt get bounce backs etc when the sbs server couldnt find people outside of the AD. This seemed to work for about 2 weeks fine. I went back to site today to find the POP connector was not receiving / Connecting / event logging etc. Restarted all the services etc and didnt come up, So I rebooted server. Worked fine, POP connector was working again.

I decided to send some test emails and started getting this bounceback message:

<emailaddress@domain.com.au>: internal software error. Command output:    Message is looping.  Existing Delivered-To for
emailaddress@domain.com.au

I cannot understand what has changed from doing a reboot that would cause this issue especially when it was working successfully after the configurations I made.

I hope I have given enough information, unfortunately I wont be able to post any screenshots etc at this point of my SMTP connectors, POP Connectors, Default Virtual SMTP as I dont have remote access to this site. I will be back there on Monday however, trying to do any recommendations you guys might come up with.

Cheers

Tony
LVL 1
H0ff3RAsked:
Who is Participating?
 
NetfloConnect With a Mentor Commented:
Hi H0ff3R,

Can you please ensure first of all the the SBS 2003 server is fully up to date. There is an update for the SBS 2003 POP3 connector, which I would recommend installing:
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=7b1ff109-092e-4418-aa37-a53af7b8f6fc

Can you also install the SBS Best Practices Analyser and see if there is anything under the hood which the SBS doesn't like:
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=3874527a-de19-49bb-800f-352f3b6f2922&displaylang=en

You could even go a step further to install and run the Exchange 2003 BPA (okay to run on SBS 2003): http://www.microsoft.com/downloads/en/details.aspx?familyid=dbab201f-4bee-4943-ac22-e2ddbd258df3&displaylang=en


This should allow you to ensure that everything is fairly up to date and running correctly. Please give this a go and report you findings, best of luck!
0
 
scriven_jCommented:
Unless I have misunderstood the set-up, the two mail servers shouldn't have any communication between each other.  POP3 is a PULL Email system (the SBS server goes to the mail handling server and requests the Email which is downloaded).  This uses Port 110 and only requires the SBS server to have internet access.

The other server uses SMTP which is a PUSH technology, meaning that this server gets connected to on Port 25 by other mail servers which then use SMTP to route the traffic.  The two mail servers shouldn't interact at all as the mail server handling the POP3 domain is actually the next hop along and not the SBS box.

I would start by following this POP3 troubleshooting guide:-

http://support.microsoft.com/kb/885685
0
 
scriven_jConnect With a Mentor Commented:
I am still trying to get my head round the set-up from this post, but message looping is when a message is bouncing between two servers, so it may be that neither server thinks it is authoritative for the Email.  In the example you gave, did you send test Emails externally (from a webmail type account) or internally (from Outlook for instance).  Is the Email address you sent TO and internal or external one?

It may be that this is an SMTP authoritative domain problem and that you need to mark the SBS box as authoritative for the domain in question.  These articles might help:-

http://support.microsoft.com/kb/823158

http://www.msexchange.org/tutorials/exchange-2003-smtp-namespace-sharing.html
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
H0ff3RAuthor Commented:
Hey guys,

Its always hard to write it down correctly.

There is Telstra hosted mail (domain1.com.au) to which all the clients had mailboxes on.
The Exchange server then pops all email from the telstra hosted mail (domain1.com.au) and dumps it into the users exchange mailbox (domain2.com.au). The exchange mailbox originally is setup for domain2.com.au and needs to combine both sets of mail from domain1.com.au and domain2.com.au.
Domain2.com.au mailboxes were setup to email out at domain1.com.au.
This caused errors when they tried to email to people who werent in the AD tree as it would complete a NDR saying they dont exist.
Extra SMTP connectors were setup to send out as domain1.com.au, and the virtual smtp connector was set to be non-authoritive enabling to send to people outside of the AD tree.

This was working a correctly until reboot.

In my mind, there should be no looping as you said POP is a pull tech, so when it gets pulled it should dump straight into the mailbox without issues.

I will check the updates, to make sure they are fine, especially the pop collector one.

I will run the BPA and see if there are any negatives from that.

If you guys need further clarification let me know. I may not reply again tonight, its beer o'clock.

Cheers
0
 
scriven_jCommented:
I just want to clarify where the mails that are looping are being sent from / to.
0
 
scriven_jConnect With a Mentor Commented:
Here are some general pointers for checking mailflow:-

http://www.msexchange.org/tutorials/exchange-server-2003-mailflow-part1.html
http://www.msexchange.org/tutorials/exchange-server-2003-mailflow-part-2.html

Other things to look at are internal and external DNS (might need an internal MX record to clarify internal mailflow).

I would go through a systematic test, disabling different connectors and testing each section of the mailflow is behaving as expected.  Definitely turn on all SMTP/POP3/Exchange logging whilst you are there to see if that gives you anymore clue.
0
 
scriven_jCommented:
One other thing to note is that Exchange settings often take a while to take effect unless you restart the System Attendant after each change, so be careful when making wholesale changes as you might break something and not notice till the next reboot (or until the system has caught up with itself)which could be what has caused this situation in the first place.....
0
 
scriven_jCommented:
The Exchange Troubleshooting Analyser also looks at mailflow and so might be worth a look:-

http://blogs.technet.com/b/exchange/archive/2006/08/07/3394688.aspx
0
 
scriven_jCommented:
Sorry - I should have said Troubleshooting Assistant....

You can download it from here:-

http://www.microsoft.com/downloads/en/details.aspx?familyid=4bdc1d6b-de34-4f1c-aeba-fed1256caf9a&displaylang=en
0
 
H0ff3RAuthor Commented:
Well guys I think I sorted it out.

There is another SMTP connector there - which I believe is causing the looping. Noted all settings and removed.

Stopped the looping but then opened another issue of not resolving names outside the AD. went to the default smtp virtual server and changed it to forward all non-resolving emails out to the smart host. That should fix it and stop any further NDR's - Havent had any negative feedback yet.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.