Dell Optiplex 745 (Desktop) Hard Drive Password Reset

Dear Experts

Is there a way to reset/remove Dell Optiplex 745 (Desktop) Hard Drive Password?

Right after POST, it asks for hard drive password, reseting CMOS Jumper/Battery, load default settings didn't show required result. If I try to reset/remove hard drive password from BIOS, it asks me old password :(

Is their any work arround to reset it without paying to company or crackers...

Thanks
Adeel
LVL 3
adeelg1Asked:
Who is Participating?
 
n2fcConnect With a Mentor Commented:
Are you referring to the BIOS system password or the TPM password?

I suspect you mean the TPM password, and if so, it is designed to be "crackproof!"

See:
http://phubner.eng.ua.edu/Files/Optiplex%20745/advfeat.htm#wp1147926

0
 
adeelg1Author Commented:
Hi n2fc

Well, I'm not sure if its TPM password!!

After POST, It just give black screen with only one sentence "Enter Hard Drive Password:****"
But I go to its CMOS Setup I can clearly see option for harddisk password & it says 'ON'. When I try to reset it asks for Old password which I dont have. If I try any bogus password then it reply incorrect old password.

Might be BIOS password...
0
 
jamietonerConnect With a Mentor Commented:
Bios password can be reset with the password jumper on the motherboard. The hdd password cant be reset. There are tools that claim thet can but ive never seen one that worked. The hdd is most likely a paperweight if you cant get the password. If you need to recover data youll need to contact a professional data recovery center.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
adeelg1Author Commented:
So no way....

Please let me know one thing more, Is this password on Hard disk itself? Is it not from CMOS setup on Hard drive controller?

That means If I change the HDD things will be OK, right?
0
 
jamietonerCommented:
The password is stored on the hdd so replacing it should fix it.
0
 
jamietonerCommented:
The password is stored on the hdd so replacing it should fix it.
0
 
nobusConnect With a Mentor Commented:
try HDD unlock :  http://www.hddunlock.com/
0
 
n2fcCommented:
I haven't tried HDD unlock and would be curious if it works on this!

For more info on TPM on the Dell Optiplex and how it integrates with Bitlocker encryption see:

http://support.dell.com/support/edocs/systems/Op745/en/UG_en/advfeat.htm#wp1147926

http://windows.microsoft.com/en-US/windows-vista/BitLocker-Drive-Encryption-Overview

I am still not sure if your issue is a password related to TPM or not...

Did you try physically removing the drive and trying to access it while attached to another system?
That might tell you if it using his style encryption...

The O/S would also be a clue, as Bitlocker is only available with Vista or Win 7 (Enterprise/Ultimate)

If not using these OS's, it might be a 3rd party encryption driver prompt as part of the boot process that you are viewing...
0
 
n2fcConnect With a Mentor Commented:
Just did some more reading on HDDUNLOCK...

It seems it is only used to "refresh" a locked drive (wipe it clean) as opposed to actually decrypting the data...

It was unclear from your original question whether you were trying to recover the data or merely wipe the HD and "start over"...

The same company that supplies HDDUNLOCK has another program: AFF REPAIR STATION
http://www.hdd-tools.com/
that can remove/reset a firmware password, but only on certain brands of drives...

This is DIFFERENT than DRIVE ENCRYPTION (which is what I thought you were dealing with prior to reading up on this!)

If you are going to use either hddunlock or aff repair station, you will need to check the drive manufacturer to see if it is one of those brands they support...

Otherwise... sorry... no joy!
0
 
nobusCommented:
i would check what it does with another disk drive
0
 
adeelg1Author Commented:
Password is on HDD itself, locked by dell HDD security.

Attached the HDD with other computer as secondary, still ask for password before booting. I can see HDD in device manager but no any partition in my computer or manage...

Installed HDD unlock tool but I believe it works with ONLINE database & my work place has proxy configured so it couldn't get connected. There isn't any option to add proxy in HDDunlock aplication.

Is there a way to completely washout without caring any data loss???
0
 
nobusCommented:
go to a place without proxy then - easiest solution imo
0
 
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.