[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 569
  • Last Modified:

Configuring Cisco 877 to allow connections to an ISA VPN behind it

Hello experts,

We had an ISA server supporting PPTP VPN. The ISA server was behind a Linksys router, in which I had configured DMZ setting to refer to ISA IP address in order to allow VPN remote users to connect.

Now, we have replace the Linksys with Cisco 877. Thanks for EE members help in configuring it.

Now the final step is to allow ISA VPN remote access. I think it need some config for GRE and PPTP protocols Natting.

Would you please help? The ISA server address is 192.168.1.45
0
Muhajreen
Asked:
Muhajreen
  • 12
  • 7
  • 4
  • +1
1 Solution
 
Ernie BeekCommented:
Have a look at these:
Configuring PPTP Through PAT to a Microsoft PPTP Server
http://www.cisco.com/en/US/tech/tk827/tk369/technologies_configuration_example09186a00800949c0.shtml

NAT—Support for PPTP in an Overload (Port Address Translation) Configuration
http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/prod_bulletin09186a0080091abd.html#wp45349
0
 
greg wardCommented:
conf t
ip nat inside source static tcp 192.168.1.? 1723 interface dialer0 1723
Where ? is the device ip (guessing the 192.168.1.)
not sure that you need gre for this.

Greg
0
 
Craig BeckCommented:
deepdraw is correct.  You don't need to forward GRE, just TCP/1723.

http://www.cisco.com/en/US/tech/tk827/tk369/technologies_configuration_example09186a00800949c0.shtml

The statement you need would be...

ip nat inside source static tcp 192.168.1.45 1723 interface Dialer0 1723
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 
MuhajreenAuthor Commented:
Thank you.

Actually I have added the ip nat entry:

ip nat inside source static tcp 192.168.1.45 1723 interface Dialer1 1723

But still PPTP is not working.

In the article given above, in the nat translation table of both house and light routers, there are GRE entries, which I didn't find in my router's show ip nat translations
0
 
greg wardCommented:
Actually I have added the ip nat entry:

ip nat inside source static tcp 192.168.1.45 1723 interface Dialer1 1723

You are using dialer0 so it should be

ip nat inside source static tcp 192.168.1.45 1723 interface Dialer0 1723

Greg
0
 
MuhajreenAuthor Commented:
Here is show dialer:

Di0 - dialer type = NONE
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Number of active calls = 0

Dial String      Successes   Failures    Last DNIS   Last status

Di1 - dialer type = DIALER PROFILE
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Number of active calls = 0
0
 
greg wardCommented:
please can you paste your config with passwords and internet ip's removed.

Greg
0
 
MuhajreenAuthor Commented:
Building configuration...

Current configuration : 12652 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HoMainInternetRouter
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 ####################
enable password #########
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-3946608639
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3946608639
 revocation-check none
 rsakeypair TP-self-signed-3946608639
!
!
crypto pki certificate chain TP-self-signed-3946608639
 certificate self-signed 02
########################
        quit
dot11 syslog
ip cef
!
!
ip port-map user-protocol--1 port tcp 3389
ip name-server ########
ip name-server ########
!
parameter-map type protocol-info msn-servers
 server name messenger.hotmail.com
 server name gateway.messenger.hotmail.com
 server name webmessenger.msn.com

parameter-map type protocol-info aol-servers
 server name login.oscar.aol.com
 server name toc.oscar.aol.com
 server name oam-d09a.blue.aol.com

parameter-map type protocol-info yahoo-servers
 server name scs.msg.yahoo.com
 server name scsa.msg.yahoo.com
 server name scsb.msg.yahoo.com
 server name scsc.msg.yahoo.com
 server name scsd.msg.yahoo.com
 server name cs16.msg.dcn.yahoo.com
 server name cs19.msg.dcn.yahoo.com
 server name cs42.msg.dcn.yahoo.com
 server name cs53.msg.dcn.yahoo.com
 server name cs54.msg.dcn.yahoo.com
 server name ads1.vip.scd.yahoo.com
 server name radio1.launch.vip.dal.yahoo.com
 server name in1.msg.vip.re2.yahoo.com
 server name data1.my.vip.sc5.yahoo.com
 server name address1.pim.vip.mud.yahoo.com
 server name edit.messenger.yahoo.com
 server name messenger.yahoo.com
 server name http.pager.yahoo.com
 server name privacy.yahoo.com
 server name csa.yahoo.com
 server name csb.yahoo.com
 server name csc.yahoo.com

parameter-map type regex sdm-regex-nonascii
 pattern [^\x00-\x80]

!
!
username ####### privilege 15 password 0 #########
!
!
archive
 log config
  hidekeys
!
!
!
class-map type inspect smtp match-any sdm-app-smtp
 match  data-length gt 5000000
class-map type inspect match-any SDM_HTTPS
 match access-group name SDM_HTTPS
class-map type inspect match-any SDM_SSH
 match access-group name SDM_SSH
class-map type inspect match-any SDM_SHELL
 match access-group name SDM_SHELL
class-map type inspect match-any sdm-cls-access
 match class-map SDM_HTTPS
 match class-map SDM_SSH
 match class-map SDM_SHELL
class-map type inspect match-all sdm-nat-user-protocol--1-3
 match access-group 104
 match protocol user-protocol--1
class-map type inspect match-all sdm-nat-smtp-2
 match access-group 110
 match protocol smtp
class-map type inspect http match-any sdm-app-nonascii
 match  req-resp header regex sdm-regex-nonascii
class-map type inspect match-all sdm-nat-user-protocol--1-2
 match access-group 103
 match protocol user-protocol--1
class-map type inspect match-all sdm-nat-user-protocol--1-1
 match access-group 102
 match protocol user-protocol--1
class-map type inspect match-all sdm-nat-smtp-1
 match access-group 105
 match protocol smtp
class-map type inspect match-all sdm-nat-imap-1
 match access-group 107
 match protocol imap
class-map type inspect imap match-any sdm-app-imap
 match  invalid-command
class-map type inspect match-any sdm-cls-insp-traffic
 match protocol dns
 match protocol https
 match protocol icmp
 match protocol imap
 match protocol pop3
 match protocol tcp
 match protocol udp
class-map type inspect match-all sdm-insp-traffic
 match class-map sdm-cls-insp-traffic
class-map type inspect match-any SDM-Voice-permit
 match protocol h323
 match protocol skinny
 match protocol sip
class-map type inspect match-any sdm-cls-icmp-access
 match protocol icmp
 match protocol tcp
 match protocol udp
class-map type inspect match-all sdm-nat-pop3-1
 match access-group 106
 match protocol pop3
class-map type inspect pop3 match-any sdm-app-pop3
 match  invalid-command
class-map type inspect match-all sdm-access
 match class-map sdm-cls-access
 match access-group 101
class-map type inspect http match-any sdm-http-blockparam
 match  request port-misuse im
 match  request port-misuse p2p
 match  request port-misuse tunneling
 match  req-resp protocol-violation
class-map type inspect match-all sdm-icmp-access
 match class-map sdm-cls-icmp-access
class-map type inspect match-all sdm-invalid-src
 match access-group 100
class-map type inspect http match-any sdm-app-httpmethods
 match  request method bcopy
 match  request method bdelete
 match  request method bmove
 match  request method bpropfind
 match  request method bproppatch
 match  request method connect
 match  request method copy
 match  request method delete
 match  request method edit
 match  request method getattribute
 match  request method getattributenames
 match  request method getproperties
 match  request method index
 match  request method lock
 match  request method mkcol
 match  request method mkdir
 match  request method move
 match  request method notify
 match  request method options
 match  request method poll
 match  request method post
 match  request method propfind
 match  request method proppatch
 match  request method put
 match  request method revadd
 match  request method revlabel
 match  request method revlog
 match  request method revnum
 match  request method save
 match  request method search
 match  request method setattribute
 match  request method startrev
 match  request method stoprev
 match  request method subscribe
 match  request method trace
 match  request method unedit
 match  request method unlock
 match  request method unsubscribe
class-map type inspect match-all sdm-nat-https-1
 match access-group 108
 match protocol https
class-map type inspect match-all sdm-nat-imaps-1
 match access-group 109
 match protocol imaps
!
!
policy-map type inspect sdm-permit-icmpreply
 class type inspect sdm-icmp-access
  inspect
 class class-default
  pass
policy-map type inspect sdm-pol-NATOutsideToInside-1
 class type inspect sdm-nat-user-protocol--1-1
  inspect
 class type inspect sdm-nat-user-protocol--1-2
  inspect
 class type inspect sdm-nat-user-protocol--1-3
  inspect
 class type inspect sdm-nat-smtp-1
  inspect
 class type inspect sdm-nat-pop3-1
  inspect
 class type inspect sdm-nat-imap-1
  inspect
 class type inspect sdm-nat-https-1
  inspect
 class type inspect sdm-nat-imaps-1
  inspect
 class type inspect sdm-nat-smtp-2
  inspect
 class class-default
policy-map type inspect sdm-inspect
 class type inspect sdm-invalid-src
  drop log
 class type inspect sdm-insp-traffic
  inspect
 class type inspect SDM-Voice-permit
  inspect
 class class-default
  pass
policy-map type inspect http sdm-action-app-http
 class type inspect http sdm-http-blockparam
  log
  reset
 class type inspect http sdm-app-httpmethods
  log
  reset
 class type inspect http sdm-app-nonascii
  log
  reset
policy-map type inspect pop3 sdm-action-pop3
 class type inspect pop3 sdm-app-pop3
  log
  reset
policy-map type inspect sdm-permit
 class type inspect sdm-access
  inspect
 class class-default
policy-map type inspect imap sdm-action-imap
 class type inspect imap sdm-app-imap
  log
  reset
policy-map type inspect smtp sdm-action-smtp
 class type inspect smtp sdm-app-smtp
  reset
!
zone security out-zone
zone security in-zone
zone-pair security sdm-zp-self-out source self destination out-zone
 service-policy type inspect sdm-permit-icmpreply
zone-pair security sdm-zp-out-self source out-zone destination self
 service-policy type inspect sdm-permit
zone-pair security sdm-zp-in-out source in-zone destination out-zone
 service-policy type inspect sdm-inspect
zone-pair security sdm-zp-NATOutsideToInside-1 source out-zone destination in-zone
 service-policy type inspect sdm-pol-NATOutsideToInside-1
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.2 point-to-point
 pvc 8/35
  encapsulation aal5snap
  protocol ppp dialer
  dialer pool-member 1
 !
!
interface FastEthernet0
 no cdp enable
!
interface FastEthernet1
 shutdown
 no cdp enable
!
interface FastEthernet2
 shutdown
 no cdp enable
!
interface FastEthernet3
 shutdown
 no cdp enable
!
interface Vlan1
 description $FW_INSIDE$
 ip address 192.168.1.10 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 zone-member security in-zone
!
interface Dialer0
 no ip address
!
interface Dialer1
 description $FW_OUTSIDE$
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 zone-member security out-zone
 encapsulation ppp
 dialer pool 1
 dialer-group 2
 ppp authentication chap pap callin
 ppp chap hostname #######
 ppp chap password 0 #######
 ppp pap sent-username ###### password 0 ########
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static tcp 192.168.1.50 3389 interface Dialer1 65050
ip nat inside source static tcp 192.168.1.45 3389 interface Dialer1 65045
ip nat inside source static tcp 192.168.1.54 3389 interface Dialer1 3389
ip nat inside source static tcp 192.168.1.50 25 interface Dialer1 25
ip nat inside source static tcp 192.168.1.50 110 interface Dialer1 110
ip nat inside source static tcp 192.168.1.50 143 interface Dialer1 143
ip nat inside source static tcp 192.168.1.50 443 interface Dialer1 443
ip nat inside source static tcp 192.168.1.50 993 interface Dialer1 993
ip nat inside source static tcp 192.168.1.45 1723 interface Dialer1 1723
!
ip access-list extended SDM_HTTPS
 remark SDM_ACL Category=1
 permit tcp any any eq 443
ip access-list extended SDM_SHELL
 remark SDM_ACL Category=1
 permit tcp any any eq cmd
ip access-list extended SDM_SSH
 remark SDM_ACL Category=1
 permit tcp any any eq 22
!
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 100 remark SDM_ACL Category=128
access-list 100 permit ip host 255.255.255.255 any
access-list 100 permit ip 127.0.0.0 0.255.255.255 any
access-list 101 remark SDM_ACL Category=128
access-list 101 permit ip any any
access-list 102 remark SDM_ACL Category=0
access-list 102 permit ip any host 192.168.1.50
access-list 103 remark SDM_ACL Category=0
access-list 103 permit ip any host 192.168.1.45
access-list 104 remark SDM_ACL Category=0
access-list 104 permit ip any host 192.168.1.54
access-list 105 remark SDM_ACL Category=0
access-list 105 permit ip any host 192.168.1.50
access-list 106 remark SDM_ACL Category=0
access-list 106 permit ip any host 192.168.1.50
access-list 107 remark SDM_ACL Category=0
access-list 107 permit ip any host 192.168.1.50
access-list 108 remark SDM_ACL Category=0
access-list 108 permit ip any host 192.168.1.50
access-list 109 remark SDM_ACL Category=0
access-list 109 permit ip any host 192.168.1.50
access-list 110 remark SDM_ACL Category=0
access-list 110 permit ip any host 192.168.1.50
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
snmp-server community public RO
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 no modem enable
line aux 0
line vty 0 4
 password ###########
 login
!
scheduler max-task-time 5000
no process cpu extended
no process cpu autoprofile hog
end

0
 
Craig BeckCommented:
Have you allowed port 1723 and GRE through the firewall on the router?
0
 
MuhajreenAuthor Commented:
Due to expert comments above, I did't allow GRE as it's not required.
I have allowed TCP 1723 only.
0
 
Craig BeckCommented:
Have you enabled PPTP inspection?
0
 
MuhajreenAuthor Commented:
No, I haven't enable PPTP inspection.

Is it enabled by default?
0
 
Craig BeckCommented:
I don't think so.  I've had a look through the config you posted but I couldn't see it.

This might be handy (although it is based on a Cisco ASA the same applies with inspection)...

https://supportforums.cisco.com/message/3021024
0
 
MuhajreenAuthor Commented:
Shall this solve my issue? If so, would you please give me the exact steps ? The article is focusing a higher experience level than mine.
0
 
greg wardCommented:
Just because you dont need to set up nat for this does not mean it does not use it from inside!
Once the Isa receives the request on port 1723 it might want to use gre so it will need to be allowed.
I dont think its possible to set up incoming gre nat without using a whole ip address.

Greg
0
 
MuhajreenAuthor Commented:
Sorry Greg, I didn't get you.
0
 
greg wardCommented:
Where you see the nat translations on the cisco website, they are created from the ISA.
If you go to a website and look at the translation rule you will see the ip of the computer and the website in the list.
Does that make sense

Does it would work if you remove the firewall?

Greg
0
 
MuhajreenAuthor Commented:
If I disable the router firewall, will other nat configs remain working? If so, how to disable the firewall for testing?
0
 
MuhajreenAuthor Commented:
Any help?
0
 
greg wardCommented:
to remove
conf t
interface Vlan1
no zone-member security in-zone
int dialer1
no zone-member security out-zone

to re-apply
conf t
interface Vlan1
zone-member security in-zone
int dialer1
zone-member security out-zone


Greg
0
 
MuhajreenAuthor Commented:
Great ! It's worked after disabling the firewall
0
 
MuhajreenAuthor Commented:
Great ! It's worked after disabling the firewall.

What is the next step now ?
0
 
greg wardCommented:
I would ask another question about how to set up your firewall correctly stating which IOS you have on you router and which services you want to allow.
Greg
0
 
MuhajreenAuthor Commented:
Thank you
As we have solved the main issue, then I will post a new question regarding firewall configuration in detail.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 12
  • 7
  • 4
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now