?
Solved

SharePoint help

Posted on 2011-05-06
6
Medium Priority
?
322 Views
Last Modified: 2012-05-11
Hi,

We have a custom application, that we want the users be able to directly from SharePoint. Just like the Office documents. The custom mime type has been registered in the IIS and the necessary changes to docicon.xml have been made.

So, the issue is, when a user tries to open the application from SharePoint, it shows following error message. Same application opens fine on a different server.
The only difference is the server where this is not working is SSL enabled. am i missing any specific setting on the server that is preventing this?

"The document could not open for editing. A Windows SharePoint Services 3.0 compatible application could not be found."

Any help is greatly appreciated.


0
Comment
Question by:Techsavy
5 Comments
 
LVL 10

Expert Comment

by:Minesh Shah
ID: 35711586
depends on what custom application and how did you embdeded into sharepoint & how are you accessing it from sharepoint.
0
 

Author Comment

by:Techsavy
ID: 35712506
The application has a similar packaging structure as office documents, and we save these files in a document library. So, nice thing is WSS is recognizing the applications' icon, which means mime-type have been correctly registered. So, the point is now when we right-click our application file in SharePoint  and say "Edit in our custom application" we get the above error.  We do not get this error on a server, where we dont have a fully qualified domain name.

Also, some additional information: The server where this is not working has a fully qualified domain name and has ssl enabled.

Let me know if you need any additional information, I will continue to debug.

Thanks for the help.

0
 
LVL 1

Accepted Solution

by:
andrepinn earned 2000 total points
ID: 35713223
Hi

I'm not sure if this is right, but I have seen this error with 1 user at my company, and after the office package was re-installed on that machine - it all worked fine. We use SP2010 and office 2007.

Let me know if this helps or if you have tried it before.

Regards,

Andre
0
 

Author Comment

by:Techsavy
ID: 35713653
Hi Andre,

Your solution seems to work fine in the case where this error is seen with office documents. But in this case, all office documents work within SharePoint context with no error.

thanks for the suggestion.
0
 
LVL 11

Expert Comment

by:sparab
ID: 35900334
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A high-level exploration of how our ever-increasing access to information has changed the way we do our jobs.
As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
This video walks the viewer through the process of creating Hyperlinks for the web and other documents. Select the "Insert" tab: Click "Hyperlink":  Type "http://" followed by a web address to reference a website or navigate to a document to ref…
The viewer will learn how to create two correlated normally distributed random variables in Excel, use a normal distribution to simulate the return on different levels of investment in each of the two funds over a period of ten years, and, create a …

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question