?
Solved

Excel files open in Internet Explorer

Posted on 2011-05-06
21
Medium Priority
?
1,656 Views
Last Modified: 2012-05-11
Hello,

If I open a link to an Excel document through Internet Explorer and choose to open the file, it does so in Internet Explorer. How do I make it so that this link will open in Excel?

I have read this article support.microsoft.com/kb/162059  and tried the registry fix but it seems to have no effect on Windows 7. Previously in XP this could be changed through the 'Open in Browser' advanced option, however that doesn't exist in Windows 7.

Configuration is Win7, Office 2007 and IE 8.

Thanks
0
Comment
Question by:piemckay
  • 8
  • 4
  • 3
  • +4
21 Comments
 
LVL 4

Expert Comment

by:argh226
ID: 35706187
I believe I have seen this...
Have you tried to go into control panel and look in to default programs?  Last time I played like that it changed that behavior... a while ago tho
0
 

Author Comment

by:piemckay
ID: 35706251
I have been through and everything is set to open in Excel. If I save the file and then open it, it works fine. Just if I open it directly from the IE link.
0
 
LVL 16

Expert Comment

by:Kalpesh Chhatrala
ID: 35706290
Change Setting as per below. It's Work for Me
Go to tools/internet options/security/custom level and

check if "Automatic prompting for file downloads" is disabled.

Make it Enabled.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 22

Expert Comment

by:Ivano Viola
ID: 35706478
If all else fails you can try resetting Internet Explorer to its default settings.
Tools - Internet Options - Advanced - Reset

That may help.
0
 
LVL 81

Expert Comment

by:zorvek (Kevin Jones)
ID: 35706529
When opening an HTML link to an Excel workbook, Internet Explorer may open the file in Internet Explorer instead of opening the file in the Excel application. By default, Internet Explorer is configured to host documents for Office programs. This means that the problem can start when a new version of Internet Explorer is installed or the current installation is repaired. This problem can be resolved one of two ways.

Use Folder Options

Note that this method is likely not available in Windows NT 4.0. Open My Computer. Select the menu command Tools->Folder Options (or View->Folder Options) and navigate to the File Types tab. In the Registered file types list, select the ".XLS" document type (Microsoft Excel Worksheet), click Advanced (or Edit), uncheck the check box "Browse in same window" or "Open Web documents in place", and click OK.

Edit the Windows Registry

Start Registry Editor (choose Run from the Start menu and enter "regedit". Locate and open the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Classes. Within that key locate the applicable Excel document key "Excel.Sheet.#". Add the following value for all Excel.Sheet.# subkeys except Excel.Sheet.5:

   Value name: BrowserFlags
   Data type: REG_DWORD
   Value: 8

For Excel.Sheet.5, add the following value:

   Value name: BrowserFlags
   Data type: REG_DWORD
   Value: 9

Quit Registry Editor.

Source: http://support.microsoft.com/default.aspx?scid=162059

Kevin
0
 

Author Comment

by:piemckay
ID: 35706749
Thanks for the responses.

kalpesh2804: - It's enabled for all zones

ivanoviola: - tried that without success

zorvek: - checked and double checked the keys and they are correct. rebooted as well with no difference.
0
 
LVL 22

Expert Comment

by:Ivano Viola
ID: 35706761
Maybe an upgrade to IE9 may work?
0
 

Author Comment

by:piemckay
ID: 35706777
Unfortunately a last resort as we have an ERP system that isn't supported on IE9.
0
 
LVL 81

Expert Comment

by:zorvek (Kevin Jones)
ID: 35706788
Have you tried repairing the Excel installation?

Kevin
0
 

Author Comment

by:piemckay
ID: 35706815
Yes I did the whole office suite.

Sorry I should have mentioned this problem occurs for all office applications.
0
 
LVL 81

Expert Comment

by:zorvek (Kevin Jones)
ID: 35706845
Firefox? Kidding!

Actually, try clicking a link to an Excel workbook in Firefox just for fun and let's see what happens. I have no idea why I'm asking this but it sounds like an interesting test. I expect it to work but if it doesn't, that WOULD be interesting.

Kevin
0
 
LVL 22

Expert Comment

by:Ivano Viola
ID: 35706903
Does the same problem occur if you run IE8 as Administrator? I think repairing Office as zorvek suggested may help.

Click on the Orb (top-left) - Excel Options - Resources - Diagnose (under "run MS Diagnostics").
0
 

Author Comment

by:piemckay
ID: 35707158
I am running as administrator so yes. I tried the repair and diagnostics comes up with nothing.

Just removed IE8 and put it back on, same thing!

Firefox does work ok, not an option for us though. shame.....
0
 

Expert Comment

by:pvsbandi
ID: 35707197
Hi piemckay,

    What you need to do is to go to open any folder and go to folder options and then to file types.
    Then navigate to the Xls extension and there, uncheck "open in browser" (don't remember the exact option) and select the prompt option.
Hope this helps.
0
 

Author Comment

by:piemckay
ID: 35707205
Hi pvsbandi. I'm running Windows 7 so I don't have that option. Wish I did!
0
 
LVL 59

Accepted Solution

by:
LeeTutor earned 2000 total points
ID: 35709647
0
 
LVL 81

Expert Comment

by:zorvek (Kevin Jones)
ID: 35709683
Be careful with that page LeeTutor provided. It's been identified as an attack page.

You might find this tool useful:

Title: Types
Link: http://izt.name/soft/types/

Description from the page: "Types is a simple freeware utility that allows you to manage program associations, icons, context menus and other properties of different file types in Windows."

Kevin
0
 
LVL 59

Expert Comment

by:LeeTutor
ID: 35716808
piemckay, any feedback?
0
 

Author Comment

by:piemckay
ID: 35718204
Sorry I was away at the weekend so couldn't test.

The FileTypesMan utlity did work and has corrected the issue. Best to go straight to the developer's site to avoid any security hazards.

http://www.nirsoft.net/utils/file_types_manager.html

The utility you suggested, Zorvek, would probably work as well but it doesn't have a handy check box so I didn't know which values to change. Does anyone know (before I close the question) the actual change FileTypesMan makes when you check the box? It would be handy to be able to sort this without using a 3rd party tool.

Thanks
0
 
LVL 59

Expert Comment

by:LeeTutor
ID: 35739266
I think you should be able to use the Process Monitor utility to find out what registry settings are made by FileTypesMan:

http://technet.microsoft.com/en-us/sysinternals/bb896645
Process Monitor v2.95
0
 

Author Closing Comment

by:piemckay
ID: 35746117
The tool worked for me. Suggest you use the link on my reply though as the other reports a security risk.
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article describes a serious pitfall that can happen when deleting shapes using VBA.
This article describes how you can use Custom Document Properties to store settings and other information in your workbook so that they will be available the next time you open the workbook.
This Micro Tutorial demonstrates how to create Excel charts: column, area, line, bar, and scatter charts. Formatting tips are provided as well.
This Micro Tutorial will demonstrate the scrolling table in Microsoft Excel using the INDEX function.

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question