• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 454
  • Last Modified:

Nic Config issues with singe Hyper V Server

So I have a single R710 server with a 4port nic running Server 2008 R2 Ent. core.  Each port has a static IP assigned in winodws.  When I launch the Hyper-V Manger and try to create external networks I am geting binding errors.  I have left the first NIC alone for managment of server but trying to the 2nd-4th nic is not working well.  I either get errors saying the remote server could not complete the operation due to a RPC call or that the nic is already bound to a different virtaul adapter even though none exist.  Once the virtual network setup fails I lose connection the the remote computer with a message stating the that RPC services aren't running.  Sometimes a reboot will restore it other times i have to remove the Hyper-V role and add it back.   I can still use remote desktop to access the machine but remote connections with Server manager drop as well.

First of an i setting the nics correctly by giving them static IP's in windows?  

Second, why am i getting binding errors?  

Third, is there a way to wipe the slate clean with out a reinstall?

Any help woudl be great!

Thanks!!
0
hamel01
Asked:
hamel01
  • 5
  • 5
1 Solution
 
Svet PaperovIT ManagerCommented:
If you don’t need management access on NICs 2 to 4 you can disable it. In that case you won’t have to set static IP addresses, and these adapters will not participate in the normal network communication with the Host; they will be reserved only for the virtual machines.

In Hyper-V Manager, Virtual Network Manager, you need to clear the “Allow management operating system…” check box for adapters 2 to 4 as it is shown on the picture below.
 Clear Allow management operating system
0
 
hamel01Author Commented:
So your saying i can disable the network adapters in the host os but they will still be available for use in the hyper-v manager?
0
 
hamel01Author Commented:
If thats the case how do you disable the nic in Core?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Svet PaperovIT ManagerCommented:
No, disable the management traffic through the Virtual Network Manager be clearing Allow management operating system, see the png picture, pls.
0
 
hamel01Author Commented:
Ok thats what i thought you meant but wanted to make sure (That is what i as doing as well).  So it is correct that I have staic IP's assigned the all the nic ports on the host OS side?  If i do a ipconfig /all on the host OS I get a bunch of Tunnel adapter ISATAP.  Could those be causing my problem?
0
 
Svet PaperovIT ManagerCommented:
Can’t say if this is the exact cause of the problem but it could be if the host server has more than one network connection on the same subnet. So, this will be the first thing to check.  
0
 
hamel01Author Commented:
Ok but to answer my other question:  Should all 4 nic's have an IP address staticly assigned to them in the host OS?  Currently they do and are all on the same subnet.
0
 
Svet PaperovIT ManagerCommented:
No, it is not correct. But when you clear that checkbox in the Virtual Network Manager the adapter will disappear from the host. Do that for adapters 2 to 4 while keeping one for management purposes and you should be OK.
0
 
hamel01Author Commented:
Ok so what you are saying is exactly what i have done.  But i get the binding errors or i lose connection to the remote computer.
0
 
Svet PaperovIT ManagerCommented:
OK, I understand. If the “Allow management operating system…” check box is cleared the only binding that should be left enabled on the adapter is “Microsoft Virtual Network Switch Protocol”; all other bindings should be disabled, including the IPv4.

If the configuration is correct, when you run ipconfig, you should be able to see only one adapter named “Local Area Connection” (or similar) with an IP address. This adapter will have all other bindings enabled except “Microsoft Virtual Network Switch Protocol”.
0
 
walter_christianCommented:
Dude

You really should team those NICs to maximize your throughput and if you have a good switch that NIC team can be that much more effective. I use the same model servers as host with 8 NICs in a team and my network performance is Bad ass even with the crappy Dell switches.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now