• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1037
  • Last Modified:

Exchange 2003 and Android

Cannot get the built in mail app to sync properly.  Contacts and Mail will sync, but the Calendar always get an error saying "Connection socket timeout".

I have tried other Mail apps, and each has it's own set of problems.  The built in app seems to work the best, but the Calendar will not sync.

The phone is an HTC Inspire 4G, we are running Exchange 2003.  I have already ran through the ActiveSync setup found in the forums here.

We also sync an iPhone to the server, it syncs just fine, and if we run the Microsoft's tool to test the setup it passes.
0
itkamisama
Asked:
itkamisama
  • 13
  • 11
1 Solution
 
MegaNuk3Commented:
Install this and then test again:
http://support.microsoft.com/kb/957191
0
 
MegaNuk3Commented:
Have you also turned on HTTP KeepAlives in IIS and set it to at least 120 seconds?
0
 
itkamisamaAuthor Commented:
Installed Hot fix, and issue is still present.  HTTP KeepAlive is enabled and set at 180 seconds.
0
NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

 
MegaNuk3Commented:
Review your AV software as that us normally the culprit when some phones synch and others don't:
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html

Have a look at the background/proactive  scanning in the article above
0
 
itkamisamaAuthor Commented:
Added the recommended registry entry, listed in the link above.  I also added exchange to exclusion list of the anti-virus, and also tried disabling the resident shield.

Still trouble with calendar syncing.
0
 
MegaNuk3Commented:
Up http KeepAlives to 600 seconds, do IISReset and test again.

Is your server SBS 2003?
0
 
MegaNuk3Commented:
Are you getting any ActiveSync events recorded in the server's Application event log when it tries to synch the Calendar?
0
 
itkamisamaAuthor Commented:
No, we are using 2003 Standard Edition.
0
 
itkamisamaAuthor Commented:
I am getting a Warning referencing the account that is having trouble syncing.

Event ID: 3007

Exchange mailbox Server response timeout: Server: [server-name]
User: [user@domain]. Exchange ActiveSync Server failed to communicate
with the Exchange mailbox server in a timely manner.  Verify that the Exchange
mailbox Server is working correctly and is not overloaded.


Same trouble after increasing the server timeout to 600 seconds.
0
 
MegaNuk3Commented:
Even though you are not running SBS verify your IIS VDs and settings match:
http://support.microsoft.com/kb/937635
0
 
itkamisamaAuthor Commented:
Followed directions on the KB article.  Everything was set correctly, the only thing I noticed was that Exchange-OMA is not listed under IIS.  I do have OMA and Microsoft-Server-ActiveSync, settings for both matched what was listed under the KB article.

Could part of the problem be that Exchange-OMA is not listed?
0
 
MegaNuk3Commented:
Are you using forms based authentication on OWA? If so then you need an Exchange-oma directory.
0
 
itkamisamaAuthor Commented:
Not sure.  How do I check?

If I'm understanding correctly, by OWA you are referring to Outlook Web Access.  Which in Exchange 2003 is listed by the virtual directory Exchange.  Under the Exchange VD I have selected Integrated Windows Authentication and Basic Authentication.
0
 
MegaNuk3Commented:
Open ESM and find the Http virtual server then do properties on it and see if forms based authentication is enabled

Or  go to http://youserver/exchange if it let's you straight into your mailbox or doesn't display a logon web page then you aren't using FBA
0
 
itkamisamaAuthor Commented:
It displays a dialog box asking for credentials when you attempt to access http://servername/exchange.

When I check the Exchange Virtual Server under System Manager it shows that Forms Based Authentication is not enabled.
0
 
MegaNuk3Commented:
Ok, don't worry about the Exchange-oma directory then...
0
 
itkamisamaAuthor Commented:
From what I can tell everything is configured correctly. But I do keep getting these 3005 and 3007 errors in Event Viewer.  I've read that this could be related to performance issues.  When I look at the performance information under Task Manager both CPU and Memory usage look fine.

Am I missing here?
0
 
MegaNuk3Commented:
Try an iisreset and see if the phone works briefly or not.

Have you run ExBpA on there to do a health check?
0
 
itkamisamaAuthor Commented:
Does not work even after restart. Ran through ExBpA and everything looks good.  The only problem it mentioned was that the page file was set to more than the physical memory.
0
 
MegaNuk3Commented:
You can try creating the exchange-oma directory for ActiveSync to use and see if that fixes your problem:
http://support.microsoft.com/kb/817379
0
 
itkamisamaAuthor Commented:
This appears to have solved the issue with syncing the Calendar.
0
 
MegaNuk3Commented:
Excellent! I'll make a note of that solution...
0
 
itkamisamaAuthor Commented:
It was method 2 that I used to resolve the issue.  Manually creating the virtual directory exchange-oma, fixed the problem.  In my case at least.

Thanks for your help.
0
 
MegaNuk3Commented:
No problem
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 13
  • 11
Tackle projects and never again get stuck behind a technical roadblock.
Join Now