Runtime version in 3rd party controls

Hi,

I'm starting my first .Net WinForms application and I'm using two 3rd party components suite:
- DevExpress XtraEditors, the free short version
- PureComponets, got it on sale for $19

Both DevExpress dlls and PureComponents dlls show "Runtime Version" as v2.0.50727 in the properties windows.
All their dll's.

For PureComponents I can't speak a lot... actually nothing... but I liked the components and the price, with source code included was unbeatable.

Now, for DevExpress.... eventhough they say they support VS 2010, they're components are still a .net 2.0 binaries?

Well, if in my Winforms Application I set to target .Net 4.0... and this components are 2.0.. does it mean my users will have to have both 2.0 and 4.0 for their applications to run?
Will my application be using both .Net frameworks while the application is running?
Would it be better if I just target my application to use .Net 2.0, too?
(I don't think I'm using anything special right now that could not be available if I change it the older version)
LVL 1
fischermxAsked:
Who is Participating?
 
Todd GerbertConnect With a Mentor IT ConsultantCommented:
Okay, I made a simple test by building a Forms application targeted to .Net 4.0, and a Class Library targeted to .Net 2.0; the forms application references the class library and uses one of it's methods.

Then I installed only .Net Framework 4.0 on a clean install of Windows XP and the application ran fine. However, I could not run a application that was targeted only to .Net 2.0 - so my earlier comment was half-correct.

But the end result is that if your application is targeted to .Net 4.0, even if the third party component was written against an earlier .Net Framework, it should run fine on users' machines who have only .Net 4.0 installed.
0
 
iHadiConnect With a Mentor Commented:
Net 3.5/2.0 Applications do not automatically run on the .Net 4.0 runtime. You have to specify explicitly for your application that it should run on .Net 4.0 in your App.config by adding:

<configuration>
  <startup>
    <supportedRuntime version="v4.0" />
  </startup>
</configuration>

In case you have third party components you also have to mark them as being ready for 4.0:

<configuration>
   ...
   <runtime>
      ...
      <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
         ...
         <dependentAssembly>
            <assemblyIdentity name="AssemblyName" publicKeyToken="31bf3856ad364e35"/>
            <bindingRedirect oldVersion="3.5.0.0-3.5.0.0" newVersion="4.0.0.0"/>
         </dependentAssembly>
         ...
      </assemblyBinding>
      ...
   </runtime>
   ...
</configuration>
0
 
Todd GerbertIT ConsultantCommented:
I'm pretty sure that the .Net releases include all the previous versions - so if a user has .Net 4.0 installed they should be able to run applications built against 2.0, 3.0, 3.5, 4.0.  So no: your users won't need to install both runtimes separately, they'll just need to have .Net 4.0.

And you're going to want to keep your application targeted to .Net 4.0 - there are some performance enhancements in .Net 4.0 that'll help your application run a little bit quicker.
0
 
fischermxAuthor Commented:
Thank you very much!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.